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Lab Prerequisites  

Following prerequisites and setup must be complete for successful completion of the exercise: 

• You must be connected to the internet. 

• Signup for Power BI: Go to http://aka.ms/pbidiadtraining and sign up for Power BI with a business 

email address. If you cannot sign up for Power BI, let the instructor know. 

• If you have an existing account, please go to http://app.powerbi.com and Sign in using your 

Power BI Account. 

• At minimum, a computer with 2-cores and 4GB RAM running one of the following version of 

Windows: Windows 10, Windows 7, Windows 8 (64-bit preferred), Windows 8.1, Windows Server 

2008 R2, Windows Server 2012, Windows Server 2012 R2. 

• Microsoft Power BI Desktop requires Internet Explorer 9 or greater.  

• Verify if you have 32-bit or 64-bit operating system to decide if you need to install the 32-bit or 64-

bit applications.  

o Search for computer on your PC, right click properties for your computer.  

o You will be able to identify if your operating system is 64 or 32 bit based on “system type” 

as shown below.  

 

• Download the Power BI Content: Create a folder called DIAD on the C drive of your local machine. 

Copy all contents from the folder called Dashboard in a Day Assets on the flash drive to the DIAD 

folder you just created (C:\DIAD).  

• Download and install Power BI Desktop using any one of the options listed below: 

o If you have Windows 10, use Microsoft App Store to download and install Power BI Desktop 

app.  

o Download and install Microsoft Power BI Desktop from http://www.microsoft.com/en-

us/download/details.aspx?id=45331. 

 

 

 

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
http://www.microsoft.com/en-us/download/details.aspx?id=45331
http://www.microsoft.com/en-us/download/details.aspx?id=45331
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Document Structure  

   This document has two main sections: 

• Power BI Desktop: This section highlights the features available in Power BI Desktop and walks the 

user through the process of bringing in data from the data source, modeling and creating 

visualizations. 

• Power BI Service: This section highlights the features available in Power BI Service including the 

ability to publish the Power BI Desktop model to the web, creating and sharing dashboard and 

Power Q & A. 

The document flow is in a table format. On the left panel are steps the user needs to follow and in the 

right panel are screenshots to provide a visual aid for the users. In the screenshots, sections are 

highlighted with red boxes to highlight the action/area user needs to focus on. 

 

 

NOTE:  This lab is using real anonymized data and is provided by ObviEnce LLC. Visit their site to learn 

about their services: www.obvience.com .    
This data is property of ObviEnce LLC and has been shared for the purpose of demonstrating PowerBI 

functionality with industry sample data.   Any uses of this data must include this attribution to ObviEnce 

LLC.   

http://www.obvience.com/
http://www.obvience.com/
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Overview    
Introduction  
Today you will be learning various key features of the Power BI service. This is an introductory course 

intended to learn how to author reports using Power BI Desktop, create operational dashboards and share 

content via the Power BI Service.   

Data Set   
The dataset you will you use today is a sales and market share analysis.  This type of analysis is very 

common for the office of a Chief Marketing Officer (CMO).  Unlike the office of the Chief Financial Officer 

(CFO), a CMO is focused not only on company’s performance internally (how well do our products sell) but 

also externally (how well do we do against the competing products).  

The company, VanArsdel, manufactures expensive retail products that could be used for fun as well as 

work and it sells them directly to consumers nationwide as well as several other countries.   

Workshop Outline  
1. Power BI Desktop   

2. Power BI Service 

3. Bring your own data to build a dashboard 

4. Q&A 
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Power BI Desktop   
Power BI Desktop - Accessing Data  
In this section, you will import VanArsdel and its competitors USA sales data. Then you import and merging sales 

data from other countries.  

Power BI Desktop - Get Data  
Let’s start with looking at the data files. The 

dataset contains sales data of VanArsdel 

and other competitors. We have 7 years of 

transaction data by day, product and zip 

code for each manufacturer. We are going 

to analyze data from 7 countries. 

 

USA sales data is in a csv file located in 

/Data/USSales folder. 

 

Sales of all other countries is in 

/Data/InternationalSales folder. Each 

country’s sales data is in a csv file in this 

folder. 

 

Product, Geography and Manufacturer 

information is in an excel file in 

/Data/USSales/bi_dimensions.xlsx. 

 

1. Open 

/Data/USSales/bi_dimensions.xlsx. 

Notice the first sheet has Product 

information. The sheet has a header and 

product data is in a named table. Also 

notice Category column has a bunch of 

empty cells. 

 

Manufacturer sheet has data laid out 

across the sheet and with no column 

headers and it has a couple of blank rows 

and a note in row 7. 

Geo sheet has geography information. The 

first couple of rows has data details. Actual 

data starts from row 4. 

We will start by connecting to data from 

these different files and perform data 

cleaning and transformation operations. 
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2. If you don’t have the Power BI Desktop 

open, launch it now. 

3. Select Already have a Power BI 

Account? Sign in option. 

4. Sign in using your Power BI credentials. 

5. Startup screen opens. Click on X on the 

top right corner of the dialog to close 

it. 

 
 
 

 
Let’s set up the locale to US English, to 

make it convenient to go through the rest 

of this lab. 

 

6. From the ribbon, select File -> Options 

and settings -> Options. 

7. In the left panel of Options dialog, 

select Regional Settings. 

8. From the Locale drop down select 

English (United States). 

9. Select OK to close the dialog. 

 
First step is to load data to Power BI 

Desktop. We will load USA Sales data 

which is in comma separated value (CSV) 

files. 

 
10. From the ribbon, select Home -> Get 

Data. 

11. Select Text/CSV. 

 

Note: Power BI Desktop has the capability 

to connect to 70+ data sources. We are 

using csv and excel data files in this lab for 

simplicity. 

  

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-data-sources/
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12. Browse to DIAD\Data\USSales folder 

and select sales.csv.   

13. Click Open. 

 

 
Power BI detects the data type of each 

column. There are options to detect the 

data type based on the first 200 rows or 

based on the entire dataset or not detect 

it. Since our dataset is large and it will take 

time and resources to scan the complete 

data set, let’s leave the default option of 

selecting dataset based on the first 200 

rows. 

After completing your selection, you have 

three options – Load, Edit or Cancel.   

• Load, loads the data from the 
source into Power BI Desktop for 
you to start creating reports.   

• Edit allows you to perform data 
shaping operations such as merging 
columns, adding additional 
columns, changing data types of 
columns as well as bringing in 
additional data.   

• Cancel gets you back to the main 
canvas.   

 
14. Click Edit as shown in the screenshot. 

A new window opens. 
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You should be in the Query Editor window 

as shown in the screenshot to the right. 

Query Editor is used to perform data 

shaping operations. Notice the sales file 

you connected to shows as a query in the 

left panel. You see a preview of the data in 

the center panel. Power BI predicts data 

type of each field (based on the first 200 

rows) which is indicated next to the 

column header. In the right panel, steps 

that Query Editor performs are recorded. 

 
Note: You will be bringing in sales data 

from other countries as well as performing 

certain data shaping operations. 

 
15. Notice Power BI has set Zip field to 

data type Whole Number. To ensure 

that Zip codes which start with zero 

don’t lose the leading zero, we will 

format them as text.  Highlight the Zip 

column. From the ribbon, select Home 

-> Data Type and update it to Text. 

16. Change Column Type dialog opens. 

Select Replace Current button which 

overwrites Power BI’s predicted 

datatype. 

 
 

 

 

Now let’s get the data that is in excel 

source file. 

 
17. From the ribbon, select Home -> New 

Source -> Excel. 

    

IMPORTANT! 

Changing the 

data type is a big 

deal to use later 
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18. Browse to DIAD\Data\USSales folder 

and select bi_dimensions.xlsx. 

 
Navigator dialog opens. 

 
19. Navigator dialog lists 3 sheets that are 

in the excel workbook. It also lists the 

Product named table. Select product 

from the left panel and in preview 

panel notice the first row is the 

header. This is not part of the data. 

20. Unselect product from the left panel. 

Select Product_Table. Notice this has 

only the contents of the named table. 

This is the data we need. 

 

Note: Table names are differentiated from 

Worksheet names by using different icons. 
 

21. From the left panel, select geo. In the 

preview panel notice the first couple 

of rows are headers that are not part 

of the data. We will remove them 

shortly. 

22. From the left panel, select 

manufacturer. In the preview panel 

notice the last couple of rows are 

footers that are not part of the data. 

We will remove them shortly. 

23. Select OK. (Make sure Product_Table, 

geo and manufacturer are selected in 

the left panel) 

Notice all 3 sheets are added as queries in 

the Query Editor. 

 

 

Power BI Desktop - Adding additional data  
International subsidiaries have agreed to provide their sales data so that the company’s sales can be analyzed 

together.  You’ve created a folder where they will each put their data. 
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To analyze all the data together you will 

want to import the new data from each of 

the subsidiaries and combine it with the 

US Sales you loaded earlier. 

 
24. Click on the New Source drop down 

in the Home menu tab of the Query 

Editor. 

25. Select More… as shown in the figure. 

 
Get Data dialog opens.      

26. In the Get Data dialog select Folder as 

shown in the diagram. 

27. Click Connect.  

    

Folder dialog opens. 

28. Click Browse… button. 

29. In the Browse for Folder dialog 

navigate to the location where you 

unzipped the class files. 

30. Open the DIAD folder. 

31. Open the Data folder. 

32. Select the InternationalSales folder. 

33. Click OK (to close the Browse for 

Folder dialog box). 

34. Click OK (to close the Folder dialog 

box). 

 
Note: This approach uses folders instead 

of individual files. This will load all files in 

the folder.  This is useful when you have a 

group that puts files on an ftp site each 
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month and you are not always sure of the 

names of the files or the number of files. 

All the files must be of the same file type 

with columns in the same order. 

Dialog displays the list of files in the 

folder. 

 

35. Since we want to combine data, click 

Combine & Edit. 

 

Note: Date accessed, Date modified and 

Date created might be different compared 

to the dates displayed in the screenshot. 

 

Combine Files dialog opens. By default, 

Power BI again detects the data type 

based on the first 200 rows. 

Notice there is an option to select various 

file Delimiters. The file we are working 

with is Comma delimited, so let’s leave 

Delimiter option as Comma. 

There is also an option to select each 

individual file in the folder (using Example 

File dropdown) to validate the format of 

the files. 

 

36. Select OK. 

 
 

You will be in the Query Editor window 

with a new query called 

InternationalSales.   

37. If you do not see the Queries pane on 

left, click on the > icon to expand.  

38. If you do not see the Query Settings 

pane on the right as shown in the 

figure, click on View in the ribbon and 

click Query Settings to see the pane.  

39. Click on the Query InternationalSales.  
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Notice that column Zip is of type Whole 

Number. Based on the first 200 rows 

Power BI thinks Zip is of type Whole 

Number. But zip code could be alpha 

numeric in some countries or leading 

zeros (similar to USA data). If we do not 

change the data type, we will see an error 

when we load the data shortly. So, let’s 

change Zip to data type Text. 

 

40. Highlight the Zip column and change 

the Data Type to Text. 

41. Change Column Type dialog opens. 

Select Replace Current button. 

 

 

In Queries panel, notice Transform File 

from InternationalSales folder is created. 

This contains the function used to load 

each of the files in the folder. 

 

If you compare InternationalSales and 

sales table, you will see the 

InternationalSales table contains two 

new columns, Source.Name and Country. 

 
 

42. We do not need Source.Name 

column. Select Source.Name column. 

From the ribbon, select Home -> 

Remove Columns -> Remove 

Columns. 

 

 

IMPORTANT! 

Changing the data 

type is a big deal 

to use later 
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43. Click on the drop down next to 

Country column to see the unique 

values.  

44. You will only see Australia as shown 

in the figure. Click on Load more to 

validate you have data from various 

countries included. 

 

You will see the countries, Australia, 

Canada, Germany, Japan, Mexico and 

Nigeria.  

 

45. Click OK. 

 

Note: You can perform various types of 

filters, sorting operations using the drop 

down to verify the imported data.  

 

 

 

Power BI Desktop – Data Preparation 
In this section, we will explore methods to transform data in the data model. Transforming the data by renaming 

tables, updating data types, and appending tables together ensures that the data is ready to be used for reporting. 

In some instances, this means cleaning the data up so that similar sets of data are combined. In other instances, 

groups of data are renamed so that they are more recognizable by end users and simplifies report writing. 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-shape-and-combine-data/
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Power BI Desktop - Renaming tables 
The Query Editor window should appear 

as shown in the diagram.  

• If formula bar is disabled, you can turn 

on the formula bar from the View 

ribbon. This enables you to see the 

“M” code generated by each click on 

the ribbons. 

• Select the options available on the 

ribbon – Home, Transform, Add 

Column and View to notice the 

various features available.  

 
1. Under Queries panel, minimize 

Transform Files from InternationalSales 

folder. 

2. Select each query name in the Other 

Queries section. 

3. Rename them in the Query Settings -> 
Properties section as shown below: 

 

Initial Name Final Name 

sales Sales 

geo Geography 

manufacturer Manufacturer 

Product_Table Product 

InternationalSales International 
Sales 

  
Note: It is best practice to give descriptive 
query names and column names. These 
names are used in visuals and in Q&A 
section, which is covered later in the lab. 
 

    

 

 

Power BI Desktop – Using Fill feature  
Some of the data provided is not in the right format. Power BI provides extensive transformation capabilities to 

clean and prepare the data to meet our needs. Let’s start with Product query. Notice that Category column has a lot 

of null values. Looks like there are values in Category column only when the value changes. We need to fill it down 

to have values in each row. 
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4. From the left panel, select Product 

Query.  

5. Select Category column. 

6. From the ribbon select Transform -> Fill 

-> Down. 

 
Notice now all the null values are filled 
with the appropriate Category values. 

 
  

 
 

Power BI Desktop – Using Split feature  
 

In Product query, notice Product column. Looks like two fields are concatenated into one field with a pipe (|) 

separator. Let’s split them into two columns. This will be useful when we build visuals, so we can analyze based on 

both fields. 

7. From the left panel, select Product 

Query.  

8. Select Product column. 

9. From the ribbon select Home -> Split 

Column -> By Delimiter. Split Column by 

Delimiter dialog opens. 

10. In the dialog, make sure Custom is 

selected in the Select or enter delimiter 

dropdown. 

Note: Select or enter delimiter dropdown 

has some of the standard delimiters like 

comma, colon, etc. 

11. Notice in the text area, there is a 

hyphen (-). Power BI assumes we want to 

split by hypen. Remove hyphen symbol 

and enter pipe symbol (|) as shown in the 

screenshot. 

12. Select OK. 

 

Note: If the delimiter occurs multiple 

times, Split at section provides option to 
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split only once (either left most or right 

most) or the column can be split on each 

occurrence of the delimiter. 

 

In this scenario delimiter occurs only 

once, hence Product column is split into 2 

columns. 

 

Power BI Desktop – Using Rename Column feature  
Let’s rename the columns. 

13. Select Product.1 column. Right click 

next to the column name. 

14. Select Rename from the selection 

dialog. 

15. Rename the field to Product. 

16. Similarly rename Product.2 to 

Segment. 

 
   

 

Power BI Desktop – Using Column From Examples feature  
 

In Product query, notice that the Price column. You will see price and currency concatenated into one field. To do 

any calculations we just need the numeric value. It will be good to split this field into two columns. We can use the 

split feature like earlier or we can use Column From Examples. Column From Examples is handy in scenarios where 

the pattern is more complex than a delimiter. 
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17. From the left panel, select Product 

Query.  

18. From the ribbon, select Add Column -

> Column From Examples -> From All 

Columns. 

19. In the first row of Column1 enter the 

first Price value which is 412.13 and click 

enter. 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

20. Double click column header Text 

After Delimiter to rename it. 

21. Rename the column to MSRP. 

22. Click OK to apply the changes. 

 
   

Notice MSRP field is of data type text. It 

must be a decimal. Let’s change it. 

23. Select ABC in MSRP column. 

24. From the selection dialog, select Fixed 

Decimal Number. 

 

Notice all the steps we performed on the 

Product query are being recorded under 

APPLIED STEPS in the right panel.  

 

Similarly, let’s create a currency column. 

25. From the left panel, select Product 

Query.  

26. From the ribbon, select Add Column -

> Column From Examples -> From All 

Columns. 

27. In the first row of Column1 enter the 

first Currency value as USD and click enter 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

28. Double click column header Text 

Before Delimiter to rename it. 

29. Rename the column to Currency. 

30. Click OK to apply the changes. 
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Now that we have split Price into MSRP 

and Currency columns, we don’t need 

Price column. Let’s remove it. 

31. From the left panel, select Product 

Query.  

32. Right click next to Price column. 

33. Select Remove. 

 

Power BI Desktop – Using Add/Remove Rows feature  
 

In Geography query, notice that first two rows are informational. It is not part of the data. Similarly, in Manufacturer 

query the last couple of rows are not part of the data. Let’s remove them so we have a clean dataset. 

34. In the left panel, select Geography 

query. 

35. From the ribbon, select Home -> 

Remove Rows -> Remove Top Rows. 

36. Remove Top Rows dialog opens. Enter 

2 in the text box, since we want to 

remove the top informational data row 

and the blank 2nd row. 

37. Select OK. 

 

Notice the first row in Geography query 

now is the column header. So let’s make it 

a header. 

38. With Geography query selected in the 

left panel, from the ribbon select Home -> 

Use First Row as Headers. 

Notice column Zip is of data type number. 

Let’s change it to text as we did earlier. If 

we don’t we will see errors when we load 

the data. 

39. Select 123 next to Zip Column. From 

the dialog, select Text. 

40. Select Replace Current in the Change 

Column Type dialog. 
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41. From the left panel, select 

Manufacturer query. Notice the bottom 3 

rows are not part of the data. Let’s 

remove it. 

42. From the ribbon, select Home -> 

Remove Rows -> Remove Bottom Rows 

43. Remove Bottom Rows dialog opens. 

Enter 3 in Number of rows text box. 

44. Select OK. 

 

Power BI Desktop – Using Transpose feature  
 

45. From the left panel, select 

Manufacturer Query. Notice 

ManufacturerID, Manufacturer and Logo 

data is laid across in rows. And the header 

is not useful. We need to transpose the 

table to meet our needs. 

46. From the ribbon select Transform -> 

Transpose.  

 

Notice this transposes the data into 

columns. Now we need the first row to be 

the header.  
  

47. From the ribbon select Home -> Use 

First Row As Headers. 

 
Notice now Manufacturer table is laid out 
the way we need it with a header and 
values along columns. 
Notice on the right panel under APPLIED 
STEPS you will see the list of 
transformations and steps that have been 
applied.  
You can navigate through each change 
made to the data by clicking on the step. 
Steps can also be deleted by clicking on 
the X that appears to the left of the step.  
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The properties of each step can be 
reviewed by clicking on the gear to the 
right of the step.  

 

Power BI Desktop – Using Append and Conditional Column feature  
To analyze the Sales of all countries, it is 

convenient to have a single Sales table. 

Hence you want to append all the rows 

from International Sales to Sales.   

48. Select Sales in the Queries window in 

the left panel as shown in the figure. 

49. From the ribbon select Home -> 

Append Queries. 

Append dialog opens. There is an option 

to append Two tables or Three or more 

tables. Leave Two tables selected since 

we are appending just two tables. 

50. Select International Sales from the 

drop down and click OK. 

 

You will now see a new column in the 

Sales table called Country.  Since 

International Sales had the additional 

column for Country, Power BI Desktop 

added the column to the Sales table when 

it loaded the values from International 

Sales. 

You see null values in the Country column 

by default for the Sales table rows 

because the column did not exist for the 

table with USA data. We will add the 

value “USA” as a data shaping operation.  

51. From the ribbon select Add Column -> 

Conditional Column. 
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52. In the Add Conditional Column dialog, 

enter name of the column as 

“CountryName”. 

53. Select Country from the Column 

Name dropdown. 

54. Select equals from the Operator 

dropdown. 

55. Enter null in the Values text. 

56. Enter USA in the Output text. 

57. Select the dropdown under Otherwise 

and pick Select a column option. 

58. Select Country from the column 

dropdown. 

59. Click OK. 

This reads, if Country equals null then the 

value is USA else value is that of Country. 

  

60. You will see the CountryName column 

in the Query editor window. 

 

The original Country column is only 

required as a temporary column. It is 

not required in the final table for 

analysis and can be removed.    

61. Right click on the Country column and 

select Remove as shown in the figure. 

We can now rename CountryName 

column to Country.  

62. Right click on the CountryName 

column and rename to Country. 

63. Using Home -> Data Type, change the 

data type of the Country column to type 

Text. 

64. Using Home -> Data Type, change the 

data type of the Revenue column to type 

Fixed Decimal Number since it is a 

currency field. 

When the data is refreshed, it will process 

through all the “Applied Steps” that you 

have created. 
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The newly named Country column will 
have names for all countries, including the 
USA.  
You can validate this by clicking on the 
drop down next to Country column to see 
the unique values.  
 
65. At first, you will only see USA data. 

Click on Load more to validate you have 

data from all 7 countries.  

66. Click OK to close this filter.  

Typically, when exploring data, we load a 

subset of data. There are multiple ways to 

do this. From the ribbon, select Home -> 

Keep Rows -> Keep Top Rows OR Home -

> Keep Rows -> Keep Bottom Rows OR 

Home -> Keep Rows -> Keep Range of 

Rows. You can use any of these options to 

filter down to a subset of data. 

Our dataset has data from 2012 to 2018. 

For our analysis we want to start with the 

last 3 years of data (2016-2018). We don’t 

know how many rows. We can filter by 

year to get the subset. 

67. Select the arrow next to Date in Sales 

Query. 

68. Select Date Filters -> In the Previous… 

69. Filter Rows dialog opens. Enter 3 in 

the text box next to is in the previous. 

70. Select years from the dropdown. 

71. Select OK. 
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Now that International Sales data is 
appended to Sales, we don’t need the 
International Sales table to load to the 
data model. Let’s prevent International 
Sales table from loading to the data 
model.  
 
72. From the Queries panel on the left, 

select International Sales query. 

73. Right click and select Enable Load. 

This will disable loading International 

Sales. 

 

Note: The appropriate data from the 

International Sales table will load into the 

Sales table each time the model is 

refreshed. By removing the International 

Sales table, we are preventing duplicate 

data from loading into the model and 

increasing its file size. In some instances, 

storing very large amounts of data affects 

the data model performance. 

 

   

74. From the ribbon select View -> Query 

Dependencies. 

 

This opens Query Dependencies dialog. 

The dialog shows the source of each of 

the queries and dependencies. E.g. We 

see that Sales query has a csv file source 

and it has a dependency on International 

Sales query. This is a useful self-document 

that can be used to share knowledge with 

your team members. 

 

75. Select Close in the dialog. 

 

Query Dependencies view can be zoomed 
in and out as needed. 
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You have successfully completed import 
and data shaping operations and are 
ready to load the data into the Power BI 
Desktop data model which allows you to 
visualize the data.  
 
76. Click on File -> Close & Apply. 

   

All the data will be loaded in memory 
within Power BI Desktop. You will see the 
progress dialog with the number of rows 
being loaded in each table as shown in 
the Figure.  
 
Note: It may take several minutes to load 
all the tables. 
 
77. Select File -> Save to save the file 

after the data loading is complete. Name 

the file as “MyFirstPowerBIModel”. Save 

the file in \DIAD\Reports folder. 

  

  

 

Power BI Desktop – Data Modeling and Exploration 
In this section, we will learn the key parts of the Power BI desktop, to model and explore the data and build visuals. 

Power BI Desktop - Layout   
You will land on the main Power BI 

Desktop window. Let’s get familiar with 

the distinct sections available in the 

Power BI Window. 

 

1. On the top, you see the Home tab 

where the most common operations 

you perform are available. 

2. View tab has options to format the 

page layout.  

3. Modeling tab in the ribbon enables 

additional data modeling capabilities 

like adding custom columns and 

calculated measures.   

 
 

 

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-query-overview/
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4. Help tab provides self-help options like 

guided learning, training videos and 

links to online communities, partner 

showcase, solution templates. 

    

5. The Fields window on the right panel, 

is where you will see the list of tables 

which were generated from the 

queries. Click the   icon next to a 

table name to expand to the field list 

for that table. 

6. Visualizations panel on the right allows 

you to select visualizations, add values 

to the visuals and add columns to the 

axes or filters. 

7. The center white space is the canvas 

where you will be creating visuals. 

8. On the left side, you have three icons, 

Report, Data and Relationships. If you 

hover over the icons, you can see the 

tool tips. Switching between these 

allows you to see the data and the 

relationships between the tables. 

9. Click on the Data icon. Expand Sales 

table in the Fields as shown in the 

figure 

Scroll up and down to notice how fast you 

can navigate through ~ 3 Million rows.   
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10. Click on the Relationships icon on the 

left panel of Power BI Desktop. 

You will see the tables you have imported 

along with some Relationships. The 

Power BI Desktop automatically infers 

relationships between the tables. 

o Relationship is created between 

Sales and Product tables using 

ProductID column. 

o Relationship is created between 

Product and Manufacturer tables 

using ManufacturerID column. 

Power BI Desktop supports 1 to many or 1 

to 1 relationships between the tables. 

This means one of the tables involved in 

the relationship should have a unique set 

of values. 

Notice there is no relationship between 

the Geography and Sales tables. If you 

want to explore sales data across state or 

city or country, you will need to setup the 

relationship between the Geography and 

Sales tables. You will create the 

relationship shortly. 

Note: Tables may not appear as shown in 

the figure. You can zoom in and out of the 

Relationships page by dragging the zoom 

slider in the bottom right corner of the 

window. Also, if want to ensure you are 

seeing all the tables, use the fit to page 

icon: . Drag and move the tables to 

appear as shown in the figure. 
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We loaded data from different 

countries. So, let’s start with analyzing 

sales by country. 

1. Click on the Report icon on the left 

panel to navigate to the Report view. 

2. Select the Clustered column chart 

visual in Visualizations as shown in the 

screenshot.  

 

3. From the FIELDS section, expand 

Geography table and click the 

checkbox next to the Country field. 

4. From the FIELDS section, expand 

Sales table and click the checkbox next 

to the Revenue field. 

5. Resize the visual as needed by 

dragging the edges. 

Notice revenue of each country is the 

same. This is because there is no 

relationship between Sales and 

Geography tables. Let’s create one. 

Note: You now need to set up the 

correct relationship between these 

tables.  

To create a relationship between the 

two tables we need a “joining” or 

“relating” column.   

 

6. Click on the Relationships icon on 

the left panel to navigate to the 

Relationship view. 

7. Sales data is by Zip code. Hence, we 

need to connect Zip column from Sales 

table with Zip column in Geography 

table. You can do this by dragging the 

Zip field in Sales table and connecting 

the line with Zip field in Geography 

table. 

 

You will notice Create relationship 

dialog opens with a warning message 

at the bottom stating the relationship 

has a many-many cardinality. The 

reason for the warning is that we don’t 
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have unique Zip values in Geography. 

This is because multiple countries 

could have the same Zip code. Let’s 

concatenate Zip and Country columns 

to create a unique value field. 

8. Select Cancel in Create relationship 

dialog. 

We need to create a new column in 

both the Geography table and the Sales 

table that combines “Zip” and 

“Country”. Let us start by creating a 

new column in the Sales table.  

9. Click on the Report icon on the left 

panel to navigate to the Report view. 

10. In the Fields section, click on the 

ellipsis next to Sales table. Select “New 

Column” as shown in the figure. 

You will see a formula bar appear as 

shown in the screenshot to help create 

this new column. 

11. We can combine or concatenate 

the Zip and Country columns into a 

new column called ZipCountry 

separated by a comma. Let us create 

this column called ZipCountry using the 

following calculation in the editor. 

 

ZipCountry = Sales[Zip] & "," & 

Sales[Country] 

12. Once you are done entering the 

formula click in the check mark on the 

left side of the formula bar. 

 

  
 

    

 

 

 

 

You will notice that as you type the 

expression the Power BI desktop guides 

you to choose the right columns using a 

Technology called Intellisense. As you 

type half way through you can select 

the right column by double clicking on 

it using your mouse or by continuing to 

hit tab until you see the correct name.  

The language you used to create this 

new column is called DAX (Data 

    

 
 

 

 

IMPORTANT! 

If you get an error 

creating a new column 

here, make sure your Zip 

column is the Text Data 

Type. 

If you still have 

problems, ask! 
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Analysis Expression) which is very 

similar to writing expressions in Excel 

where you are concatenating the two 

columns (Zip and Country) in each row 

by using the “&” symbol.  

You will see a new column ZipCountry 

in Sales table. The icon with a (fx) 

indicates you have a column that 

contains an expression, also referred to 

as calculated column.  

You can also create a new column by 

selecting the table and then clicking on 

Modeling -> New Column from the 

ribbon. Let us use this method to 

create a “ZipCountry” column in the 

Geography table.  

 

 

 

   

13. From Fields section, select 

Geography table and from the ribbon 

select Modeling -> New Column as 

shown in the figure. 

14. Formula bar appears. Enter the 

following DAX expression in the 

formula bar:  

ZipCountry = Geography[Zip] 

& "," & Geography[Country]  

You will see a new column ZipCountry 

in Geography table. The final step is to 

setup the relationship between the two 

tables using the newly created 

“ZipCountry” columns in each of these 

tables. 
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15. Click on the Relationships icon on 

the left panel to navigate to the 

Relationship view. 

16. Drag ZipCountry field from Sales 

table and connect it to ZipCountry field 

in Geography table. 

Now we have successfully created a 

relationship. The number 1 next to 

Geography indicates it is on the one 

side of the relationship and * next to 

Sales indicates it is on the many side of 

the relationship. 
 

17. Click on the Report icon on the left 

panel to navigate to the Report view. 

Notice the clustered column chart we 

created earlier. It shows different sales 

for each country. USA has the most 

sales followed by Australia and Japan.  

By default, it is sorted by Revenue. 

18. Click on the ellipsis on the top right 

corner of the visual. 

Notice there is option to Sort by 

Country as well.  
 

Now let’s analyze Sales by Country by 

Manufacturer and see if we get more 

insights. 

19. With the Clustered column chart 

selected, from the Fields section 

expand Manufacturer table. 

20. Drag and drop Manufacturer field 

to Legend section. 

 

There are many manufacturers and 

clustered column chart does not 

represent the information well. Let’s 

change the visual. 
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21. With the Clustered column chart 

selected, from the VISUALIZATIONS 

section select Stacked column chart 

visual. 

22. Resize the visual as needed. 

 

Now we can figure out the top 

manufacturers by country. It will be 

nice to narrow down to the top 5 

competitors to better analyze the data.  

 

23. With Clustered column chart 

selected, scroll down to the Visual level 

filters section under VISUALIZATIONS 

panel. 

24. Expand Manufacturer under Visual 

level filters. 

25. From the Filter Type drop down 

select Top N. 

26. Enter 5 in the text box next to Top. 

27. From the FIELDS section expand 

Sales table. 

28. Drag and drop Revenue field to By 

value section. 

29. Select Apply filter. 

 

Notice now the visual is filtered to 

display the Top 5 manufacturers by 

Revenue. We see that VanArsdel has 

higher percentage of sales in Australia 

compared to other countries. 
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Let’s see if there is another way to 

build this visual. 

30. Click on the white space in the 

canvas and from the ribbon select 

Home -> Ask A Question. 

31. In the dialog start typing Top 5 

Manufacturer. Notice a table with the 

top 5 manufacturers is displayed. 

32. Continue typing Top 5 

Manufacturer by country by revenue. 

Notice a bar chart is created. 

33. Continue typing Top 5 

Manufacturer by country by revenue 

as stacked column chart. Notice we 

can create the same visual we did 

earlier by typing the question. 

34. With the visual selected, under 

VISUALIZATIONS section, scroll down 

to Visual level filters. Expand 

Manufacturer. Notice the Top N filter is 

applied. 

35. We have two of the same visuals, 

so let’s delete this one. Hover over the 

visual and select the ellipsis on the top 

right corner. Select Remove. 

 

We are interested in the top 5 

competitors by revenue. Let’s group 

them so we don’t have to add a filter in 

every visual.  

Before we do that let’s remove the Top 

5 visual level filter. 

 

36. With Clustered column chart 

selected, scroll down to the Visual level 

filters section in VISUALIZATIONS 

panel. 

37. Expand Manufacturer under Visual 

level filters. 

38. Hover over and select the Clear 

filter icon (erase) next to Manufacturer 

field.  
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39. From the FIELDS section expand 

Manufacturer table. 

40. Click on the Manufacturer field 

name (note: do not check the 

checkbox). 

41. From the ribbon select Modeling -> 

New Group. Groups dialog opens. 

42. In the Ungrouped values section, 

using Ctrl key, select Aliqui, Currus, 

Natura and Pirum. 

43. Select Group button. Notice a new 

group is added in the Groups and 

members section. 

44. Double click the newly created 

group and rename it to Top 

Competitors. 

45. Select VanArsdel from the 

Ungrouped values section and select 

Group button to create VanArsdel 

Group. 

46. Select the check box Include Other 

group. This will create an Other group 

which will include all the other 

manufacturers. 

47. Select OK to close Groups dialog. 

 

48. With the Stacked column chart 

selected, click on the X next to 

Manufacturer in the Legend section. 

This will remove Manufacturer. 

49. From the FIELDS section, drag the 

newly created Manufacturer (groups) 

to the Legend section. 

 

Now we can clearly see that VanArsdel 

has nearly 50% share in Australia.   
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50. Hover over VanArsdel section of 

the Australia column. You will see a 

tooltip with the Revenue. 

51. Hover over Top Competitors 

section of Australia column to get the 

Revenue value. 

 

Let’s find a better way to view the data 

without creating a new visual. 

 

52. Hover over one of the columns and 

right click. 

53. Select Show Data. 

You will be in Focus mode with the 

chart displayed on top and the data 

displayed below. It is easy to see that 

VanArsdel has a big percent of the 

Australian market. 

54. You can use the icon on the top 

right corner to switch to vertical 

layout. In this layout you will view the 

chart on the left and data on the right 

panel. 

55. Select Back to Report to go back to 

Report canvas. 

 

 

56. There is also an option to see the 

records. Hover over one of the columns 

and right click. 

57. This time select See Records. 

You will see the detailed records. 

58. Select Back to Report to go back to 

Report canvas. 

 

Note: See Records and Show Data 

options are also available in the ribbon 

under Data/Drill menu option. 
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Let’s remove Manufacturer from the 

Legend and create a visual which 

represents Revenue by Manufacturer 

and check if it will help with any new 

insights. 

59. With the Stacked column chart 

selected, click on the X next to 

Manufacturer (groups) in the Legend 

section. This will remove Manufacturer. 

 

Let’s use Ask a Question feature to 

create Revenue by Manufacturer 

visual. 

60. Click on the white space in the 

canvas. From the ribbon, select Ask A 

Question. 

61. In the dialog, type Revenue. Notice 

a card visual is created with Total 

Revenue. 

62. Continue typing… Revenue by 

Manufacturer. Notice a bar chart is 

created. 

63. Continue typing… Revenue by 

Manufacturer as Treemap. 

64. Resize the visual as needed. 

We have Revenue by Manufacturer. 

Let’s figure out the interaction 

between the Stacked column chart and 

the Treemap visuals. 

 

65. Click on USA column in the Stacked 

column chart and notice the 

Highlighted section of Treemap 

updates. 

66. Click on Australia column in the 

Stacked Column chart and notice the 

Highlighted section of Treemap 

updates. 

67. Similarly, select VanArsdel in the 

Treemap and notice Stacked column 

chart is filtered. This confirms that 

VanArsdel has a big percent of the 

Australian market. 
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68. To remove the filter select 

VanArsdel again. 

The interaction between visuals is 

called cross filtering. 

Previously we added Top 5 Visual level 

filter. Let’s add a filter to the Page 

level, so we are working with the Top 

Competitors and VanArsdel and filter 

out the other manufacturers. 

Page level filters apply to all the visuals 

on the page whereas Visual level filter 

applies to a visual. 

69. From the FIELDS section expand 

Manufacturer table. 

70. Drag Manufacturer (groups) field 

to Page level filters section under 

VISUALIZATIONS panel. 

71. Select Top Competitors and 

VanArsdel. 

 

Let’s add a visual that will provide sales 

information over time. 

72. Click on the white space in the 

canvas. From the FIELDS section, 

expand Sales table. 

73. Click the checkbox next to the Date 

field. Notice a Date Hierarchy is 

created. If Date hierarchy is not 

created, select the arrow next to Date 

field in the Axis well and select Date 

Hierarchy. 

74. Click the checkbox next to the 

Revenue field. 

Notice a Clustered column chart is 

created. Also notice in the Axis section, 

a date hierarchy is created. There are 

arrows on the top bar of the chart. This 

is used to navigate through the 

hierarchy. 
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75. Click on USA column in the 

Revenue by Country visual. Notice 

sales is on the upward trend over time. 

76. Click on Australia column in the 

Revenue by Country visual. Again, the 

trend is upwards. 

77. We see a similar scenario with 

Japan as well. 

With the current interaction the visuals 

are slicing the data. It will be nice to 

filter data across visuals. This might 

give us a better perspective. Let’s try 

that. 

 

 

78. Click on Australia column in the 

Revenue by Country visual. 

79. With the Revenue by Country visual 

selected, from the ribbon select 

Format -> Edit Interactions.  

Notice on the top right of the other 

two visuals we see new icons with the 

highlight icon selected. 

80. Select filter icon for both visuals. 

Notice now in both Revenue by Year 

and Revenue by Manufacturer data is 

filtered for Australia. 

 

81. Now select Revenue by Year visual. 

82. Select filter icon on the other two 

visuals. 

83. Similarly, select Revenue by 

Manufacturer visual and select filter 

icon on the other two visuals. 

Once you are done, all the visuals 

should be in filter mode. 

84. With the Revenue by 

Manufacturer visual selected, from the 

ribbon select Format -> Edit 

Interactions to remove the icons.  
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85. Click on VanArsdel in the Revenue 

by Manufacturer visual. Notice sales is 

on an upward trend over time. 

86. Click on Natura column in the 

Revenue by Manufacturer visual. 

Notice sales in 2018 for Natura was on 

a downward trend. 

Similarly, you can analyze other 

manufacturer’s performance. 

 

We had already noticed that VanArsdel 

has a big share of the market in 

Australia. Let’s check how VanArsdel 

has done over time in Australia. 

87. Click on VanArsdel in the Revenue 

by Manufacturer visual. 

88. Ctrl+Click Australia column in 

Revenue by Country visual. Now we 

have filtered the charts by both 

VanArsdel and Australia. We see a 

spike in 2018 sales for VanArsdel in 

Australia. 

89. Let’s see what’s happening in USA. 

Click USA column in Revenue by 

Country visual. 

90. Ctrl+Click on VanArsdel in the 

Revenue by Manufacturer visual. Now 

we have filtered the charts by both 

VanArsdel and USA. We see a steady 

growth. 

Similarly, we can analyze data for 

different countries, manufactures and 

time frame.  
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We are intrigued by the spike in 2018 

for VanArsdel in Australia. Let’s 

investigate further. 

91. Click on VanArsdel in the Revenue 

by Manufacturer visual. 

92. Ctrl+Click Australia column in 

Revenue by Country visual 

93. Select the down arrow on the top 

right corner of the Revenue by Year 

visual. This enables drill down 

capability. 

94. Select 2018 column in Revenue by 

Year visual. 

Notice you have drilled down to 

quarter level of 2018. There is a big 

spike in the 4th quarter. Interesting let’s 

dig further… 

 
 

95. Click on the double arrow icon on 

the top right of Revenue by Year 

visual. This drills down to the next level 

of the hierarchy which is month. 

Looks like sales picked up in September 

and October and is holding steady since 

then. Ok this is interesting. Now is this 

a yearly trend. Let’s check? 

96. Click on the up arrow icon on the 

top right of Revenue by Year visual to 

drill up to Quarter level. 

97. Click on the drill up icon again to go 

up to Year level. 

 

98. Click on the split arrow icon on the 

top right of Revenue by Year visual. 

This expands down to the next level of 

the hierarchy which is quarter for all 

the years. 

Notice 4th quarter sales have always 

been high but in 2018 there is a bigger 

spike in the 4th quarter. 

99. Let’s expand down to the month 

level. Click on the split arrow icon on 

the top right of Revenue by Year 

visual. This expands down to the next 
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level of the hierarchy which is month 

for all the years. 

There is a lot of information on the 

visual and we must scroll left and right 

to compare.  

100. Click on focus mode icon on the 

top right of Revenue by Year visual.  

Now Revenue by Year takes over the 

complete canvas. Notice that sales 

have typically been high that last 4 

months of the year. It confirms the 

spike in 2018. 

Drill up/down functionality is available 

in the ribbon as well.  

101. From the ribbon, select Data/Drill 

-> Drill up to move to Quarter level. 

102. From the ribbon, select Data/Drill 

-> Drill up to move to Year level. 

103. Click on Back to Report on the top 

left corner of the visual to go back to 

report canvas. 

104. Click on VanArsdel in the Revenue 

by Manufacturer visual to remove 

filters. 

 

 

Power BI Desktop – Data Exploration Continued 
 

In this section, you will continue to 

explore the data. You will investigate to 

see if a product segment has an impact 

on sales. 

At the end of the section, you will find 

that one of the reasons for the spike in 

sales in Australia for the year 2018 is 

158% growth of product Maximus UE-04.  
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Let’s continue to investigate our findings 

of VanArsdel’s sales spike in 2018 in 

Australia. We will start by adding a new 

page. 

1. Right click on Page 1 (bottom left). 

2. Select Rename Page. Rename the page 

to Market Analysis. 

3. Right click on Market Analysis page. 

This time pick Duplicate Page. We are 

duplicating the page since we can reuse 

some of the visuals. 

A new page is created, and you will be 

navigated to this new page.  

Let’s add a slicer so we can filter 

manufacturers. 

4. Click on the white space in the canvas. 

From the FIELDS section, expand 

Manufacturer table and click the 

checkbox next to Manufacturer field.  

5. From the VISUALIZATIONS section 

select Slicer visual. 

6. You will see a list of Manufacturers. 

Select VanArsdel and notice all the 

visuals are filtered based on your 

selection. 

7. Hover over the top right corner of the 

visual and click on the down arrow. 

Notice you have the option to change the 

slicer from a list to a drop down. 

8. Select Dropdown. 

9. Select VanArsdel from the dropdown. 
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10. In the VISUALIZATIONS panel, scroll 

down to FILTERS section.  

Notice the Page level filters for 

Manufacturers. Since we have two pages 

and we want Manufacturer filter to apply 

to both pages it makes sense to move it 

to Report level filters. 

11. In the FIELDS section, expand 

Manufacturer table. 

12. Drag Manufacturer (groups) field to 

Report level filters. 

13. Select Top Competitors and 

VanArsdel. 

14. Click on “X” next to Manufacturers in 

Page level filters.  

We use the Manufacturer slicer to 

analyze one manufacturer at a time. 

Notice when we do this, Revenue by 

Manufacturer Treemap visual is not the 

best representation of the data. Let’s 

change it. 

15. Select Revenue by Manufacturer 

Treemap visual. 

16. From the VISUALIZATIONS section, 

select Card visual. 

 

The card visual will give us the Revenue as 

we filter and cross filter the visuals. 

 

 

Notice all key dimensions/characteristics 

is in its own table with the related 

attributes except date. E.g. Product 

attributes are in Product table and we 

created a relationship between Product 

and Sales. 

It is good practice to have dimensions in 

different tables. In the future if we need 

to add date attributes like Week number, 

Day of Week, Holiday, etc, we need to 

have a Date table. Let’s create Date table. 

 

17. Navigate to Data view by clicking on 

the Data icon on the left panel. 

18. From the ribbon select Modeling -> 

New Table. 
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Notice a new table is created in the 

FIELDS section on the right and formula 

bar opens. 

19. Enter Date =CALENDAR 

(DATE(2012,1,1), DATE(2018,12,31)) in 

the formula bar and click on the check 

mark. A Date table with a Date column is 

created. 

We are using 2 DAX functions: CALENDAR 

function which takes the start and end 

data. DATE function which takes year, 

month and date fields.  

We are creating Date from 2012 to 2018 

since our dataset has data for those 

years. 

We can add more fields to this table like 

Year, Month, Week etc. by using DAX 

functions. 

Notice Date field is of type Date/Time. 

Let’s change it to data type Date. 

 

20. Select the Date field in the Date table. 

21. From the ribbon, select Modeling -> 

Data type -> Date. 

 

 

Next, we need to create a relationship 

between the newly created Date table 

and Sales table. Previously we used the 

visual drag and drop feature to create a 

relationship. This time around let’s use a 

different option. 

22. From the ribbon, select Modeling -> 

Manage Relationships. 

23. Manage Relationships dialog opens. 

Select New button. 

24. Create relationship dialog opens. 

Select Date from the top dropdown. 

25. Select Sales from the second 

dropdown. 
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26. Highlight Date fields from both the 

tables. 

27. Select OK to close Create relationship 

dialog. 

28. Select Close to close Manage 

relationships dialog. 

29. Navigate to Report view by clicking on 

the Report icon on the left panel. 

Notice Revenue by Date chart looks 

different. Let’s fix it. 

30. Select Revenue by Date visual. 

31. From the Axis click on “X” to remove 

the Date field. 

32. From the FIELDS section expand Date 

table. 

33. Drag Date field to Axis section. 

Notice with the new Date field behavior is 

like earlier. 

 

 

There are two Date fields, it might get 

confusing to figure out which to use. Let’s 

hide the Date field in Sales table. 

34. From the FIELDS section, expand 

Sales table. 

35. Click on the ellipsis next to Date field. 

36. Select Hide. This hides Date field in 

the reports view. We have the option to 

view hidden fields and unhide fields as 

needed. 

 

Note: It is best practice to hide fields that 

are not used in reports like ZipCountry, 

ProductID, ManufacturerID. 
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Let’s get back to our data story, Australia, 

VanArsdel and 2018 – remember 😊. 

Let’s check if the spike occurred in a 

specific region in Australia. 

37. Select Revenue by Country visual. 

38. In the FIELDS section, expand 

Geography table. 

39. Drag State field below Country in the 

Axis section. 

40. Drag District field below State in the 

Axis section. 

We just created a hierarchy.  

41. Make sure VanArsdel is selected in 

the Manufacturer slicer. 

42. Enable Drill mode by selecting down 

arrow on the top right corner of Revenue 

by Country visual. 

43. Select Australia to drill down to State 

level. 

44. From Revenue by Year visual select 

2018 and notice Revenue by Country and 

State visual. 

45. From Revenue by Year visual select 

2018 and notice Revenue by Country and 

State visual. 

46. Similarly, select 2016. We don’t see a 

spike in a specific state.  

47. Select 2016 again to remove year 

filter. 

48. Drill up to country level. 

 

 

Let’s analyze by Product to figure out 

what’s happening there. Before we start 

with that let’s create a Product Hierarchy. 

This way we don’t have to drag multiple 

fields to the visual. 

49. From the FIELDS section, expand 

Product table. 

50. Click on the ellipsis next to Category. 

51. Select New Hierarchy. 
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Notice a new field called Category 

Hierarchy is created in the Product table. 

52. Double click on Category Hierarchy 

and rename it to Product Hierarchy. 

 

53. Click on the ellipsis next to Segment. 

54. Select Add to Hierarchy -> Product 

Hierarchy. 

55. Click on the ellipsis next to Product. 

56. Select Add to Hierarchy -> Product 

Hierarchy. 

We have created a Product Hierarchy 

which is Category -> Segment -> Product. 

 

57. Click on the white space in the canvas. 

From the VISUALIZATIONS section select 

Clustered bar chart. 

58. From the FIELDS section, expand 

Product table. 

59. Click the checkbox next to Product 

Hierarchy. Notice complete hierarchy is 

selected. 

60. From the FIELDS section, expand 

Sales table. 

61. Click the checkbox next to Revenue 

field. 
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Note: Make sure you have VanArsdel 

selected in the slicer. 

We see that VanArsdel has a presence in 

the Urban category and a small presence 

in the Rural category. 

62. Drill down Urban category (yes you 

are an expert drilling up and down 

hierarchy 😊). If not, select the down 

arrow on the top right corner of the 

visual. 

63. Select the Urban row to drill down to 

Urban segments.   

64. In Revenue by Country visual make 

sure drill down mode is disabled. 

65. Select USA. Notice that Convenience 

and Moderation are the segments with 

most sales. 

66. In Revenue by Country visual select 

Japan. Notice that again Convenience and 

Moderation are the segments with most 

sales. 

67. In Revenue by Country visual select 

Australia. Notice that sales in Extreme 

segment is comparable to Convenience 

and Moderation. Let’s dive into Extreme 

segment and investigate further. 

 

68. In Revenue by Country visual select 

USA. 

69. Ctrl+Select 2018 from Revenue by 

Year visual. Notice Convenience and 

Moderation are the key segments in USA. 
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70. In Revenue by Country visual select 

Australia. 

71. Ctrl+Select 2018 from Revenue by 

Year visual. Notice sales in Extreme 

category is higher than Convenience and 

Moderation segments. 

We need to investigate further… 

 

72. Select the down arrow on the top 

right corner of Revenue by Country visual 

to enable drill model. 

73. Select Australia to drill down to State 

level. 

74. Select 2018 in Revenue by Year visual. 

75. Remove drill mode from Revenue by 

Category visual. 

76. Ctrl+Select Extreme Segment in 

Revenue by Category and Segment visual. 

77. Select 2017 in Revenue by Year visual. 

78. Ctrl+Select Extreme Segment in 

Revenue by Category and Segment visual. 

 

There is no significant spike by State. 

 

79. Select Extreme again to remove cross 

filtering between visuals. 

80. Drill up to Category level in Revenue 

by Category visual. 
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Let’s add a matrix visual so we can view 

data in rows and columns. We can apply 

conditional formatting to the matrix 

visual to highlight outliers. 

 

81. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Matrix visual. 

82. From FIELDS section expand Product 

table. 

83. Drag and drop Product Hierarchy field 

to Rows section. 

84. From FIELDS section expand Sales 

table. 

85. Drag and drop Revenue to Values 

section. 
 

86. Enable drill mode in the matrix by 

selecting the down arrow on the top right 

corner of the visual. 

87. Select Urban row to drill down. 

  

Well the text is too small, let’s format the 

matrix and make it more readable. 

88. In the VISUALIZATIONS panel, select 

the paint roller icon to format the visual. 

89. Scroll down and expand Values 

section. 

90. Scroll down and increase the Text 

size to 10. 

Notice there are a lot of formatting 

options. Feel free to explore them. 

91. Scroll up and expand Column headers 

section. 

92. Scroll to Text size and increase it to 

10. 

93. Scroll up and expand Row headers 

section. 

94. Scroll to Text size and increase it to 

10. 
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Let’s add percent of total field. This will 

give us a better perspective. 

95. From FIELDS section expand Sales 

table. 

96. Drag Revenue field below the existing 

Revenue field in Values section. 

97. Select the arrow next to the newly 

added Revenue field. 

 

98. From the dialog select Show value as 

-> Percent of grand total. 

 

We see that in Australia, Extreme 

segment has highest market share. Let’s 

check across time if this is true. 

 

99. In the Revenue by Year visual select 

2016 column. Notice Extreme segment 

has around 30% of the grand total.  

100. In the Revenue by Year visual select 

2017 column. Notice Extreme segment 

has around 30% of the grand total. 

101. In the Revenue by Year visual select 

2018 column. Notice Extreme segment 

has around 40% of the grand total. 

102. In the Revenue by Year visual select 

2018 column to remove the filter. 

 

Let’s drill down Extreme Segment and 

figure out if a Product stands out. 
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103. In the matrix visual select Extreme 

row to drill down to Product level. 

104. Resize the visual as needed. 

105. Hover over matrix visual and select 

the ellipsis on the top right corner.  

106. Select Sort By % GT Revenue and 

Sort Descending. 

 

We see the top Products. Let’s analyze 

top Products over time. 

 

107. In the Revenue by Year visual select 

2016 column. Notice Maximus UE-04 and 

11 are the top products.  

108. In the Revenue by Year visual select 

2017 column. Notice Maximus UE-16 and 

17 are the top products. 

109. In the Revenue by Year visual select 

2018 column. Notice Maximus UE-04 and 

21 are the top products. And Product 04 

has nearly 7% of the grand total. Product 

04 has a big spike. 

110. In the Revenue by Year visual select 

2018 column to remove the filter. 
 

Earlier we created a calculated column 

(ZipCountry). Let’s create % Growth 

measure so we can compare sales over 

time. We are going to do this in two 

steps. 

 

But first, what’s the difference between 

measure and calculated column. 

Calculated column is evaluated row by 

row. We extend a table by adding 

calculated columns. 

Measure is used when we want to 

aggregate values from many rows in a 

table. 
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111. In the FIELDS section, select Sales 

table. 

112. From the ribbon, select Modeling -> 

New Measure. Formula bar opens. 

113. Enter PY Sales = 

CALCULATE(SUM(Sales[Revenue]), 

SAMEPERIODLASTYEAR('Date'[Date]) 

114. Select the check mark next to the 

formula bar. You will see PY Sales 

measure in Sales table. 

Let’s create another measure. 

115. In the FIELDS section, hover over 

Sales table. 

116. Click on the ellipsis on the right 

corner. 

117. Select New Measure from the 

dialog. Formula bar opens. 

118. Enter % Growth = 

DIVIDE(SUM(Sales[Revenue])-[PY 

Sales],[PY Sales]) 

119. Select the check mark next to the 

formula bar. You will see % Growth 

measure in Sales table. 

 

120. Select the matrix visual. 

121. In the FIELDS section, expand Sales 

table. 

122. Click the checkbox next to the newly 

created PY Sales and % Growth 

measures. 

Notice these fields need to be formatted. 

123. From the FIELDS section, click the 

checkbox next to % Growth field. 

124. From the ribbon select Modeling -> 

Format -> Percentage 

125. Similarly, from the FIELDS section, 

click the checkbox next to PY Sales field. 

126. From the ribbon select Modeling -> 

Format -> Currency -> $ English (United 

States) 
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127. In the Revenue by Year visual select 

2018 column. Notice Maximus UE-04 has 

nearly 158% growth compared to last 

year. 

 

128. Select matrix visual. 

129. From the Values section, select the 

arrow next to % Growth. 

130. Select Conditional Formatting -> 

Background color scales. 

 

Note: Conditional formatting can be 

applied using font color or data bars as 

well. 

 

Background color scales dialog opens. 

This dialog provides options to format 

background color either using rules or 

diverging colors. 

 

131. Select the Diverging checkbox. 

132. Select OK. 

 

Note: Conditional formatting can also be 

based on another column using Color 

based on drop down. 
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Power BI Desktop – Data Visualization  
 

Having done the data exploration and visualization you have found good insights to share with your team. In this 

section, you will create a professional report from which you and your entire team can benefit.  

 

At the end of this section, you will build a 

report like the one shown in the 

screenshot. 

 

Let’s add Collapse and Expand capability 

to the matrix visual. 

1. Select matrix visual. 

2. In the VISUALIZATIONS panel, select 

the paint roller icon to format the visual. 

3. Scroll down and expand Row headers 

section. 

4. Scroll down to +/- icons and using the 

slider, turn the feature On.  

Notice now you have the 

Expand/Collapse icon in the matrix, giving 

a pivot table like experience. Color/size of 

these icons can be further formatted. 
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Let’s remove Revenue by Category 

clustered bar chart. 

5. Hover over Revenue by Category 

visual. 

6. From the top right corner select the 

ellipsis 

7. Select Remove to delete the visual. 

 

Initially we added a filter to load 3 years 

of data. Let’s load the complete data. 

8. From the ribbon, select Home -> Edit 

Queries. Power Query Editor window 

opens. 

9. From the left panel, select Sales query. 

10. From the right panel, under APPLIED 

STEPS click on the X next to Filtered 

Rows1 to remove the 3-year filter. 

11. Select Home -> Close & Apply to load 

the data.  

Sales data is reloaded, this time all the 

data is loaded. It might take a couple of 

minutes as we are loading ~7 million 

rows. 

 

Make sure the report is filtered by 

VanArsdel using Manufacturer slicer. 

Remove all other filters. 

 

At this point your report page should look 

something like the screenshot. 

Once data is loaded, notice Revenue by 

Year visual. You will see columns for 

years 2012 through 2018. 
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Let’s add a Date slicer so we can control 

how many years of data we want to 

analyze. 

12. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Slicer visual. 

13. From FIELDS section, expand Date 

table. 

14. Click the checkbox next to  Date field.  

Notice we have a range slicer with a 

slider.  

15. Move the slicer to filter the data to 

1/1/2014 to 12/31/2018 or type in the 

values. 

 

16. Hover over the date slicer. 

17. Select the arrow from the top right 

corner. Notice following options are 

available – Before, After, List, Dropdown 

and Relative. Feel free to try out the 

various options. 

18. Select Relative. Notice this has 

options to filter data by the Last x years, 

months, days or Next x years, months, 

days, etc. Feel free to try out various 

options.  

19. Hover over Manufacturer slicer 

visual. 

20. On the top right corner select the 

arrow.  

21. Select List. 

22. in VISUALIZATIONS panel select the 

paint roller icon. This opens the 

formatting options available for a visual. 

23. Expand General section, select 

Horizontal from the Orientation 

dropdown. 

24. Notice the Slicer visual is updated. 

You can resize the visual, so all the 

manufacturers are listed horizontally. 

Note: There are other options to change 

the Outline color, weight, etc. 

25. Select VanArsdel. 

26. Collapse General section. 
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27. Note: Expand Selection Controls 

section. Notice there is an option to 

enable Select All option in the visual. 

There is also an option to make the slicer 

multi select. Feel free to explore other 

formatting options. 

It will be nice to add logos of the 

manufacturer to the slicer. Let’s do it. 

28. From FIELDS section, expand 

Manufacturer table. 

29. Click the checkbox next to  Logo field. 

30. From the ribbon, select Modeling -> 

Data Category -> Image URL. Setting data 

category to Image URL helps Power BI to 

understand that it is a URL and it can 

access the data. 

 

31. From the canvas, select Manufacturer 

slicer. 

32. From FIELDS section, expand 

Manufacturer table. 

33. Drag and drop Logo to Field section. 

34. Select Logo field. 

35. Resize slicer visual as needed. 

36. Select VanArsdel logo to filter all the 

other visuals. 

 

37. Select Revenue by Year visual. 

38. From VISUALIZATIONS panel, select 

Line and clustered column chart to 

change the visual type. 

39. From FIELDS section, expand Sales 

table. 

40. Drag and drop % Growth field to Line 

values. 

 

This provides a representation of the 

revenue and growth over time.  
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41. Select Revenue Card visual. Let’s 

change this to a Gauge visual. 

42. From VISUALIZATIONS panel, select 

the Gauge visual. 

43. From FIELDS section, expand Sales 

table. 

44. Drag and drop PY Sales field to Target 

value. 

45. Resize the visual as needed. Now we 

can compare Revenue with the target. 

 

It will be nice to change the colors on the 

visuals.  

46. Select Gauge visual. 

47. From VISUALIZATIONS panel, select 

paint roller icon. 

48. Expand Data Colors section. 

49. Select the arrow next to Fill color. 

 

Notice you can pick a color from the 

default color palette or pick Custom 

colors. 

 

Let’s check out some of the themes 

available. 

50. From the ribbon, select Home -> 

Switch Theme -> Sunset. 

Notice colors on all the visuals updated. 

Feel free to try the other out of the box 

themes. 

 



Version: 02.15.2019                                  Copyright 2019 Microsoft                                                            60 | P a g e  
Maintained by:  Microsoft Corporation    

Marketing department has provided 

standard color themes to be used across 

reports. We can use Report Theme 

feature in Power BI by uploading a theme. 

Report Theme requires a JSON file where 

the data colors, background, foreground 

and table Accent colors are defined. The 

JSON file can be used across all the 

reports. 

51. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

52. File browser dialog opens. Navigate to 

/Data/Theme folder. 

53. Select DIADTheme1 file and select 

Open. 

54. Once theme is imported, a success 

dialog opens. Select Close. 

 

Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

This one is good, but too much red in it. 

Marketing team has provided two more 

themes, let’s try the next one. 

55. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

56. File browser dialog opens. Navigate to 

/Data/Theme folder. 

57. Select DIADTheme2 file and select 

Open. 

58. Once theme is imported, a success 

dialog opens. Select Close.  
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Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

 

This theme looks good. Now most of the 

visuals are blue in color, let’s add some 

contrast. 

 

 

59. Select the Gauge visual. 

60. From VISUALIZATIONS panel, select 

paint roller icon. 

61. Expand Data colors section. 

62. Select the drop down next to Target. 

Notice the color palette is different now. 

63. Select black color. Notice the change 

in the visual. 

 

64. Collapse Data colors section. 

65. Expand Data Labels section. 

66. Increase Text size to 10. 

67. Expand Target section. 

68. Increase Text size to 10. 

 



Version: 02.15.2019                                  Copyright 2019 Microsoft                                                            62 | P a g e  
Maintained by:  Microsoft Corporation    

69. Select matrix visual. 

70. Drill up to Segment level. 

71. Select Revenue by Country visual. 

72. Drill up to Country level. 

73.  From VISUALIZATIONS panel, select 

paint roller icon. 

74. Expand Data colors section. 

75. Select a light shade of gray as the 

Default color. 

76. Enable and expand Data labels. 

77. Change Display units to Millions. 

 

Notice there a lot of formatting options. 

E.g. visual title can be changed and 

formatted, you can add a border and 

background to the visual, etc. Feel free to 

explore the options. 
 

78. Select Revenue and % Growth by 

Year visual. 

79. From VISUALIZATIONS panel, select 

paint roller icon. 

80. Expand Data colors section. 

81. Select black color for % Growth. 

82. Select a light shade of gray as the 

Default Column color. 

 

Let’s add a report title. 

83. From the ribbon, select Home -> Text 

box. Notice a text box visual is added. 

84. Resize the visual as needed. 

85. Enter Manufacturer Analysis in the 

Text box. 

86. Highlight Manufacturer Analysis to 

format the text.  

87. Select Segoe (Bold) as the font. 

88. Select 36 as the font size. 

89. Resize the text box as needed. 
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90. From the ribbon, select View. 

91. Select the checkbox next to Show 

Gridlines and Snap Objects to Grid. This 

will help with aligning the visuals. 

92. Move and align the visuals like the 

screenshot. As you move visuals notice 

the red smart guide helps aligning them. 

Uncheck Show Gridlines and Snap 

Objects to Grid options to disable these 

features. 

93. Rename the page to Manufacturer. 

 

 
 

We can also use a background image to 

format the reports. Let’s try it. 

94. Select + icon in the bottom of the 

page to create a new page. You will be 

navigated to a Page 1. 

95. Click on the white space in the 

canvas. 

96. From VISUALIZATIONS panel, select 

paint roller icon. 

97. Expand Page Background section. 

98. Select Add Image button. 

99. File browser dialog opens. Browse to 

/DIAD/Data folder. 

100. Select Background file. 

101. Select Open. 
 

102. From Image Fit drop down, select 

Fit. 

103. Slide Transparency slider to 0%. 

Notice we have a template which has 

place for header and slots for images. 

104. Navigate to Manufacturer page.  

105. Select Revenue by Country visual. 

106. From the ribbon select Home -> 

Copy. 

107. Navigate to Page 1. 

108. From the ribbon select Home -> 

Paste. 

109. Resize the visual and place it as 

shown in the screenshot. 
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110. Navigate to Manufacturer page.  

111. Select Manufacturer slicer. 

112. From the ribbon select Home -> 

Copy. 

113. Navigate to Page 1. 

114. From the ribbon select Home -> 

Paste. 

115. Sync visuals dialog opens. Select 

Sync.  

This will keep Manufacturer slicer in both 

the pages in sync. Changing slicer in one 

of the pages will update visuals in both 

the pages. 

116. Resize the slicer and place it as 

shown in the screenshot. 

 

117. Similarly, copy the report title, 

gauge, matrix and the line and clustered 

column visual. 

118. Resize and arrange the visuals as 

shows in the screenshot. 

 

Let’s add a logo. 

119. From the ribbon, select Home -> 

Image. 

120. File browser dialog opens. Browse to 

/DIAD/Data folder. 

121. Select VanArsdel_Logo file. 

122. Select Open. 

123. Resize the visual as needed. 

124. Drag the visual to the top left corner 

of the page. 
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Let’s change the font color of report title.  

125. Highlight Manufacturer Analysis. 

126. Select the arrow next to A for font 

color. 

127. Select white color. 

 

Out of the box, Power BI has a good 

selection of visuals. However, there is 

always a use-case where you need a 

custom visual. To meet this need, the 

visualization engine is open sourced. 

Power BI community contributes visuals 

which are available in the marketplace. 

You can add and use these visuals in your 

reports. 

There is also an option to create your 

own visual and import it into Power BI 

Desktop. 

Let’s add a custom visual.  

128. From VISUALIZATIONS section, 

select the ellipsis in the last row of 

visuals. 

129. Select Import from marketplace. 

130. Type play axis in the search box and 

select search. 

131. Select Add next to Play Axis 

(Dynamic Slicer). 

132. Import custom visual dialog opens. 

Select OK. 

Notice a new visual is added to the list of 

available visuals. 

 

133. Click on the white space in the 

canvas. 

134. From VISUALIZATIONS section, 

select the newly imported Play Axis 

visual. 

135.  From FIELDS section, expand Date 

table. 

136. Click the checkbox next to  Date 

field. 
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137. From VISUALIZATIONS panel, select 

paint roller icon. 

138. Expand Colors section. 

139. Enable Show all option. 

140. Resize and position the visual as 

shown in the screenshot.  

141. Enable drill mode in matrix visual. 

142. Select Extreme category to drill 

down to Extreme products. 

143. Select Play in the Play axis visual. 

Notice all the visuals update as play axis 

moves through years. You can view 

Product performance over time as well as 

performance of countries over time. Play 

axis provides an option to analyze data 

over time (or any other dimension) across 

all visuals in the page. 

144. Once you are done playing through 

the years, in the matrix visual drill back 

up to Product Category level. 

145. Disable drill mode in matrix visual. 

There are a lot of custom visuals available 

and new ones are added periodically. 

 

Now we have a report ready, let’s use 

Bookmarks to tell the story we 

discovered. Bookmarks capture the 

currently configured view of a report 

page, including filtering and the state of 

visuals which makes it easy to present the 

story. 

146. From the ribbon, select View. 

147. Select the checkbox next to 

Bookmarks Pane to enable Bookmarks. 

BOOKMARKS pane opens. 

148. Click on Add in BOOKMARKS pane. 

This will add the current state of the 

visual to the bookmark. 

149. Click on the ellipsis next to the 

newly created Bookmark 1. 

150. Select Rename to rename it to Initial 

State 
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151. In Revenue by Country visual, select 

USA column. 

152. Hover over Revenue by Country 

visual and select the ellipsis on the top 

right corner. 

153. Select Spotlight. 

154. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report.  

155. Click on the canvas. 

156. Select Australia in Revenue by 

Country visual. 

157. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report. 

 

158. From the BOOKMARKS pane, select 

View. You are in Bookmarks slide show 

mode. 

You will be in the first bookmark which 

we called Initial State. Notice on the 

bottom of the report pane there is an 

option to navigate between bookmarks. 

159. You can use the arrows to navigate 

between bookmarks and tell your story. 

160. From BOOKMARKS pane, select Exit 

to exit Bookmarks slide show mode. 

 

If time permits, feel free to explore other 

options available with Bookmarks like 

Selected Visuals and more as you 

continue to build the story. 
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161. From the ribbon, select View. 

162. Uncheck Bookmarks Pane. 

163. Collapse the Visualizations and 

Filters pane by clicking on the arrows. 

Report should look as shown in the 

figure. Save the file. 

164. Select File -> Save. 

 

You have built your first report!!! 

 

165. Navigate to /DIAD/Reports folder. 

166. Open DIAD Final Report.pbix file.  

 

This file uses the same dataset that you 

used for the lab. We have added a few 

more visuals and formatted the reports. 

Feel free to explore the report. 

 
 

You have successfully completed the hands-on lab in creating a report to share to your team. The next 

section covers creating a dashboard from this report so that you can easily share it to your team. You have 

learned a quick overview of various functionality in Power BI Desktop to get accelerated. There are a lot 

more features for you to build upon this on your own data.   
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Power BI Service  
  

You will now leverage the report authored using Power BI Desktop and create a dashboard for VanArsdel data 

analysis team and share it with the CMO. A Power BI Desktop file with additional reports / visuals is provided. Please 

use this for the next section of the lab.  

Power BI Service - Publishing Report  
 

1. If you have not signed up for a Power 

BI account, go to 

http://aka.ms/pbidiadtraining and sign up 

for Power BI with a business email 

address.  

2. If you have not already opened 

app.powerbi.com page, please open the 

browser and navigate to 

http://app.powerbi.com. 

3. Sign in to Power BI using your user 

account. Once logged in, you will see a 

screen like the screenshot. 

 

 
 

4. If the left navigation is collapsed, 

select  icon below Power BI on the 

top left of the screen to expand the left 

navigation. 

Following options are listed in the left 

navigation: 

Favorites: Lists all your favorite 

dashboards (we will create a favorite 

in a later section). 

Recent: Lists the most recent 

dashboards you have viewed. 

Apps: List all the apps you have 

installed. 

Shared with me: Lists the dashboards 

that are shared with you (we will 

share dashboards in a later section). 

Workspaces: Lists all the workspaces 

you are assigned. By default, you are 

assigned My Workspace. 

  

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
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5. Select the down arrow next to My 

Workspace. Notice DASHBOARDS, 

REPORTS, WORKBOOKS and DATASETS 

section are empty. Let’s import a Power 

BI Desktop file and create dashboards. 

 

Note: If you have previously signed into 

Power BI, then your screen will look 

different. You will be directly navigated 

to your Workspace skipping the 

Welcome page. 

My Workspace is your personal 

workspace. We need to create a 

workspace where we can collaborate 

with team members and distribute 

content to end users. Let’s create a 

workspace. 

6. In the left panel, select Workspaces -> 

Create app workspace. Create an app 

workspace dialog opens. 

7. Let’s try the improved workspace. This 

is a preview feature. Select Try now. 

Note: Creating workspace is a Pro 

feature. If you do not have Pro license, 

please choose the trial option. 

 

8. In the Create an app workspace, select 

Upload Image. 

9.  File browser dialog opens. Browse to 

/DIAD/Data folder. Select 

VanArsdel_WSLogo file. 

10. In Name your workspace text area, 

enter DIAD_<youremailaddress>. 

Note: you are entering your email 

address as part of the workspace name 

to keep it unique. 

11. In Description text area, enter “This 

is DIAD workspace”. 

12. Select Save to create the workspace. 

Notice you are now navigated from My 

Workspace to the workspace you just 

created. 
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Let’s publish the report to Power BI 

Service and then we will come back to 

the browser. 

13. Navigate to /DIAD/Reports folder. 

14. Open DIAD Final Report.pbix file.  

15. From the ribbon select Home -> 

Publish. 

16. If you have not already logged into 

Power BI, a Sign in dialog opens. Please 

sign in. 

17. Once you are signed in, Publish to 

Power BI dialog opens. Select 

DIAD_<youremailaddress> from the 

dialog. 

18. Click Select. 

 

Publishing to Power BI dialog opens. 

Once completed, a success message is 

displayed. 

19. Select Got it to close the dialog. 

 

Now we have published the report to 

Power BI service. Let’s navigate back to 

the browser and start exploring. 

 
 

Once you are in the browser, in the left 

panel notice under  

DIAD_<youremailaddress>, you will see 

REPORTS -> DIAD Final Report and 

DATASETS -> DIAD Final Report. 
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Power BI Service – Building Dashboard  

In this section, we will create a 

dashboard that will help compare 

VanArsdel’s market share and 

performance over time. 

 

At the end of the section, we will create a 

dashboard that looks like the screenshot. 

 

Let’s start with exploring the report. 

20. From the left menu, select REPORTS -

> DIAD Final Report. You will be 

navigated to the report you just 

uploaded. 

21. In the map visual, enable drill down 

by hovering over the visual. 

22. Select the down arrow on the top 

right corner of the visual. 

23. Select Australia to drill down to State 

level. 
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24. In the map visual, disable drill mode 

by selecting the down arrow on the top 

right corner of the visual. 

25. Select the bubbles on different 

states and notice that as you select the 

states, other visuals get cross filtered. 

The behavior is like that of Power BI 

Desktop. 

26. Select the top arrow on the top left 

corner to drill up to Country level. 

 

27. Hover over the bubble chart on the 

bottom right of the screen. 

28. Select Focus mode icon so the visual 

fits in the canvas. 

29. Select Extreme from the legend. This 

will highlight the performance of Extreme 

segment over time. Notice the spike in 

2018. 

30. Select the Play axis on the bottom 

left of the screen. This will show the 

revenue and % growth of each Product 

Segment over time. 

31. Select Extreme from the legend again 

to remove the filter. 

32. Select Back to Report on the top left 

to navigate back to report view. 

 

Let’s pin visuals to the dashboard. 

33. Hover over VanArsdel Market Share 

card visual. 

34. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

35. We do not have a dashboard yet. 

Let’s create one. With New dashboard 

selected, enter VanArsdel in the text box. 

36. Select Pin. 

 

Notice alert messages are displayed 

stating the dashboard is ready to view. 
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Notice in the left panel, VanArsdel 

Dashboard is created under 

DASHBOARDS. 

 

37. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice the VanArsdel Market Share tile is 

pinned to the dashboard. 

38. Click on VanArsdel Market Share, 

notice you are navigated to the report.  

 

Tiles in dashboard are not interactive. 

  

39. Hover over % Growth by 

Manufacturer visual. 

40. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

41. Make sure VanArsdel is selected in 

the dropdown. 

42. Select Pin. 

 

43. Close out alert dialogs. 

44. Hover over Revenue by Year and 

Manufacturer visual. 

45. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

46. Make sure VanArsdel is selected in 

the dropdown. 

47. Select Pin. 
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48. Close out alert dialogs. 

49. Navigate to By Manufacturer page. 

50. From the top right corner, select the 

down arrow. Notice manufacturer slicer 

displays. 

51. Select VanArsdel from the slicer. This 

will filter the visuals. 

52. From the top right corner, select the 

up arrow. Notice manufacturer slicer 

collapses. 

 

53. Pin the gauge visual to the 

dashboard. 

54. Pin Revenue by Country visual to the 

dashboard. 

55. Close out alert dialogs. 

 

Note: VanArsdel filter is applied to the 

tile that is pinned to the dashboard. 

 

56. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice all the visuals are pinned as tiles 

to the dashboard.  

You will see the visuals on the dashboard 
like the screenshot. 

 

Each visual on the dashboard is called as 
a tile.  The tiles represent the data 
chosen and will be kept up to date as the 
data in the data model updates. Tiles are 
not interactive. 

 

Let’s organize the dashboard now. 
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57. Select and move the gauge tile as 

shown in the screenshot. 

58. Select the bottom right corner of the 

tile and move it diagonally to change the 

image size. 

 

Tiles can be of various sizes (1x1 to 5x5). 

Drag the tile using the bottom right 

corner to resize. As you are dragging, 

note the gray shadow which indicates the 

size of the tile when you stop dragging. 
 

59. From the top menu, select Add tile. 

Add tile dialog opens. 

60. Select Image as the source. 

61. Select Next. 

62. In URL text box, enter 

https://raw.githubusercontent.com/Char

lesSterling/DiadManu/master/Vanarsdel.

png 

63. Select Apply. 

 

Notice a new tile with VanArsdel logo is 

added to the dashboard. 

 

64. Resize and rearrange the tiles as 

shown in the screenshot. 

 

https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
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Revenue by Country tile shows Revenue 

by Country for VanArsdel, so let’s rename 

it. 

65. Hover over Revenue by Country tile. 

66. Select the ellipsis on the top right 

corner of the tile. 

67. Select Edit Details. Tile Details dialog 

opens. 

68. Change Title to VanArsdel Revenue. 

69. Select Apply. 

 

It will be nice to have a visual that 

represents Market Share by country. 

Notice on the top of the visual, there is 

an option to Ask a question about your 

data. 

70. In the text box start typing, 

VanArsdel market share. Notice a card 

visual is created. 

71. Continue typing VanArsdel market 

share by country. Notice a bar chart is 

created. 

72. Continue typing VanArsdel market 

share by country as treemap. Notice a 

treemap visual is created. 

 

Note: Remember we renamed tables. 

One of the reasons we did it is to make it 

user friendly for Q&A. 
 

73. From the right panel, select the 

arrow next to VISUALIZATIONS to 

expand the section. 

74. Select the paint roller icon. 

75. Enable Data labels. 

 

Note: The visual can be modified and 

formatted like we did in Power BI 

Desktop. You can expand FIELDS section 

to add fields like Power BI Desktop. 
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76. From the top right of the screen, 

select Pin Visual. 

77. Pin to dashboard dialog opens. Select 

Pin to pin the visual to VanArsdel 

dashboard. 

78. Close the alert dialogs. 

79. Select Exit Q&A to navigate back to 

the dashboard. 

 

Notice the visual is added as tile to the 

dashboard. Clicking on the tree map 

visual will navigate you back to the Q&A 

section. 

 

80. Hover over the line chart on the 

dashboard. 

81. Select the ellipsis on the top right 

corner. 

82. Select View Insights. 

 

You will be navigated to Focus mode for 

the line chart.  

83. Scroll on the Insights panel to review 

the various insights Power BI can 

generate. Notice that there is an option 

to pin insight visuals to the dashboard. 

84. Click on Exit Focus mode on the top 

left to navigate back to the dashboard. 
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85. Hover over VanArsdel Market Share 

tile. 

86. Click on the ellipsis on the top right 

corner of the tile. 

87. Select Manage alerts. Manage alerts 

dialog opens. 

88. Select Add alert rule dialog. 

Notice you can add Above and Below 

threshold and notification frequency can 

be set. 

This is an introduction to managing 

alerts. Complete functionality is not 

covered in this lab.   

89. Select Cancel to close the dialog. 

90. Select Don’t Save.  

91. Click on VanArsdel Market Share tile 

to navigate to the report. 

92. In map visual, right click on Australia 

bubble and select Drillthrough -> By 

Manufacturer. 

You will be navigated to By Manufacturer 

page of the report with Australia filter 

applied to the report page. 

 

93. Hover over matrix visual.  

94. Select focus mode icon on the top 

right corner of the visual. 

95. From the top menu, select Explore -> 

Show Next Level. Notice now data is at 

Product Segment level. 

96. From the top menu, select Explore -> 

Drill up. 
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97. This time from the top menu, select 

Explore -> Expand to next level. Notice 

now data is at Segment level but laid out 

as a hierarchy.  

98. Select Back to Report to navigate 

back to the report view. 

 

Notice all the functionality that is 

available in Power BI Desktop is available 

in the service. E.g. Show Data, See 

Records, etc. 
 

99. From the top menu, select View and 

enable Bookmark pane. Bookmark pane 

opens on the right. There are 2 options, 

Personal bookmarks and Report 

bookmarks. 

Report bookmarks: are the bookmarks 

report author created (we did this in 

Power BI Desktop). 

Personal bookmarks: Report consumer 

can create their own bookmarks. 

100. Select View in the Report 

bookmarks pane. 

Notice you can view and navigate 

through the bookmarks using the arrow 

in the bottom of the screen. The behavior 

is like in Power BI Desktop. 

101. Select Exit in Bookmark pane to 

close it. 
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Power BI provides an option to get quick 

insights into the complete dataset. 

 

102. In the left panel, hover over 

DATASETS -> DIAD Final Report. 

103. Select the ellipsis. 

104. Select Quick Insights. 

 

It might take a few minutes for the 

insights to be created. Once insights are 

ready a message appears of the top right 

corner. 

 

105. Select View insights. 

  

A quick insights report is displayed based 

on the dataset. This provides insights into 

data you may have missed and helps to 

get a quick start with creating 

dashboards. 

Hovering over each report provides an 

option to Pin it to a dashboard. 

 

Marketing team has captured data from 

social networks and built a Power BI 

report. Let us publish this report to 

Power BI service and analyze the data. 

106. From the bottom of the left panel, 

select Get Data. 

107. Get Data screen is displayed. Under 

Import or Connect to Data, select Files. 
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108. From Get Data -> Files screen select 

Local File. 

109. File browser dialog opens. Navigate 

to /DIAD/Reports folder. 

110. Select Social.pbix file and click 

Open. 

 

 

111. Once the report is published, an 

alert message appears. Close the alert 

dialog. 

In the left panel, notice under REPORTS, 

we see Social. 

112. Select REPORTS -> Social to be 

navigated to the Twitter page of the 

Social report.  

Marketing team has captured the 

retweets of #VanArsdel. Notice there is a 

spike in 2018. Does this have any 

correlation to the spike in sales in 

Australia? Let’s investigate. 

113. Hover over Retweets visual and 

click on Focus mode icon. 

 

114. Enable drill mode. 

115. Drill down to month level for the 

year 2018. 

Notice there is a big spike in retweets in 

the last few months of 2018. Maybe this 

has a correlation to the spike in sales. 

116. Drill back up to Year level. 

117. Select Back to Report to navigate 

back to report view. 
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118. Hover over Retweets visual. 

119. Select the pin icon on the top right 

of the visual. Pin to dashboard dialog 

opens. 

120. Pin the visual to VanArsdel 

dashboard. 
 

121. Close the alert dialogs. 

122. From the left panel, select 

DASHBOARDS -> VanArsdel to navigate 

to the dashboard. 

Notice two new tiles are added to the 

dashboard. The retweets tile we just 

pinned and a default tile that is added 

when a new dataset is added. 

123. Hover over Social.pbix tile. 

124. Click on the ellipsis on the top right 

corner. 

125. Select Delete tile to remove the tile. 

 

Notice you can have tiles from multiple 

reports and Q&A section on a single 

dashboard. 

 

 

126. Navigate back to VanArsdel 

dashboard. 

127. Notice on the top right of the menu 

bar, there is options to add this 

dashboard to the favorites. Click on 

Favorite option. 

128. Now click on Favorite in the left 

panel. Notice the dashboard is added to 

the list. This is an easy way to access all 

your favorite or most used dashboards 

quickly. 

129.  Click on the ellipsis on the top right 

corner of the page, next to Share option. 

Notice there are options to duplicate, 

print and refresh dashboard. 
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On the top right corner of the screen, 

next to Favorite, there is Set as featured 

option. Set as Featured dashboard sets 

the dashboard as the default dashboard 

that user will land on every time they 

login. 

 

130. In the left panel, select VanArsdel 

Dashboard. 

131. Select Set as Featured from the top 

menu.  

132. A confirmation dialog is displayed. 

Select Set as Featured Dashboard. This 

sets VanArsdel as the featured/default 

dashboard. 

 

133. Navigate back to VanArsdel 

dashboard. 

134. If you have not already done so, 

move the visuals to look like the 

screenshot. 

You have successfully built a dashboard. 
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Power BI Service – Collaboration and Distribution  

You have built the dashboard and ready 
to get feedback and collaborate with 
your team members. 

 

1. From the left panel, select 

Workspaces. 

2. Select the ellipsis next to 

DIAD_<youremailaddress>. 

3. Select Workspace access. 

4. Access dialog opens. You can enter 

email address of the colleagues you want 

to collaborate with. 

Each user can belong to one of the 3 

roles: 
Admin Can change/delete workspace. 

Can add Admins. 

Everything a member can do. 

Member Re-share. 

Publish & update Apps. 

Everything a Contributor can 

do. 

Contributor Add/edit/delete content within 

workspace. 

 

5. Select the role and select Add. 

6. Once you finish adding your colleagues 

and select Close. 

Note: you can ask your colleague to login 

and access the workspace. 

 

 
 

 

Now let’s share the content we created 

with the report viewers/consumers. We 

need to publish an app to do this. 

7. In the left panel select 

DIAD_<youremailaddress> workspace. 

8. In the Dashboard page, notice there is 

an option INCLUDED IN APP, to include 

the Dashboard in the App. 

 

9. Navigate to Reports page. 

10. Notice there is an option INCLUDED 

IN APP to include the Reports in the App. 

If you have reports and dashboards in 

your workspace that you do not want to 
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share with report viewers, you can use 

this feature. 

11. In the left panel select 

DIAD_<youremailaddress> workspace. 

12. From the top right corner of the top 

menu select Publish app. 

 

13. In the Details page, enter “This is 

DIAD app” in the description field. 

14. Navigate to Content page. 

 

15. From the dropdown select VanArsdel 

(dashboard).  

When a user accesses the DIAD app, we 

want them to land on the VanArsdel 

dashboard. 

16. Navigate to Content page. 

 

17. Enter the email address of the users 

or groups you want to give access to. 

18. On the top right corner, select Finish. 

19. Ready to publish dialog appears. 

Select Publish. 

20. Once the App is published a success 

dialog appears. 
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You can copy the link to the App and 

share it with the individuals via email. But 

a better way for report viewers to 

consume the App is by logging onto 

Power BI Service and registering the App. 

Let’s impersonate a report viewer. 

21. From the left menu, select Apps. 

22. Select Get Apps. 

 

23. AppSource dialog opens. You will 

notice DIAD_<youremailaddress> App 

listed. Select Get it now. 

 

This is a one-time registration. Going 

forward when you select Apps in the left 

panel, you will see 

DIAD_<youremailaddress> app in the list 

of Apps you have registered. 

 

24. Click on DIAD_<youremailaddress> 

tile. 

You will be navigated to VanArsdel 

dashboard.  
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References 
 

Dashboard in a Day introduces you to some of the key functionalities available in Power BI. In the ribbon 

of Power BI Desktop, the Help section has links to some great resources to help you as needed. 

 

 

Here are a few more references that will help you with your next steps with Power BI. 

 

Getting started: http://powerbi.com  

Power BI Desktop:  https://powerbi.microsoft.com/desktop  

Power BI Mobile: https://powerbi.microsoft.com/en-us/mobile  

Community site https://community.powerbi.com/ 

Power BI Getting started support page: https://support.powerbi.com/knowledgebase/articles/430814-

get-started-with-power-bi  

Support site https://support.powerbi.com/  

Feature requests https://support.powerbi.com/forums/265200-power-bi  

Power BI course https://www.edx.org/course/analyzing-visualizing-data-power-bi-microsoft-dat207x-0 
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By using this demo/lab, you agree to the following terms: 

The technology/functionality described in this demo/lab is provided by Microsoft Corporation for purposes of 

obtaining your feedback and to provide you with a learning experience. You may only use the demo/lab to 
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for any other purpose. You may not modify, copy, distribute, transmit, display, perform, reproduce, publish, 

license, create derivative works from, transfer, or sell this demo/lab or any portion thereof. 
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PROHIBITED. 

THIS DEMO/LAB PROVIDES CERTAIN SOFTWARE TECHNOLOGY/PRODUCT FEATURES AND 

FUNCTIONALITY, INCLUDING POTENTIAL NEW FEATURES AND CONCEPTS, IN A SIMULATED 

ENVIRONMENT WITHOUT COMPLEX SET-UP OR INSTALLATION FOR THE PURPOSE DESCRIBED 

ABOVE. THE TECHNOLOGY/CONCEPTS REPRESENTED IN THIS DEMO/LAB MAY NOT REPRESENT 

FULL FEATURE FUNCTIONALITY AND MAY NOT WORK THE WAY A FINAL VERSION MAY WORK. 
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EXPERIENCE WITH USING SUCH FEATURES AND FUNCITONALITY IN A PHYSICAL ENVIRONMENT 

MAY ALSO BE DIFFERENT. 

FEEDBACK.  If you give feedback about the technology features, functionality and/or concepts described 

in this demo/lab to Microsoft, you give to Microsoft, without charge, the right to use, share and 

commercialize your feedback in any way and for any purpose. You also give to third parties, without 

charge, any patent rights needed for their products, technologies and services to use or interface with any 

specific parts of a Microsoft software or service that includes the feedback. You will not give feedback that 

is subject to a license that requires Microsoft to license its software or documentation to third parties 

because we include your feedback in them. These rights survive this agreement. 

MICROSOFT CORPORATION HEREBY DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH 

REGARD TO THE DEMO/LAB, INCLUDING ALL WARRANTIES AND CONDITIONS OF 

MERCHANTABILITY, WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR 

PURPOSE, TITLE AND NON-INFRINGEMENT.  MICROSOFT DOES NOT MAKE ANY ASSURANCES 

OR REPRESENTATIONS WITH REGARD TO THE ACCURACY OF THE RESULTS, OUTPUT THAT 

DERIVES FROM USE OF DEMO/ LAB, OR SUITABILITY OF THE INFORMATION CONTAINED IN THE 

DEMO/LAB FOR ANY PURPOSE. 

DISCLAIMER 

This demo/lab contains only a portion of new features and enhancements in Microsoft Power BI. Some of 

the features might change in future releases of the product. In this demo/lab, you will learn about some, but 

not all, new features. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   


