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Introduction 

Maplytics™ is a leading geo-analytical mapping app. Maplytics empowers users across verticals with the 
power of Geographical Data Visualization, Optimized Routing, Automated Appointment Planning, 
Proximity Search, Heat Maps, Shape Overlay, Census data visualization and Territory Management to drive 
better sales, improve business processes and engage right customers at the right time. 
 
Maplytics is available for Microsoft Dynamics versions CRM 2013 and above and supports all deployment 
models of CRM On-Premise (IFD as well), CRM Online and Partner-hosted. It uses the API services provided 
by Bing maps. The following are the highlights of Maplytics: 
 
✓ Ease of access 

✓ Compatible with Dynamics 365 App for 

Phones and Tablets 

✓ Multiple language support 

✓ Plot multiple OOB & custom entities on map 

✓ Hierarchal Territories 

✓ Area of Service 

✓ Search nearby records with Proximity Search 

✓ Auto Scheduling for multiple users 

✓ Track field reps’ activities with Check-In 

✓ Custom icons for pushpins 

✓ Multiple categories on plot card 

✓ PowerApps Component Framework 

✓ Multiple categorizations for single entity 

✓ Multiple territories for a record 

✓ Spider Cluster 

✓ Building Marketing list 

✓ Pie Charts and Column Charts in Heat Map 

✓ Overlay 

✓ Merged Plot and Route view 

✓ Maplytics Security Template 

✓ Point of Interest search 

✓ Layer Menu 

✓ Concentric Proximity search 

✓ Land Area Mapping 

✓ Bulk geographies upload 

✓ Shape operations 

✓ Territory Management 

✓ Auto-Territory Creation 

✓ Real-Time Tracking  

✓ Maplytics API 

✓ Territory Assignment Rules 

✓ Draft Territories 

✓ Census data visualization 

✓ Support for CDS 

✓ Data grid resizable 

✓ Plot Saved Templates on individual records 

✓ Configurable color-coded pushpins  

✓ Routing with multiple waypoints 

✓ Along the Route search 

✓ Ability to Save & Share Driving directions 

✓ Sales analysis with Heat Maps 

✓ Summary Card on Detail and Heat Map 

✓ Configurable color for Heat Map measure  

✓ Maplytics Dashboards with configurable 

queries  

✓ Geocoding Confidence Rating 

✓ Turn-by-turn navigation on mobiles & 

tablets 

✓ Seamlessly integrated within Dynamics  

✓ CRM / Dynamics 365 Customer Engagement 

 

✓ Multi-search layer in Detail map Control 
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Language Support 

Maplytics is a multi-language solution currently available in eleven different languages namely: 

• English 

• Spanish (Español) 

• German (Deutsche) 

• French (Français) 

• Portuguese (Português) 

• Turkish (Türk) 

• Arabic (  عرب)  

• Hungarian (Magyar) 

• Dutch (Nederlands) 

• Polish (Polski) 

• Russian (Русский) 

Maplytics auto-detects the user language set in Dynamics CRM and sets its language accordingly.  

To check user language set in Dynamics CRM, please go to Settings > Options > Languages 

Maplytics Configuration (Personalization) 

 

 

 

 

 

Each user of Maplytics can customize Maplytics configuration according to their preference. The user can 

configure Zoom level, Current Location, default origin and destination and a couple of other settings like 

Map more, default summary grouping, etc. Please go to Settings > Maplytics Configuration Details > 

Select Maplytics Configuration record for the required user (users added in Team Maplytics)> Set 

according to the preference  

Refer to ‘Maplytics Configuration Details (Personalization)’ section of Installation Manual for a detailed 

description of personalization settings.  
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Maplytics Security Template 

System admin and Maplytics admin can provide selective access of Maplytics actions to the Maplytics 
users. They can select the required Mass actions & other actions in the list and save it as a Security 
template. They can further assign this template to the required users so as to provide the access of the 
selected actions in the template to the respective Maplytics users.  
To create a Security Template,  
Go to the Maplytics App > Settings > Maplytics Security Templates > New > ‘General’ tab > Give a name 
and ‘save’ the template. 
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To assign a template to the Maplytics users, Admins can add 
the Maplytics Configuration Detail records of the Maplytics 
users under the section of ‘Maplytics Configuration Details’, 
to whom the template has to be assigned.  

 
 

 

 

 

 

 

 

 

 

 

In order to assign the Security Template to multiple users at once. Admins can also add teams/users using 

the button ‘Manage users’ from the Ribbon bar.  They can also remove the required users/teams from 

the list. Thus, using ‘Manage users’ admins can easily manage the users assigned with any Security 

Template. 
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Admins can choose whether they want to assign the template to Users or Teams by adding them. They 

can also choose to remove the users/teams from the list. They can also see the list of teams and respective 

users added from those teams.  

  

Note: A Maplytics Security template can be assigned to the users belonging to any team, however, 

they should also exist into the Maplytics team.  
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Go to Action Configuration > Select the required actions to be made available to the users assigned with 

this template and save. 
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Along with using the ‘Remove’ button, to unassign any template to a user, admins can also Go to Maplytics 
App > Settings > Maplytics Configuration Details > Select the record of the required user> Remove the 
lookup value for the field of ‘Maplytics Security Templates’   

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note:  

• All the actions will be visible to a user, if no template is assigned to the user 

• Only System Admin and Maplytics Admin will be able to access the Maplytics Security Template 
Entity 
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Individual Record Map 

A tab to display an Individual Map section has been added by default on the Account, Contact and Lead 

records as a part of the Maplytics solution. 

 
Here, two types of pushpins are plotted on the map: 

Orange color pushpin: This always indicates the record location on the map. This pushpin is 
movable on the map. If the user is not satisfied with the automatic geocoding information stored 
for the record, they can click on the pushpin and drag it around to the required location on the 
map. As the user moves the pushpin, the geocoding information (Latitude and Longitude) and the 

address is updated in the bar at the top. Use the Update button  to save the updated 
geocoding information. It will ask the user whether they would like to update only the Latitude & 
Longitude values or the address as well. They can select the required option. This will help the 
user to geocode the address as per the requirement.  
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Set the ‘No Auto Geocoding’ option to ‘Yes’ available on the left-hand side, if the user has manually 
set the geocoding information and do not want the automation to override the geocoding 
information. Right Clicking on the Map gives an option of Street View. 

 

Selecting it would get the User a 3D View. 
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• Address: If users wants to modify the geocoding for any record, they can click in the Address text 

box. 

 

After that, they can click on ‘Update’ button  to update the address and Latitude & Longitude 

values. It will ask the user whether they would like to update only the Latitude & Longitude values 

or the address as well. They can select the required option. Apart from this, users can also click 
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on the orange pushpin, drag it around to the required location, and then click on update to update 

the address and/or Latitude Longitude values.  

 

 
 

• Map My Current Location: Clicking on the ‘Locate Me’ button the user is asked to allow his 

current location to be plotted on the map. Once allowed, the user’s current location gets plotted 

with a blue pushpin while the orange one stays as is.  

 
Right-clicking the current location provides two options, Set Address and Street View. Set 

Address helps in populating the address of the current location to the text box. Similarly, the 

Latitude and Longitude of this location are populated in the respective fields in the bar above. 

Note: Users can be restricted to update the address and Latitude & Longitude values by 
assigning them a security template where ‘Allow Push Pin Update’ is not selected. Please 
refer to the Maplytics Security template in this User manual to know more about the same.   
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On clicking the Update button and confirming the address, the address, latitude, and longitude 

get updated successfully for the record.  

 
Map My Current Location function is available for Detail Map as well. Using this functionality, 

the user can view the travel distance from the Current Location and the User’s Location and plan 

the travel accordingly. 

 

• Deactivate: On deactivating a record by selecting the option, all the fields from CRM and on the 

Individual Map for that record get deactivated.  

 

• Related Records: User can use ‘Relations’ drop-down to select the available relationships for this 
Entity. Related records correspond to all 1:N relationship between the plotted Entity. The user 
can further see related record information by clicking or hovering on it. The required attributes 
like Email Address, Phone Number etc. can be selected within the entity map to be seen on hover 
or click. At a maximum, user can view 5 relationships at once. Default relationships can also be 
selected that will be plotted by default whenever this map is loaded. At a maximum, user can 
select five Default relationships. User can also select the color and pushpin icons for the related 
records. Check the Entity Map settings (refer to Installation Manual) to set Default relationship, 
colors & pushpins and adding more relationships to ‘Relations’ dropdown. In the image below, 
two relationships (Account-Contact and Account-Lead) are plotted for the account “Adventure 
Works”. 
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Steps to add the Map to other entity 

forms 

Open the Entity form and go to the ‘Insert’ 
tab. 

Click on ‘Web Resource’ button, as shown 
in the screenshot. 
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In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.IndividualMap.html” 
web resource and check the Pass record object-
type checkbox as shown in the screenshot. The 
recommended number of rows in formatting is 
minimum 10. 

Click OK, then Save and publish the form to see 

the Map on the entity form. 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

Note: To plot a particular address on the Map, it should be geocoded and the Latitude & Longitude 

should be set for that address. For geocoding you need to execute Maplytics Geocoding workflow for 

the records. 
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Area of Service 

The user can view the data in a proximity or a region around an individual record as defined by the user 
in the Area of service.  

 

Add Area of Service tab 

To add Area of Service tab, Open the Entity 
form and go to the ‘Insert’ tab. Click on Web 
Resource button, as shown in the 
screenshot.  

 

In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.AutoSearchFilters.
html” web resource and check the ‘Pass record 
object-type’ checkbox. 

The recommended number of rows in 
formatting is minimum 10. 

Click OK, then Save and publish the form to see 
the Map on the entity form. 
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 Create an Area of Service field 

To save the values entered in the Area of Service, the user needs to create a field for the Entity for which 
Area of Service has been added. Go to Entity form > New field. Enter the following values:  
Name - Area of Service 
Data type – Multiple Line of Text 
Maximum Length – 10000 
Select the field in the respective Entity map for the Area of Service field.  

  

The values when entered and saved into the Area of Service, the corresponding data will be plotted on 
the map.  

View Area of Service data on a map 

To view the Area of Service data on the map, there are two ways:  

• Using Map button – the results are shown in a map opened in a different tab 

• Adding Detail map on form – the results are shown in a map added on the same record 

Using Map button 

The user can open the Detail map to view the corresponding Area of Service data plotted on the map. 
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Adding Detail map on form 

 

To add a Detail map to show the data of Area of 

Service, follow the steps mentioned below: 

Open the Entity form and go to the ‘Insert’ tab. 
Add two columns.  
 

 
Click OK, then Save and publish the form to see 
the Map on the Entity form. 
 
 
Enter the required values into Area of Service, 
save it and click on the refresh button on the 
Detail map to view the data plotted.   

 

After adding Area of Service tab in the entity form 
as mentioned above, follow the steps mentioned 
below to add the Detail map on the entity form.  
 
To add a detail map, Click on ‘Web Resource’ 
button. In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.DetailMap.html” 
web resource, add “form” as custom parameter 
(data) and check the ‘Pass record object-type’ 
checkbox as shown in the screenshot. The 
recommended number of rows in formatting is 
minimum 10. 
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Advanced Area Of Service 

The advanced feature of Area Of Service enables users to determine an area in which services are being 

offered. It also helps in visualizing the records that lie in that area. 

In the case of a Doctor, the Area Of Service helps in determining the region in which the doctor is operating 

or offering his services. Patient records falling under this service region can also be visualized. Similarly, 

from a Patient’s POV, he can visualize all the doctors that offer services or whose services fall in his area. 

This helps the patient in selecting the nearest available doctor and the doctor can check the patients falling 

in his area of work. 

Attribute Mapping of Service Area 

Before we start using the advanced features of Area Of Service, the user needs to check the configuration 

as mentioned at the beginning of the feature. 

Once the relationship is created, select the same in the respective Entity map. As per our example, the 

Maplytics admin or system admin needs to go to Maplytics App > Settings (Left bottom) > Entity Maps > 

Accounts Entity map > Attributes Mapping > Geography relationship > Select the 1: N relationship of 

Geography and Account for Service Area Mapping 

 

To restrict access to creating and assigning of Service Area and saving Template as Service Of Area, the 

user can move to Settings>> Maplytics Security Templates>> Action Configuration  

The user can then uncheck Service Area and Save Template- Service Area options to restrict the feature 

and the Template enabling them again, when required. 
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Working of Area Of Service 

Users can create Service Area in an Individual Detail Map by using 6 ways- 

by File, by Proximity, by Region, by Drawing, by Territory & By Overlay. Let us consider by Proximity. 

 

After creating the shape, user can select the shape using align tool & right click over it to select Area of 

Service option to assign Service Area for individual record. 
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Once the area is assigned, the map can be refreshed to see the assigned Service Area for individual 

record. 

Using Area of Service template, user can see the records that lie within the created Service Area. For 

example, doctors can see patients' records which are falling under their service region. 

There are two ways to save the Area of Service template,  

1. Using the Area of Service tab, which is configured by user, 

 

2. Using Plot cards either by location or by region on the individual map 
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Plotting a Shape Layer on the created Service Area. This can be done by clicking on the ‘Show Region 
Boundary’ on the right  
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Detail Map 

Maplytics buttons are added to the Entity forms as well as the Entity Homepages so that it can be easily 
accessed from anywhere.  
 
 

 
 
Using this button, the user can invoke the Maplytics application for detailed geographical analysis. 
Maplytics provides both ‘Heat Maps’ view as well as ‘Detail Map’ view of the Dynamics CRM data. These 
views can be easily accessed from the buttons added to the command bar in entity home pages and other 
views. 
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Selecting a few records and clicking on the ‘Detail Map’ button on a particular Entity Grid view will open 
the following window;  

 

It will automatically plot the selected records from the view on the map. Records that do not have their 
latitude/ longitude will be ignored and will not be plotted on the Map.  

Map My Current Location- 

 

Clicking on the ‘Locate Me’ button the user is asked to allow his current location to be plotted on the 

map. Once allowed, the user’s current location gets plotted with a blue pushpin.  
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Right-clicking the current location provides two options, Set Address and Street View. Set Address 

populates the address of the current location in the text box. The Latitude and Longitude of this location 

are populated in the respective fields in the bar above. On clicking the Update button and confirming 

the address, the address, latitude, and longitude get updated successfully for the record. Using this 

functionality, the user can view the travel distance from the Current Location and the User’s Location 

and plan the travel accordingly. 

Street View 

Right Clicking on the Detail Map gives an option of Street View.  
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Clicking it opens an improved 3D view of the street. 

 

Right Clicking on the Detail Map on the Mobile App also gives an option of Street View and a 3D View.  
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Plot 

There are five different search options to plot the data on Map: 

• By Location 

• By Region 

• By Drawing 

• By Shapefile 

• By Territory 

• By Template 
 
 

 
 

By Location 

This helps the user to plot the data using the geocoding of each record. 
By Location search option also allows the user to perform 
Proximity/Radius Search based on Distance or Time.  

The Current Location is fetched from the user’s personalization record. 
The user can also set a new current location using the contextual menu. 
Refer to the section of the Contextual menu.   

 

 

 

 

 

 

Select Datasource dropdown will list out all the Entities (OOB 

and Custom) configured for Maplytics and the active views 

(System views, Personal views, Maplytics Dashboards and 

Marketing Lists) that are available for the selected Entity type. 

The user can choose one of the views to plot all the records 

available in that view.  

 

Note: The user can also configure the ‘Search Options’ to be visible on the map. Refer ‘Setup Entity 

Map’ section of Installation Manual for further instruction. 

Note: The user can also configure the ‘Views List’. Refer ‘Setup Entity Map’ section of Installation 

Manual for further instruction. 
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The user can select multiple entities using the ‘+’ button. This allows for 

viewing Dynamics CRM data across Entities in a single view on the map.  

After selecting multiple entities, the user can click on the ‘Search’ 

button to plot the records for the selected entities. This helps the user 

to visualize three entities on a single map. 

 

 

 

 

 

 

 

 

Note: User can define the colors as well as pushpin shapes of the 

Entity – view combination. Refer to ‘Setup Entity Map’ section of 

Installation Manual for further instructions. 
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By Region 

This helps the user to plot the data by the region of records, i.e., 
City, State, County, Country, PostalCode, PostalCode Sector, 
Postal Code(Outward Code), Postal Code Areas. The user can plot 
multiple regions under a particular region type. 

• Postal Code: The smallest postcode category, such as a zip 
code. 

• Postal Code Sector: The second ‘1’ is called “Postcode 
Sector”. Example: CA1 1 

• Postal Code(Outward Code): This is called Outward Code, 
the part of the postcode before the single space in the 
middle. Example: CA1 

• Postal Code Areas: The next largest postcode category 
after Postcode1 that is created by aggregating Postcode1 
areas. 

 

  

 

 

 

Note:  

• The regions that were plotted using the option of 
Post code Areas before will now be plotted by using 
the option of Post code sector.   

• The regions will be plotted as per the Bing maps.  

 

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FPostcodes_in_the_United_Kingdom%23Overview&data=02%7C01%7Cv-szczup%40microsoft.com%7C65818020a8fc4120be9108d618ac626f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636723526031148736&sdata=uIf6X6f4o349Rg6LSBtVlpIXeqzCk4kDyXjSZjRzWbE%3D&reserved=0
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FPostcodes_in_the_United_Kingdom%23Overview&data=02%7C01%7Cv-szczup%40microsoft.com%7C65818020a8fc4120be9108d618ac626f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636723526031148736&sdata=uIf6X6f4o349Rg6LSBtVlpIXeqzCk4kDyXjSZjRzWbE%3D&reserved=0
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By Drawing 

This helps the user to plot data by defining their own shapes. The user can use the ‘Drawing tool bar’ to 
draw the following shapes:  

• Freehand drawing  

• n-sided polygon 

• Circle 

• Rectangle 

The user can further edit the drawn shapes by using the following options in the Drawing tool bar: 

• Edit  

• Erase 

• Fill color 

• Stroke color 
 

 
 

 
 
 

Note: While creating an n-sided polygon, use the ‘Esc’ key from keyboard to close the shape.  
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By File within By Drawing 

Within the ‘By Drawing’ Option, there is a ‘By File’ Option available in the drop-down.  

 
 
This helps the user to plot data by uploading .zip, .shp, .kml or. geojson file and filter records on the plotted 
shapes as per the uploaded file. Thus, the user can visualize records as per his requirement within a 
specific shape. 
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By Territory 

This helps the user to plot the data defined in a particular sales territory. 
The user can select multiple territories in ‘Select Territory’ option and 
respective Datasource & view to plot the territories along with the 
records assigned with them. 
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By Template 

This helps the user to plot the predefined search criteria in Detail Map. The user can save the search 
criteria as a template and use the ‘By Template’ search option to quickly plot the data with that search 
criteria. This helps the user to save a considerable amount of time.  

 

For example, if any user is assigned with a task where 
the requirement is to regularly plot ‘My Active Accounts’ 
records in 2 miles of a particular location and filter a 
particular Industry, then the By Template option can be 
beneficial. 

 

The User can plot the required criteria on the map 
and use the button ‘Save template’ to save the 
search criteria as a template and define the access 
level of the Template while saving the template as 
described below: 

• Personal – The users can limit the usage of 
this template to themselves 

• Public – Anyone in the organization can 
use this template 

Apart from saving information of Plot Records, 
Category card, and filters from Grid, it also saves 
the Zoom level & Center of the map. 

 

 

Note:  

• Please assign ‘Maplytics User’ security role to Team Maplytics before exploring this 
functionality.  

• If user saves a template with Proximity search and current location as blank, while 
plotting the template, the current GPS location of the logged-in user will be fetched and 
the results to the Proximity search will be plotted around the user’s current GPS location.  
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Default Template 

User can set the Default Template within their respective Configuration Detail record and view the 

predefined search criteria saved in the template plotted by default on the Detail Map.  

To set a template as Default, user need to Go to the Maplytics App > Settings > Maplytics Configuration 

Details > Respective User Configuration Detail record > General > Default Template > Select required 

template.  

 

 

When clicked on the ‘Detail Map’ button, it will plot the default template selected in the respective user’s 

Maplytics configuration detail record by default on the map.  

Note: Default Template will not open if, 

• User selects a few records in Entity home grid and then clicks on Detail map button. 

• User expands a dashboard to open on Detail map. 

• User has saved Default template with search criteria other than Proximity Search and uses 

the ‘Map’ button on a specific record and opened the map  
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Note: Default Template will not open if, 

• User selects a few records in Entity home grid and then clicks on Detail map button. 

• User expands a dashboard to open on Detail map. 

• User has saved Default template with search criteria other than By location/ Proximity 
Search and uses the ‘Map’ button on a specific record to open the map. In this case, the 
respective record will be plotted on map. 

• User has set Area of Service on a record and is using the ‘Map button’ on the record to open 
the map. 

Note: Below are some exceptional cases for Default template where the plotted data might vary.  

• If Default template has been saved with search criteria By Location and the user uses the 

‘Map’ button on a record to open the Map, in this case, the respective record will be plotted 

as the current location along with other records selected within the Default template. 

• If Default template has been saved with search criteria Proximity Search and the user uses 

the ‘Map’ button on a record to open the Map, in this case, the respective record will be 

plotted as the current location replacing the initial current location set in the template. Thus, 

the records will be plotted within the specified radius from the respective record’s location 

which is now the current location on the map.   
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Search Record 
Once the records have been plotted, a search bar appears at top center of the map. This search bar can 
then be used to search any specific record from among the plotted ones using the primary attribute. 

 

 

 

As in the above example, the Industry of ‘Engineering’ displayed for the search entity appearing in the bar 
above is derived from the second column of the Quick Find View. 

This search zooms the map to the area where the required record is plotted. The preferred pushpin blinks 
in quick succession to highlight its position from among the records. 
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Finding a particular record from among many becomes easy with this feature. 
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Cluster map 
 
The user can select this option to group the closely positioned pushpins into a cluster. A cluster shows the 
number of pushpins in the cluster. The user can zoom in further to break down the cluster into smaller 
clusters or zoom out to group closely positioned clusters into one. 

 

Cluster Area  

The user can hover on any cluster to see the ‘Cluster area’ which shows the data spread. The data spread 
is based on the area covered by the pushpins existing in the cluster.  
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Spider cluster   

The user can click on any cluster to view the pushpins existing in the same in the form of a ‘Spider cluster’. 

 

 

 

 

 

 

 

 

 

 

Note: Spider clusters can be visualized only for records less than or equal to 50.   
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Category  

Users can choose any attribute for the selected entity to categorize the data on the map and visualize the 
pushpins color-coded based on the selected attribute. The category card will further help the user to 
differentiate between the pushpins. 

Multiple categories for multiple entitles 

User can plot entities on the map and can also select attributes for the datasources selected to categorize 
them. The screenshot below shows the categorization of the records of Account, Lead and Opportunity 
based on the attributes Annual revenue, Rating and Estimated Revenue respectively.  
 

 

 
 
 
 
 

Note:  

• User can choose respective categories for different entities.  

• The user can define the color as well as shape of pushpins for each parameters of category. 
Refer to Pre-Define Colors for Category section for further details.  

• User can also choose the field attributes to be visible in Category list. Refer to ‘Setup Entity Map’ 
section of Installation Manual for further instruction. 
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Multiple categories for single entity  

Users can also plot a single entity records categorized by multiple 

attributes e.g. Account records categorized by Open revenue, 

Originating lead, Owner. The user can choose an entity twice or 

thrice with two or three different views respectively and choose 

required attributes for the respective views to categorize the 

same entity with different attributes. User can select a maximum 

of three attributes to categorize a single entity. 

 

 

 

While plotting a single entity categorized by three attributes, 

three category cards will open up for the three attributes. For 

example, the screenshot below shows Accounts plotted on the 

map which is categorized by three different attributes viz. Annual 

Revenue, Industry and Owner and three different cards have 

opened up for each of them.  

 

Note: User can select a maximum of three attributes 
to categorize a single entity.  
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The category cards shown above states which category is represented by which pushpin. The categories 

are represented with the following three different parts of every single pushpin, , ,  

All the above three icons combine to form a pushpin which will represent the plotted records. Each of 
the three parts represent three different categories with different colors shown within the category card. 
For example, the category card ‘Account – Annual revenue’ shows that the icon represents the 
Account records that belong to different ranges of Annual revenue with different colors. The 
category card ‘Account-industry’ shows that the icon represents the Account records that belong 
to different industries with different colors and the category card ‘Account-Owner’ shows that 

the icon represents the Account records that belong to different owners with different colors. 

In case, the user has selected only two attributes in order to categorize the entity records, the 

pushpin that will be used to represent two categories will be . 

The plotting of categories follows AND condition. This means that if the user deselects a category in one 
category card, then all the pushpins for records that belonging to that category will be hidden from the 
map even if any of the records belong to any other categories as well. For instance, if the user deselects 
the category of Annual revenue between 5000-10000, then all the pushpins for the records that belong 
to this category will be hidden from the map even if any of these records belong to other category like 
owner or industry. 
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In the screenshot below, three categories have been selected viz. Annual Revenue, Industry and Owner.  

 
In the screenshot below, only two categories have been selected viz. Annual Revenue and Industry.  
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Set colors and shapes for pushpins  
 
The users have the ability to define colors and shape of the pushpins to visualise the records plotted on 
the map as per the requirement. This will help the user to differentiate between the records that belong 
to different views or categories.  

Set pushpins from map 

Users can select the pushpin of their choice with the desired color, right from the Detail Map while 

visualizing CRM records on the map.  

Set pushpins for views 

While plotting records using the Plot card, users can select the required colors and the shape of the 

pushpins for the records of the view within the Datasource section in the Plot Records card. Once the 

color or pushpin are selected, it will instantly reflect on the map. 

 

Set pushpin for categories 

While plotting CRM records along with categorization, user can select the color and shape of the pushpins 

and also save the selection for future use. Once the categorized data is plotted, user can go to the 

respective category card, change the color and shape of the pushpins and click on ‘Save’ to save the 

pushpins selected for future use. 
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Configure pushpins in Entity map for new category 

To set the colors and shape of the pushpins for the categories for any entity, the users have to follow the 
below steps: 

• Go to Maplytics App > Settings > Entity Maps > select the entity map for required entity > Category 
configuration.  

 
• Click on the plus ‘+ New Entity Category’ in the subgrid to open the new Entity Category form. Select 

the name of the category attribute in the Category text box and save the form. 

• The user can select only OptionSet, Two options, Numeric, String, Lookup and Money attributes to 
define category colors. 

• Colors and shapes will be auto-populated, the user can further set their own preferences. 
 



Maplytics™ – User Manual 

 

Page 54 of 386 

   

Category configuration for users 

User can open a category from the Category Configuration tab by going to Maplytics App > Settings > 

Entity Maps > select the entity map for required entity > Category configuration. They can change the 

colors and shape of pushpins to view the same on the map using the following buttons. If user has saved 

some colors and pushpins for categories from the map then those saved selections will be shown here.  

• Save : User can change the colors and pushpins and click on this button to save the selection 

• Auto-Set : This button helps to set the colors and pushpins randomly 

• Discard Changes : If user has made any changes to the colors and pushpins, they can click on 

this button to discard the changes done 

• Set to default : User can click on this to set the selection of the colors and pushpins to default 

which has been selected by Maplytics admin or System admin. 

 

Category configuration for admins 

System Admin and Maplytics admin can also check the colors and pushpin selection in the entity map. 

Along with this, they will also have the ability to set the required colors and pushpins for all the Maplytics 

users as well. To do this, admins can go to the Maplytics App > Settings > Entity Map > Respective Entity 

map > Category Configuration > Select required category. 
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Admins will be able to view two Option lists, one for themselves as a user and one for Default selection. 

The User Option list will work the same as explained above. The admin can further take some actions 

within the Default Option List using the following buttons.  

• Apply to all : Admins can select the required colors and pushpins and click on this button to 

save the selection for all Maplytics users 

• Auto-Set : This button helps to set the colors and pushpins randomly 

• Discard Changes : If admin has made any changes to the colors and pushpins, they can click on 

this button to discard the changes done. 

 

 

Note:  

• Selecting pushpins and saving the selection for categorized CRM data is only available for entities 
plotted with single category. 

• The selection of pushpins saved will be available for the respective logged-in user only. 

• If a category does not exist in the list of categories created in the respective entity map, then 
while saving the pushpin selection, the category will be created automatically for all the users. 

• If a user has not selected any preference for pushpin colors and shapes for any category, the user 
will be shown the visualization of the pushpins on the map as per the selection saved by the 
Maplytics admin or the system admin in within the Default-Option list of the category in the 
respective entity map. 
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Data Grid in Detail Map 

The Data Grid is available at the bottom of the Detail map which can be opened using the yellow button 
‘View Data’. All plotted pushpins represent a unique record in Dynamics CRM and data grid helps the users 
to access these records from the map screen, filter the data further and perform some mass actions. Order 
of columns in the grid depends upon the Dynamics CRM View selected to plot the data and in the case of 
Marketing Lists & Maplytics Dashboard records, it is same as that of the Entity-View selected in Entity 
Map. The users can also customize the data columns to be visible in the grid by adding/removing columns 
from the Entity view.   

 
Filter & Sort Data: 
The user can use the filter present on the top of every column to filter the data further selecting any of 
the conditions and entering the respecting value.  
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User can see the filter icon at the column header to understand based on which column the data has been 
filtered. Further, user can also click on any of the column header to sort the data and can see the arrow 
icon at the column header to understand based on which column the data has been sorted. User can 
deselect some of the records and see at the bottom the number of records selected from the list

 
Reset: 
This will reset the grid to the initial search. 
 
Parent Record / Related Record: 
This is useful when the user is dealing with plot related records functionality. The user can switch between 
child data and parent data using this button. 
 
Resizable Data grid: 
Double click on     Expand button to view the data grid in full screen. Double click on      Collapse 
button to view the default size of the data grid. Use can also click once and drag to resize the data grid to 
the desired size.  
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Highlight pushpins 

User can click on any record within the Data Grid to highlight the respective pushpin on the map. User can 
also click on any pushpin on the map to highlight the respective record in the Data grid.  

 

Mass Action Buttons 

The user has the option to take actions on the plotted records like adding to route or executing the 
workflow on selected records in the grid. Defined mass actions are as follows: 

• Add To Route: This option will add selected data points to the route. The user can add at max 25 
data points to the route 

• Save Data: The selected records can be saved as static Marketing List or Personal View in 
Dynamics CRM 

• Change Owner: The user can assign the owner of the plotted records by selecting a user or a Team 

• Manage Territory: The User can assign or change the territory of selected records 

• Send Email: The user can send a mass email to the selected records. User can select any one the 
available email templates or a new email to write their own content. User can also choose to keep 
the recipient as To/Cc/Bcc in the email.  
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Select regarding: If user needs to send bulk emails and also wants to keep a specific record in the 
Regarding field into the email. They can select the option of ‘Select Regarding’. To view this option, 
they can follow the steps mentioned below.  
o Open the respective record to be set in Regarding field from the ‘Map’ button on the record. 

In the screenshot below, we have taken an Account ‘Gourmet to your door’ as an instance.  

 
o Now plot the required records to whom the mail has to be sent and Go to Mass actions to 

choose the option of ‘Send email’. Here, we have plotted Contacts.  

 
o Once clicked on ‘Send Email’ from ‘Mass Actions’, user can select the option of ‘Select 

Regarding’ and  the Account that we plotted earlier ‘Gourmet to your door’ will be set by 
Default within the Regarding field. 
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• Execute Workflow: The user can execute any on-demand workflow with this functionality 

• Export To Excel: The user can use this feature to export data from the map to excel. This 
functionality adhere to CRM security roles, if the user does not have the permission to ‘Export 
Data to Excel’ in CRM then that user will not be able to export data from Maplytics 

• Create Activities: User can create activities for non-activity Entity records currently selected in 
“View Data grid.” The user can define the Activity, Subject, Schedule Start date and Schedule end 
Time, Duration,  Owner(User/Team) and Priority. The activities selected in respective Entity maps 
can be seen in the list of activities available to creare using the button of “Create activities”. By 
clicking this button below window will open and the activities will be created based on the inputs 
given in the window by the user. 
 
For example: If a user selects the appointment as the activities to be created for 20 records plotted 
on the map. Now if they select the Schedule start date to be let’s say 1st August 2022 at 10 am 
and schedule end time to be 5 pm along with the duration as 1 hour. So the appointments will 
start getting created for record 1 at 10 am for 1 hour and record 2 at 11 am for 1 hours and so on 
till the appointment for record 7 is created for 1 hour till 5 pm. Here it meets the schedule end 
time i.e. 5 pm. Now for the rest of the records will be handled in the follwing days. So the 
appointments for the next 7 records will get created for the next day i.e. 2nd August starting from 
10 am, each for an hour till 5 pm. Likewise, the appointment for the rest of the 6 records will get 
created for the third day i.e. 3rd August 2022.  
The user can also select the required owner or the record’s owner for the appointments being 
created. If the user has selected ‘Record’s owner’ in the space for owner, the appointments will 
be assigned with the owner of the respective record i.e. if Record 1 has user A as the owner, then 
the appointment for the Record 1 will be User A itself.  
 

Note: This option will be visible only if the map has been opened using map button on a record.  
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• Associate Records: This helps the user to associate a record with the plotted record(s) on map.  

To do this, user needs to open the map using 'Map' button on the record they want to associate. 

In the below screenshot the Account record is being opened using the ‘Map’ button. 
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Once the map is opened, plot the required Entity & View to associate the Account. Now, click on 

‘Mass actions’. In the below screenshot, Contacts are plotted on the map using Proximity Search.  

 
Within Mass Actions, click on ‘Associate Records’to open the window. Here, the relationships 

between both of the entities, the records plotted and the record from which the map has been 

opened will be listed. User can select the relationship through which they want to associate the 

records . Here, the record from which the map was opened earlier has been selected by default. 

User can also select another record as per their requirement to associate with the plotted records.  

 

 

Note: This option will be visible in Mass Actions only if the map has been opened using map 
button on a record.  
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o Associate records with many-to-many relationship: ‘Associate records’ feature can 
also be used for many-to-many relationship. Users can associate multiple records of 
an entity with another related entity record. The related entity record can be an 
existing or new one. 
For an instance, we have two entities Doctor and Patient with many-to-many 
relationship. Let’s say, the user opens the record of ‘Dr Danny’ of the entity ‘Doctor’ 
and clicks on ‘Map’ button to plot the record on the map.  

 
Now in the map, user can choose entity Patient as Datasource to plot multiple patients 
on the map. In this case, the Active patients are plotted. 

 

Now user can click on a record of Patient and select the option of ‘Associate Records’ from 

the Tooltip card to open the window. Here, select the relationship Patient N:N Doctor.  
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Associate with Existing Record: This option can be selected in order to view the list of the 

Existing Records of the Middle Entity. Here select a record from the list and ‘add’ to 

associate the records of the Entities Doctor and Patient.  

 

 

• Auto Scheduling: This can be used to create a schedule for one or more users automatically.  Refer 
to the section of Auto scheduling to know how Auto Scheduling works.  

Note: Associate record for many-to-many relationship can only be performed through 
the tooltip card and cannot be performed from the Mass Actions. 
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Tooltip Card  

User can click on any pushpin to open a tooltip card. 
This card will display the data like Address, Account 
name etc. along with the Image set for the record. 
These attributes and image can be configured within 
the Tooltip Mapping section of the Entity Map so as to 
show on the Tooltip card.  
 
 
 
 
 
 
 
 

 
 
 
 
 
User can also set a particular record as ‘Origin’, 
‘Destination', ‘Add to Route’ under Direction, ‘Set as 
Current Location’ and ‘POI location’ from the Tooltip 
card.  
 
 
 

 
 
 
 

User can also click on the pushpin of that contact to 
open the tooltip card to view the respective image on 
the card. User needs to select the ‘Default Image’ field 
in the field of ‘Entity image’ in Entity map to view the 
record image on hover and tooltip card. Please refer to 
the installation manual.  

 

 

 

 

 



Maplytics™ – User Manual 

 

Page 66 of 386 

   

Moreover, the user can hover on the image appearing in tooltip 
card to zoom in the image.  

 

 

 
 
 
 
 
 
 

Quick Call to Action Buttons 

User can associate quick action buttons. This helps in saving time while switching between screens to take 
actions. First four actions are the default actions and cannot be changed by the user. User can further add 
actions for creating records for activities and related entities. The default records are as follows: 
 

• Change Owner      : Assign an owner to the respective record by selecting a user or a team 

• Open Record      : Open record directly from this screen to edit any field 

• Plot Related Record      : Plot One-to-Many Relationships/Related records of a particular record as 
shown below: 

 

 
Select the required relationships from the list and click on ‘Plot Records’ button. Related records will be 
plotted as shown below. Use ‘Parent Records’ button to switch between Parent and Related records data 
points.  
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• Run workflow   : The user can execute on-demand 
workflows on an individual record. When clicked on this 
button, it will open a window which will list down all the 
on-demand workflows available for respective Entity as 
shown below:  

 
 
 

• Follow and Unfollow: When clicked on the pushpin the 

respective Tooltip card opens that has actions on it. The follow/unfollow action is visible among 

them.  
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This action enables the Admin and all the users to follow the record.  

 

In this way, the activities performed on the record by the users get listed within the timeline. The emails 

sent, contacts updated, and more can be easily viewed and tracked. With these updates, the admin or 

the users can understand the activities performed on the record by any of the users or the admin 

himself. 
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The same button switches to unfollow if the record is already being followed. With ‘unfollow’, the 

activities will not be visible on the timeline. This means User A will not be able to check if an Email invite 

has been shared with the record by User B, and so on. 

The principle of follow/unfollow in Maplytics is similar to the one within Dynamics 365 CRM. 

The user can define this action under ‘Advance Settings’ in Entity Maps. Go to Setting > Entity Map  

Advance Settings > Tooltip Card Actions or refer to the ‘Setup Entity Map’ section of the Installation 

Manual for further instructions. 
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The user can customize the rest of the actions according to their requirement. For example, user can add 
Email, Add Task, Appointment and Quote and many more.  

• Email      : Send email to this record  

• Add Task      : Add task to this particular record 

• Appointment      : Schedule appointment with this record  

• Quote       : Create Quote related to the plotted entity record 
 

The user can define these actions under ‘Advance Settings’ in 
Entity Maps. Go to Setting > Entity Map > Select Required 
Record > Advance Settings > Tooltip Card Actions or refer to 
‘Setup Entity Map’ section of Installation Manual for further 
instructions.  
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Hover 

User can hover on Dynamics CRM Records plotted on the map to have a quick glance at its details and the 
record image. The user can have a maximum 6 different attributes here apart from the title attribute. 
Refer to the ‘Setup Entity Map’ section of Installation Manual for steps to configure attributes and image 
on hover.  
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Reset Map 

User can use the button of ‘Reset Map’ to reload the map with the initial Detail map 
settings.  
 
 
 
 
 
 
 
 
 

 
 
 

Note:  

• This action will clear all the data plotted on map 

• The refresh map button will show the same data on the map in the following conditions: 
o Expanding the map or plotting a route from a dashboard 
o Using the map button from an individual Entity record page 
o Plotting a route or a template 
o Plotting records by selecting the records from the Entity records page 
o User had set a default template for the Detail map 
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Summary Card 

The user can click on any enclosed area to get the summarized information of the plotted records in that  
area in a summary card. The area clicked will get highlighted and the respective data will be visible in the 
data grid. The user can customize the settings for this under the Summary card section in the respective 
‘Entity Maps’. Refer to ‘Setup Entity Map’ section of Installation Manual for further details.  

 
With territories plotted on the map, Summary card also provides a button to ‘Open Record’ that can be 
used to open the respective territory from the map itself and ‘Change Manager’ to change the Territory 
Manager for the selected territory.  
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Layer Menu 

This helps the user to select the required data among the multiple data plotted on the map. The user can 
use the toggle buttons on the Layer menu card to show or hide the required layers of the data to be shown 
on the map without removing the same from map. 

 
The layer menu card will show the following icons for the respective layers mentioned:  

 

Layer type Icon Layer type Icon 

Data source 
 

Territory 
 

Route 
 

POI 
 

Proximity  Cluster Pushpin 
 

Drawing Shape 
 

Shape Operation 
 

Region Shape 
 

Overlay- Shape file 
 

Plot-child 
 

Territory Management – 
Shape file  

 

 

     Note: Layer menu card is collapsible but a user cannot close this card exclusively. 
 

     Note:  

• Layer icon for Data source layer, POI layer and Plot-child layer will change depending upon 
pushpins visible on map 

• If category is selected in the plot card, the layer menu card will show only the default pushpin 
for the Data source layer 
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Show/Hide Labels  

User can click on the ‘Show label’  button to view the labels for the pushpins, regions as well as 
territories plotted on the map. User can again click on ‘Hide Label’  to hide the labels showing on the 
map. The option for showing/hiding labels is available for every individual layer of data plotted on the 
map. 

 

 
 

Show/Hide Territory List 
With territories plotted on the map, layer menu 
will also show an option of Show/Hide List for the 
layer of territories. User can click on the 

show/hide list button  option to open the list 
of territories plotted on the map.  
 

User can select or deselect the territories which are 
required to be plotted on map. User can further 
change the name, select a color and select the 
manager for the respective territories and also save 
the same with the ‘Save’ button within the ‘Territory 
List’ card. 
 
 
 

     Note: Show Labels is available for less than 5k records. 
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Download map 

Using the Download map button, the user can download the 
map as visible on the screen. 
 
 
 
 
 
 
This helps the user to get the map download for using offline. 
 

 
 
 
 
 
 
 
 
 
 
 
 

Note: Download map is not supported for Internet 

Explorer. 
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If the user has plotted data with categorization, the map will be downloaded with a legend showing the 
categories. 
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Contextual Menu 

User can right click on the map to open Contextual menu. It provides 
commonly used features in Dynamics CRM like creating a new record, set 
origin/destination or selecting map zoom level on the map, etc. The 
contextual menu provides the following options:  

 
Create New Record:   
User can right-click 
anywhere on the map or 
POI result icons and 
create a record for that 
particular location. This 
will save the record with 
the details of the address 
and the geo-coordinates 

(Latitude & Longitude).  
 

 
 
 
 

Directions:  

• Set As Origin: This option will set the address of the pushpin/map location as the start location of the 
route. 

• Set As Destination: This option will set the address of the pushpin/map location as the end location 
of the route. 

 
Add to Route: This option will set the address of the pushpin/map location as a middle waypoint(s) of the 
selected route. For example, the user has selected Point A & B as orgin & destination respectively for a 
route and now clicks on the ‘Add To Route’ option, the Point B will remain as the destination and will 
become the Point C. The address of the selected pushpin will become the Point B of the route. 
 

Set as Current location: User can click on any pushpin or anywhere on the map to set the address of the 
pushpin or the location as the current location respectively, which can be used for Proximity search.  

 
Set as POI Location:  
This option helps the user to set the location for the Point of Interest (POI) searches like ATMs, restaurants, 
Airports, etc. Setting the POI location, user can search for various Geo-tagged & Bing mapped locations 
around it. 
 
Save Settings: 
User can save the default settings for the following options. These settings will be saved in the 
Configuration details record of the user: 

• Current location: This will save the location as the default current location. 

• Map zoom level: This sets the zoom level and map center for the Map. After this setting is done, 
whenever the user will open the Detail Map, it will be zoomed down to the location set here.  

Note: Create new record option will not available 

for existing record pushpin 
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• Origin: This sets the location as the default origin. 

• Destination: This sets the location as the default destination 
 
Street View: 
User can right click on map to get a Street view option. This will open a 3D view of the Map 
 
Show Territory: 
User can right click anywhere on the map or at any record to select the option ‘Show Territory’ from the 
Contextual menu. This will plot the respective territory to which the selected location or the record 
belongs to. Further, user can click on ‘Hide territory’ from Contextual Menu to hide the plotted territory. 

 
 
User can also click on any pushpin to get a contextual menu. Along with the 
options mentioned above, this will provide the following options: 
 
Open record: User can open the record form right from the map and can 
further edit the details for the record. 
 
Actions: User can perform the following actions on the pushpin selected: 

• Add Task: This option helps the user to create a new task in Dynamics 
CRM regarding the selected record. 

• Schedule Appointment: The user can use this option to create a new 
appointment for the selected record.  

• Manage Territory: The user can assign/re-assign a territory to the 
selected record from the map and hence can manage the territory. 
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Multi-Address Plotting 
 

If the entities in CRM contains more than one addresses, users can plot the records based on multiple 

addresses at once. This feature will enhance the visualization experience of those records that have 

presence in multiple cities or states etc. Admins can configure required addresses within the Entity map 

of the entity so as to view the option of selecting the addresses to plot the same on the map. Please refer 

to the Entity map section of the Installation manual to know how to configure multiple addresses in 

Maplytics to plot records based on multiple addresses.  

 

While selecting the Datasource and View within the Plot records card, user can click on the ‘Select address’ 

to select the addresses based on which they would like to plot the records. This will open the window 

that lists out all the addresses saved within the ‘Address Attribute’ Section of Entity map. User can select 

the required addresses and click on Search.  

 

 

 
The below screenshot shows the Accounts plotted based on the two addresses, Billing address and 

Shipping address. Here 4 records have been plotted and due to the two addresses of each of the records 

the map is showing 8 pushpins in total.  

 

Note: The icon for ‘Select Address’  will only appear if multiple addresses are configured in the 
Attribute Mapping section of the respective entity map.  
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The Layer menu will list both of the addresses, the Billing address and the Shipping address for Accounts.  

 
While working with any enclosed shape like proximity, drawn shape or a territory, user can click on the 

enclosed shape to view the Summary card. The below screenshot shows Proximity search performed on 

the above Accounts that were plotted based on two addresses Billing address and Shipping address.  
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With the click on the outer circle it is showing the 

Summary card for the same. Within the summary card, 

the Total Records will show the count based on the 

total number of pushpins plotted on the map i.e. 7 

pushpins in total.  

The second section of the Summary card shows the 

classification of the count of records based on the two 

types of the addresses i.e. 4 pushpins are plotted 

based on the Billing address and 3 pushpins are plotted 

based on the Shipping address.  

In the third section, it shows the summary of the 

Annual revenue and the no. of Employees based on 

the actual(unique) count of the records plotted i.e. 4 

Accounts.  
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Point of Interest (POI) Locations  
User can search for any geo-tagged Bing-mapped locations called points of interest (POI) like ATMs, 
restaurants, hotels, coffee shops, etc. near a specified location. This can also be plotted alongside the CRM 
data. User either can right-click on map to set the location as the POI location or can directly enter the 
required location in the POI card.  

 
User can either click on any of the POI icons or manually search for required POI location by entering the 
respective keyword in the search bar. 
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Based on the selected POI location icon or the entered keyword, the results will be loaded. 

 

 
 
Apart from plotting POI data, user can also add the plotted businesses in Dynamics CRM record as leads, 
accounts, contacts, or any custom entity by using the Create New Record option in the POI card or 
Contextual menu. (Refer to Contextual menu section) 

 
 

Note:  

• The option to enter a keyword to search POI locations is only available while searching in USA.  

• For each POI location search, only 25 locations will be plotted on the map.  
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Proximity Search  

User can search for the nearby records around a required location using Proximity Search. This will help 

the users to understand the proximity of the nearby records in regards to the selected location. There are 

two different options to perform a Proximity Search: 

1. Proximity by Distance  

2. Proximity by Time.  

 

Current Location: User can select any location or a record as the current location. This is used to specify 

the center point for the Proximity search. By default, this field displays the address stored in the Maplytics 

personalized record of the logged in user. This is always represented by a green color pushpin on the map 

and also indicated right next to the current location message box.  

Proximity by Distance 

This option will calculate the straight-line distance between the current location and all the points which 
fall in the proximity parameter as shown below: 
 

 
 
Enter the radius for the Proximity search. The user can also add decimal values with a scale of 2 for the 
radii. The Proximity can be provided either in Miles or Kilometers. The User can also hover over a pushpin 
and see the distance from current location.  
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Concentric Proximity Search 

This new addition to Proximity based on Distance allows users to perform up to 3 proximity searches 
simultaneously. The user needs to enter the distance values separated by a comma (,) and all the points 
that fall in the defined proximity parameter will be plotted. 
 

 
 
The Concentric proximity zones are represented by different colors for easy visual analysis. The user can 
also click on individual proximity zones to highlight the circle and open the Summary Cards for that 
proximity parameter. 
The user can also filter the data points based on the proximity zone and their proximity distance from the 
current location in the ‘View Data’ grid.  

 
 

 
 
 

 
 

Note: User can enter integer value from 0.1 to 2000 for distance proximity search. 
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Show Travel Distance 

While performing Proximity Search by Distance or Time, if the user wants to see the actual travelling 

distance from the current location till each of the individual pushpins, they can select the checkbox of 

‘Show Travel Distance’ to view the Shortest Travel Distance on the hover and view data grid.  

 

Show Travel Distance for Truck 

 

Once the user selects the option of ‘Show Travel Distance’, user 

will get an option to an Asset and Hazardous material. This will 

provide the list of the assets created in the Asset entity within 

the CRM. If the user wants to search for the shortest travel 

distance for truck, they can choose to select the respective 

Asset and if any Hazardous material is being carried out or select 

none from the following list: 

• Combustible   

• Corrosive   

• Explosive   

• Flammable   

• Flammable Solid   

• Gas   

• Goods Harmful To Water   

• Organic   

• Poison   

• Poisonous Inhalation   

• Radioactive  

• Other 

• None 

 

Note:  

• If user has not selected any asset here, by default, the travel distance will be calculated as 

per driving by car.   

• The feature of ‘Show Travel Distance’ based on driving by truck uses a separate key. Every 

time the travel distance is searched based on driving by truck, 3 transaction limits of the key 

are consumed for each pushpin that appears within the proximity. 
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Proximity by Time 

This option will calculate how many points fall in ‘x’ minutes or hours of driving distance from current 
location.  The Proximity can be provided in either Minutes or Hours. The User can also hover over a 
pushpin and see the distance from current location.  
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Overlay 
 

This helps user to view the Dynamics CRM records along with 
shape/excel files, existing territories, and ArcGIS Online feature 
layers plotted on the map. User can also view the ‘layer menu’ to 
select or deselect the layers so as to show or hide the same 
respectively. Using Overlay user will easily be able to understand 
and analyze the data spread in required shape file regions and 
territories. 
 

User can select the following three options: 
• Territory – This option helps the user to select among the 

list of existing territories 
• File – This option helps the user to select among the list 

of shape/excel files. The file should be in a territory in 
order to be visible in the list. 

• ArcGIS - This option helps the user to select from among 
the live feature layers hosted by ArcGIS Online. The file 
need not be in territory and can be used even with real-
time changes. 

 
Let us consider a Sales and Marketing Manager of a Food and 
Beverage brand planning on Sales Area expansion. He would 
want to know the demographic of the Target Group in the new area. Knowing the information about 
the population, their age groups, spending capacities, buying patterns, sex ratio, etc. would be helpful 
in categorizing them and designing marketing campaigns for them. The sales processes could then be 
planned to cater to young adults, working population, senior citizens, and so on. Strengthening the 
location data with demographics would help in better decision making. With the overlay feature, the 
Manager would be able to- 

• View the existing territories within the new area by plotting them over the map and know the 
head count in all the territories along with other details 

• Import external shape/ excel files, save them in CRM and plot the same over the map to view 
the territorial data in-depth, or 

• Seamlessly integrate the ArcGIS Online feature layers with the Map and view the collated data 
of the new area 

Viewing this organized data spread in the new sales area he might decide on targeting 3 main territories 
with the right population age group and create marketing and selling plans for the young adults there. 

 

Overlay by Territory 

User can select the option of Territory and select the territories they want to plot. Along with this, they 

can also select any datasource & view. This will help them view the datasource records along with the 

Overlay of territories selected.  
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Overlay by File 

User can select a excel/shape file saved in CRM to plot the same on the map. Further users can select the 
following options as well. 
 
Category Attribute: An attribute can be selected to categorize the regions plotted by file.  
Summary Attributes: One or more attributes can be selected to show the same in the Summary card. The 
attributes selected within the ‘Configuration’ of the saved file in the Territory Entity will be selected by 
default. User can deselect them in the plot card and can select other attributes. 
 
Users can also uncheck the option of ‘Plot All Regions’ if they do not want to plot all regions from the file. 
In this case, they can right click at any location on the map to select the option of ‘Show region’ from the 
Contextual Menu. This will help them to view the region for the respective selected location. User can 
again click on ‘Hide Region’ from the Contextual Menu to hide the region for the respective selected 
location. Further, user can also open the respective territory within which the file is saved using the ‘Open 
record’ button on the Summary card.  
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Save Shape/Excel file in territory 

A file should be saved in a territory in order to be visible in the list of the files to be plotted as an Overlay. 
Follow the steps mentioned below to save the shape/excel file in a territory: 

• Go to Settings > Business Management > Sales Territories > Create a sales territory > Save  

• Go to Territory Map Preview > Select Option > Shape file/Excel file > Save 

 
Save Shape file 

Within the Territory Map preview, user can select the option of ‘Shape file’ and select the color to view 

the regions in the same. 
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Save Excel File 

Within the Territory Map preview, user can select the option of ‘Excel File’ to select an excel file to the 

territory. User can also select the color to view the regions in the same. They further need to select the 

following options in order to save the excel file as per their requirement: 

Select Region Type: User should select the region type based on which the boundaries of the regions from 

the excel file is to be plotted.  

Select Region Value: User needs to select the column from the excel file that contains the values for the 

selected Region Type.  

Select Main Region: User needs to select the column from the excel file that contains the value for the 

biggest region for the selected Region type in order to plot the regions accurately. For example, if the 

Region type selected is Postal code, so the Main Region should be preferably Country. If the column of 

country is not available then the column with the values for respective States or Cities can be selected.  
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Convert Overlay to territory  

User can use this button to convert an overlay record 
to a territory. After the overlay record is converted, it 
becomes a territory which can be searched in the 
option of ‘Territory’ in Overlay.  

 
 
Overlay by ArcGIS Online 
 
User can begin with establishing a seamless integration between Maplytics and ArcGIS Online with a few 
configuration steps. Once done, the user can select from among the various feature layers available online 
on the ArcGIS portal and plot the same on the map. Further users can select the following options as well. 
 

 
 
Category Attribute: An attribute can be selected to categorize the regions plotted using the ArcGIS feature 
layer. The plotted regions are differentiated with multiple colors. This visual representation makes 
regional analysis easy. 
Summary Attributes: One or more attributes can be selected to show the same in the Summary card. All 
attributes will be selected by default. User can deselect them in the plot card and can select other 

Note:  

• Supported file types for shape files are .shp, .kml and .geojson and excel files are .xlsx, .csv 

• In a territory, either a shape/excel file can be saved or geographies can be created  

• Only one shape/excel file can be saved in one Territory 
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attributes. Attributes selected in summary attribute field will also be displayed when hovered over region 
boundary. 
  

Integrate ArcGIS Online with Maplytics 
 
For a seamless integration and to be able to utilize the hosted feature layers of ArcGIS Online, the user 
can perform the following steps- 
 
 

Single factor authentication 

Go to Settings > Maplytics Configuration Details > Default configuration record> ArcGIS 

 

In case the multi factor authentication option has not been enabled, the user can enter the URL from the 

ESRI Website, user name and password.  
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Once saved, the user can avail the option of ArcGIS in the Overlay dropdown. 

 

 

Multi- factor authentication 

The user needs to have a Developer’s Account on the ArcGIS Website by Esri. Once an account is created, 
the user will have his user name and password. Having access to this account, the user can select the 
feature layer that is suitable for his overlay needs. 
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Go to Settings > Maplytics Configuration Details > Default configuration record> ArcGIS 

 

 
 
The user needs to provide a Client ID and a Secret Code that is available for the developer account. On 
saving the entered configuration record, a redirection URL gets generated.  
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This URL needs to be put up on the ArcGIS Developer’s Account.  
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A new button, ‘Authenticate Esri’ will then appear on the Maplytics Default Configuration page. On clicking 
this button, the user will get a window to enter username, password and code.  Once done, a connection 
will be established between Maplytics and user’s ArcGIS Account allowing an access to Feature Layer 
hosted by Esri 
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A code will then be sent on authenticator app which the user has selected while enabling multi factor 
authentication.  
 

 
 
The User then needs to enter that code and avail an access to an option of ArcGIS in the Overlay 
dropdown. 
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Census data Visualization 

This feature helps the user to visualize census data on the map. Census data provides the information 
about the population for a whole country or parts of country. Visualization of this data on Maplytics will 
help the user to analyze various information of the required area in a country like Housing units, Area 
land, Area water, population demographics, etc. and take strategic decisions. A few census data are 
available by default within Maplytics. These default census data are provided by Bing maps for USA. User 
can also plot their own census files on the map which contains census data. User can configure categories 
to see colored regions as per the configuration and also configure attributes to see on Summary card and 
hover on region. 
 
To plot the census data, user can choose the option of ‘Files’ in the feature of Overlay. Please refer to the 
section of ‘Overlay’. Further users can select the following options as well. 
 
Category Attributes: An attribute can be selected to categorize the regions plotted by file.  
Summary Attributes: One or more attributes can be selected to show the same in the Summary card. The 
attributes selected within the ‘Configuration’ of the saved file in the Territory Entity will be selected by 
default. User can deselect them and can select other attributes. 

 

Configuration for Census data 

User can configure the Census files provided by Maplytics in the Dynamics CRM. Please refer to the section 
of ‘Configure’ in Installation manual for the steps to configure. This will save some census files in CRM 
provide by Maplytics. 
 
While configuring the census data into Dynamics CRM, territories will get created within which the 
respective census data will be saved in the form of geographies. To view the saved census data, Go to 
Settings > Business Management > Sales Territories. Following are the territories for census data saved 
on configuration: 
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• England-Cities 

• Germany-Postalcodes 

• NewYork-Postalcodes 

• USA 111th Congressional Districts 

• USA Counties  

• USA States 

• USA-Postalcodes 

Configuration for attributes 

User can configure the attributes available in the census data/shape files to show on the map, create 
categories for attributes and select the colors to visualize the categorized data on the map. This allows 
the user to frame the data how they want to view on the map.  
 
Go to Settings > Business Management > Sales Territories > Territories with census data/shape files 
saved > Configuration  
 

• Attribute Configuration: 
o Summary Attributes:  

User can select the attributes to show on the Summary card shown on the click on the 
regions in the census data/shape file plotted on the map.  

o Hover Attributes: 
User can select at a maximum of 6 attributes that will be shown on the hover on the 
regions in the census data/shape file plotted on the map. 

o Data grid Attributes: 
User can select the attributes from the census data/shape file to be shown as columns in 
the data grid in Detail map. 

 
• Category Configuration 

User can create categories for the attributes in the census data/shape file. Creating categories will 
help the user to view the categorized census data for the required attributes in the desired colors. 
Some categories are provided by default for configured census data. User can click on              New 
button to create a new category for any attribute. User can also click on     ‘Edit’ and       ‘Remove’ 
to make changes or delete the existing categories respectively.   
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▪ Create filters and define colors 
After clicking on Edit/New button, user can filter the attributes and define colors for the 
ranges of the filtered attributes.  
o Attribute: This shows the name of the Attribute for which the category has been 

created/will be created.  

o Display Name: User can type a name for the category which should be displayed in the 

list of the categories. 

o Save: User can click on save button to save the changes made. 

o Discard: User can click on Discard button to discard the changes made. 

o Filter: User can set various filter conditions for the category. 

o Value: User can set values for respective filters set. 

o Color: This can be used to set colors for individual filters set. The user can click on the         

Auto Set button to set random colors for all the values.  

o Add/Remove: Click on Add or Remove to add a new filter or delete the filter respectively. 
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After the user has created categories, user can plot the census data along with an attribute selected to 
visualise the categorised Census data on the map as shown below: 
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Shape Operations 

With the help of Shape operations, users can perform Binary operations on the shapes drawn on the map. 
These operations can only be performed under the Search option of ‘By Drawing’ in the Plot card and 
Territory management section. Please refer to the section of Territory management for the shape 
operations in Territory management.  
 
User can open the ‘by drawing’ search option and right click on the shapes and can choose the option of 
‘Shape operations’. The following five operations can be performed on the shapes: 

Difference 

This highlights the shape(s) obtained by subtracting the overlapped ones from the selected shape  
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Intersection 

This highlights the shape(s) where the selected shape and other shapes overlap. 

 

Union 

This adds all the shapes overlapped on the selected shape 
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Union Aggregate 

This performs union operation on all the shapes that are drawn on the map. If a shape does not overlap 
with any other shapes, it highlights such shapes and the union of the rest of the overlapping shapes.  

 

Disjunctive union  

This highlights the shapes that are not overlapped and lie in the selected shape & the shapes that are 
linked with the selected shape. 
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Undo – While performing operations, user can use the option of ‘Undo’ to go only one step back 
into the binary operations performed  
Reset – Using the option of reset, user can remove all the operations that are performed on the 
shapes drawn on the map  
 
 
 
 
 
 
 
 
 
 
 

Note:  

• To perform any operation, two or more shapes should overlap.  

• For Union Aggregate, there should be more than one shapes with or without overlap. 

• The highlighted shapes are new shapes as resultants of the operations performed. User 
can click on the highlighted shapes to view the summary card and the data in the view 
data grid.  
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Territory Management 

Territory management helps the user to create new territories manually as well as automatically and align 
the existing territories as well to get proper distribution of territories. User can plot required regions, draw 
shapes or directly upload shape files/excel files to get the required regions plotted on the map to create 
territories for the same. User can create multiple territories automatically based on count of records or 
use the territory Alignment tool to select the required regions and create new territories for the same. 
While creating multiple territories automatically, user can also save the territories as a draft and rework 
on the draft to get the territories created as per the requirement. Further, user can plot the existing 
territories and edit them to get proper distribution of territories.  
 

To access Territory Management, Go to Detail map > Territory Management  

 

 
 
 
User can use the search options to plot shape files, 
excel files, search by region, draw a shape or plot 
existing territories on the map. There are five search 
options:  

• By File 

• By Region 

• By Drawing 

• By Territory 

• By Overlay 

• By ArcGIS 
 
 

Note: Users other than System Admin, can use Territory management only if they are given the role 

of Maplytics Territory Manager 



Maplytics™ – User Manual 

 

Page 111 of 386 

   

By File 

This helps user to plot the shape files and excel files on the map that store geographical information and 
attributes of the geographic features. User can plot the following two types of files:  

• Shape files: The supported file formats are .shp, .kml and .geojson 

 
• Excel files – The supported file formats are .xlsx, .csv 
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By Region   

 
This options helps the users to search for regions on the map by 
City, State, County, Country, PostalCode, PostCode Sector, 
PostCode(Outward Code), PostalCode Area.  
 
 
 
 
 
 
 

 



Maplytics™ – User Manual 

 

Page 113 of 386 

   

By Drawing 

This helps the user to draw a shape on the map using the Drawing Tool Bar. 
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By Territory 

This helps user to plot the existing territories on the map.  
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By Overlay 

Users can select this option of ‘By Overlay’ to select any 

shape/excel file saved in CRM to plot the same on the 

map. Users can also select an attribute within ‘Category 

Attribute’ to categorize the regions plotted on map. Also, 

they can select one or more attributes within ‘Summary 

Attribute’ to show on Summary card when clicked on any 

region plotted on the map. 

 

  

 

Note: If user has plotted any territory or shape/excel file using the feature of ‘Overlay’ within the ‘Plot 

records’ card and moves to ‘Territory Management’ card so the option of ‘By Overlay’ will retain the 

selection of the same while working with Territory Management. 
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By ArcGIS 

This option helps the user to select from among the live feature layers hosted by ArcGIS Online. The file 

need not be in a territory and can be used even when updated in real-time.  

A seamless integration can be experienced with the 

online files. Users can choose this option to select 

any live feature layer hosted by ArcGIS Online to 

plot the same on the map. Users can also select an 

attribute within ‘Category Attribute’ to categorize 

the regions plotted on map. Also, they can select 

one or more attributes within ‘Summary Attribute’ 

to show on Summary card when clicked on any 

region plotted on the map. 

 

 

 

 

Note: If user has plotted any territory using the feature of ‘ArcGIC’ within the ‘Plot records’ card and 

moves to ‘Territory Management’ card so the option of ‘By ArcGIS’ will retain the selection of the 

same while working with Territory Management. 
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Layer Menu 

This helps the user to select the required data 

among the multiple data plotted on the map. 

The user can use the toggle buttons on the 

Layer menu card to show or hide the required 

layers of the data to be shown on the map 

without removing the same from map. If user is 

using the ‘Plot Records/POI/Directions card’ 

and has plotted Datasource Records, POI 

locations or Route and has proceeded for 

Territory Management, the plotted layers of 

data will be retained and will be listed in the 

section of ‘Plot/POI/Direction Layers’ of the 

Layer menu. The data plotted using the 

Territory Management card will be listed in the 

‘Territory Management Layers’ section of the 

Layer menu. 

Territory Alignment Tool 

This tool has four options respectively as mentioned below:  

• Select/Deselect: User can select 
regions/shapes/territories one by one on the map 

• Deselect All: User can deselect all the selected 
regions/shapes/territories on the map 

• Select Multiple: This is a freehand selection which helps the user to select multiple 
regions/shapes/territories on the map 

• Delete: User can delete the shapes/regions/geographies plotted on the map  
Note: If the delete option is used on the existing territories, it will delete the selected 
geographies from the existing territories. 
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Create new territory  

User can select some of the regions/shapes using the ‘Alignment Tool’ and right click to create a new 
territory.  User can also select the required manager who will be responsible for the respective territory. 
 

 

 
 

 

Note: Users who have already been assigned as a manager for another territory will not be visible in 

the list of users to be selected as a manager of the territory. 
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Auto Territory creation 

User can create territories automatically based on a shape/excel file and count of records plotted on the 

map to get the desired number of balanced territories. To do this, user can go to Territory Management 

and use the option of ‘By File’ to upload a Shape file or an Excel file to get it plotted on the map. User can 

also choose the option of ‘By Overlay’ to plot a saved shape/excel file on the map. 

 

Now, user can go to the ‘Plot Records Card’ and select the required ‘DataSource’ and the respective ‘View’ 

to plot the same on the map. These records will be distributed among the territories that are to be created.  
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Using the options of ‘Select’ or ‘Multi-select’ from the ‘Alignment Tool’ user can choose the required 

regions and right click to select the option of ‘Create Territory’ to open the window. Here, user can select 

the option to ‘Create Multiple Territories’ and enter the number of territories they want to create out of 

the selected regions on the map. In the screenshot below, we have entered 4 for an instance.  

 

 

 

This will calculate the number of records and divide the selected regions automatically to get 4 balanced 

territories. By default, territories will be named as Territory_0, Territory_1, Territory_2 and so on. User 

can change the names as per their requirement.  

 

Note: Only those records which lie within the regions selected will be considered while creating 

multiple balanced territories.  

Note: The count of records in the territories created automatically might vary slightly. 
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User can also set the required user as a manager for the territories processed, by clicking on the ‘Select 

manager’ icon. 

 

 

 

Note: Users who have already been assigned as a manager for another territory will not be visible 

in the list of users to be selected as a manager of the territory. 
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User can also set the colors for the territories using the option of ‘Fill color’.  

 

User can further choose to take an action on the territories 

processed on the map by using ‘Actions’. There are three 

Actions available: 

Create: If the user is satisfied with the territories processed, 

then they can choose this option to create the territories 

processed on the map within the CRM.  

Save: If user needs to work on the territories processed to 

further make any changes or take an opinion on the same from 

a colleague, they can use this option to save the territories 

processed as Draft Territories within the CRM. 

Realign: User can further rework on the territories processed 

using this option. This will allow the user to revise the number 

of territories processed.  

Assign territories to record 

If user chooses to create territories from the ‘Actions’, then 

after creating the territories, user will be asked if they want to 

assign the territories created to the respective records plotted 

on the map. User can click on ‘Yes’ to do so.  
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Register to Windows Service 

If the number of records is more than 9K, then user needs to register to Windows service in order to create 

multiple territories. With more than 9K records plotted on the map when user tries to create multiple 

territories then the below message will be shown and these records will be processed by Windows Service. 

When the user clicks on ‘Confirm’ then it will create the territory records with the status ‘Process by WS’ 

and Windows Service will process these territories by distributing the records to create the specified 

number of balanced territories based on the number of records.  

 

Windows service runs at the interval that user will set. For example, user can set it for every 1 hour. When 

windows service runs and finds territories with the status ‘Process by WS’ then it will process them one 

by one. It takes one territory and performs the logic and distributes the records properly to create the 

respective number of territories and while updating these territories it changes the status of those 

territories to draft. User can plot this draft territory and create the respective territories into the CRM. 

To install Windows Service, user can go to the ‘Batch processing tool’.  
 

1. To get the tool, Extract the Batch Processing tool .zip file from the extracted Zip folder of 
downloaded Maplytics solution.  
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2. Run the BatchProcessingTool as Administrator as shown below. 

 

 
 

3. Once the user runs the tool, the following window will open where they need to enter the 

credentials and click on ‘Next’. 
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4. Once user clicks on ‘Next’, it validates the credentials and if credentials are valid then the below 

window shows up. Here, user needs to select the option to Install/Uninstall Territory Distribution 

Windows Service and click on ‘Install’. 

 

 

 

 

Once clicked on ‘Install’ the ‘Territory Windows Service’ will be installed in the PC as shown below. 

User can click on ‘Uninstall’ to uninstall ‘Territory Windows Service’.  
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User can start and stop windows service using ‘Start’ and ‘Stop’ button. 

 

To update the windows service run interval, user needs to change “RUNINTRERVAL” in the app 

config of windows service (Inogic.Maplytics.TerritoryDistribution.exe.config). 

 

 

 

Note: Make sure the PC in which the Windows Service is installed is running all the time because if 

the PC is turned off, the Territory Windows Service will also get turned off and it will not perform 

any task. 
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Draft territories 

If the users need to further work on the territories 

processed or needs to make any changes, they can choose 

the ‘Save’ from the Actions and save the territories 

processed as a ‘Draft territories’ within the CRM. 

 

After saving a draft, user can use the option of ‘By Territory’ within the ‘Territory Management’ card to 

plot the draft territories saved in CRM and rework on them. Further, user can choose to save it again as a 

draft with the updates done or create the respective territories in the CRM using the option of ‘Create’ 

from the Actions. If user wants to create the respective territories from the draft, they can also choose 

whether or not to delete the respective draft territory.  
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Create territory on one click 

User can create multiple territories with a single click on ‘Create Territory’ button. User can plot shape 
files or excel files on the map to view the shapes required as geographies and follow the steps mentioned 
below to create territories: 
 

By Shape file 

After plotting a shape file on the map, user can click on the ‘Create Territory’ button to create a new 
territory with the plotted shapes as geographies or create the plotted shapes as geographies into a 
selected existing territory.  

 

 
User can provide the name for the new/existing Territory to be created and select the column from the 
excel file for ‘Select Geography Name’ and the respective names of geographies will be fetched from the 
file.  
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By Excel file 

After plotting an excel file, user can click on the ‘Create Territory’ button to create territories with the 
shapes plotted on the map as Geographies. The names of the territories and the respective Geographies 
will be fetched from the excel file.  
The excel file should in the supported file format as mentioned below.  
Name: Name of the Geography. 
Search Option: Bulk geography feature is available only for the ‘By Region’ option, so this value should 
always be ‘1’. 
Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in other format 
then the default color (Blue) will be set. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Region 
Type: There are 6 region types that the user can define to create the geography. (Country, State, County, 
City, PostalCode1, PostalCode2). 
Region Value: If the user needs to create the geography based on Postal Code, then they can define the 
postal code values in this column. To define multiple geographies in single territory, use the comma 
separator (,). 
Territory: This is a lookup value to define which geography belongs to which territory. 
Manager: The names of the users can be provided here. While creating territories, the managers for the 
respective territories. However, the column of ‘Manager’ is not mandatory to be in the excel file. 

Note: For Territory management: 

• The column of ‘Territory’ should contain the Names of the territory(ies) 

• Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in 

other format then the default color (Green) will be set.  

• There are 8 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2, PostalCode3, PostalCode4). 
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Alignment of Existing territories 

 
User can plot the existing territories and align them to get the proper distribution of the regions. User can 

use the following two options to align the territories. 

Move to 

User can select some geography(ies) of one or more territories and move it to another plotted existing  
territory or create a new territory. This will remove the geographies from the original territory.  
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Copy to  

User can select some geography(ies) of one or more territories and copy it to another plotted existing 
territory or create a new territory while keeping the geography in the original territory.  
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Edit Existing Territory 

Users can modify the boundaries of the drawn shapes in existing territories using this option. To do this 

first plot the existing territories on the map. Now, go to the ‘Territory List’ and click on the ‘Edit’ button 

for the required territory and click on the required shape to modify.  

 
Now user will be able to drag the boundaries of the shape to modify it according to the requirement. 

 

Note: Only the territories that contains shapes created using the Drawing tool can be edited by Edit 

Existing Territory option. 
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Shape Operations in Territory Management 

User can perform Binary operations on the shapes, regions or territories plotted on the map. User can 

select the shapes on which they want to perform operations and right click on them to select the Binary 

operations. There are five Binary options available: Difference, Intersection, Union, Union Aggregate and 

Disjunctive Union. Please refer to the section of the Shape operations to know more about these Binary 

operations.   

 

 

 

 

 

 

Note:  

• The shapes should overlap each other to be available for performing shapes operations 

• There should be a layer of drawing overlapped with the shapes on which binary operations has 
to be performed 

• The required shapes should be selected before performing Binary operations 
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Defining Geographies for Sales Territory using Maplytics 
 

The users can create sales territories using the native Dynamics CRM ‘Sales Territories’ feature and define 
geographies for the sales territories on a map using Maplytics. 
 
To create geographies for sales territory, go to Settings > Territories and click on ‘New’ to create a sales 
territory. With Maplytics a ‘Geographies’ Entity is added on the territory. User can use this feature to 
visualize and create geographies for the sales territory. To create a new geography, click on ‘Add New 
Geography’. 
 

 
In the section ‘General’, provide a name for the Geography. 

 
Within the section ‘Map preview’, the user has the option to visualize the geography on a map ‘By Region’ 
or “By Drawing’. The ‘By Region’ option lets the user to plot the geography based on region types and the 
user has the freedom to choose the color for the plotted region.  
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The ‘By Drawing’ option lets the user to plot the geography by drawing a shape on the map and the user 
can further edit the shape based on their needs.  

 

Note: User can define multiple geographies for a single territory. 
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Hierarchal Territories 
 

Dynamics 365 supports the hierarchy of territory where user can manage multi-level territories. If an 

organization has enabled the Hierarchical territories in the CRM, the users can plot the territories to plot 

and manage multi-level territories. So, if there are any child territories created for the selected territories, 

then those will also get plotted on the map along with the selected territories.  

User can select and plot the territories on the map using the three ways as follows: 

• By Territory using plot card in Detail map 

User can open the Detail map to choose the icon of ‘By territory’ in the Plot card. They can 

select the territories from the list, select Data source & view and click on Search to plot the 

same. 
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• By Territory using Territory Management in Detail map 

Within the Detail map, user can click on the icon of ‘Territory Management’  and select the 
option of ‘By territory’. Now, select the territories and click on Plot.  

 
• Overlay in Detail map 

User can use the option of Overlay within the Plot card or Territory management to plot the 
territories. 
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Note:  

• System admin and Territory Manager will have access to all territories 

• The visualization of the territories to the rest of the users will be dependent on the usage of the 

option of ‘Show All Territories’ within the Default Configuration Detail record > Advanced 

Settings > Configure Option>Show All Territories. If the option is not selected then the user will 

be able to view only the territories for which they are the Territory Manager or the member. 

• If a user is the Territory Manager or the member of a parent territory, then the user will be able 

to access the child territories as well, either using the Maplytics maps as mentioned above or 

by going to the respective child territory records within the Territory entity to visualize it in the 

Territory Map Preview.  
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Bulk Geographies by uploading an Excel file 
 
The users also have the option to upload multiple 
geographies through an Excel files supported by 
CRM using the Bulk Geographies feature in 
Maplytics. 
 

 
 
To upload the geographies in bulk, the user 
first needs to export an Excel template. Go to 
Settings > Data Management > Imports > 
select the ‘Excel Templates’ and then click on 
the ‘Create Excel Template’ option. 
Select the ‘Excel Template’ and in the ‘Select 
data’ section, select the ‘Geography’ Entity in 
the ‘Filter by entity’ field. 
 
Click on ‘Edit Columns’ and select the below 
columns; 

 
 
 

The excel file should in the supported file format as mentioned below: 
Name: Name of the Geography. 
Search Option: Bulk geography feature is available only for the ‘By Region’ option, so this value should 
always be ‘1’. 
Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in other format 
then the default color (Blue) will be set. 
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Region Type: There are 6 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2). 
Region Value: If the user needs to create the geography based on Postal Code, then they can define the 
postal code values in this column. To define multiple geographies in single territory, use the comma 
separator (,). 
Territory: This is a lookup value to define which geography belongs to which territory. 
 

 

Note: For Territory management: 

• The column of ‘Territory’ should contain the Names of the territory(ies) 

• Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in 

other format then the default color (Green) will be set.  

• There are 8 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2, PostalCode3, PostalCode4). 
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Multiple Territories assigned to records 

If a user needs to assign more than one territory to the entity records, user can enable the feature of 

Multiple Territories for a record. This feature will help the user to visualize records which lie in single or 

multiple territories. After assigning the territories, they can plot the territories to visualize the respective 

records lying into them.  

To start using the feature of Multiple Territories for a record, user can follow the steps mentioned below: 

Step 1: Enable Multiple Territories 

Go to Settings > Maplytics > Maplytics Configuration Details > Default configuration detail record > 

Configuration option > Select ‘Enable Multiple Territories’. 

 

Step 2: Creating N: N relationship of entity with Territory. 

Go to Settings > Customizations > Customize the System > Entities > Select Entity > N: N Relationships > 

New Many-to-Many Relationship 

Step 3: View the list of territories assigned to a record 

User can add a sub-grid to show the territories that an 

entity record is associated with. This step is optional, 

even if a sub grid is not added, the assigned territories 

will get associated with the records in background. 

 

 

  

Step 4: Select relationship for the field ‘Territory Relationship’ in Attribute mapping section of Entity 

map. 

Go to Settings > Maplytics > Entity maps > Attribute mappings > Territory Relationship > Select ‘Entity - 

Territory’ relationship   

 

 

 

Note: User cannot undo this option, once selected and saved. 
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Step 5: Assign territories to records 

User can either run Batch Processing tool or the Inogic.Maplytics.AssignTerritoryWorkflow on the 

records to assign the territories to the records.  

After assigning the territories, user can choose the Search option of ‘By territory’ to plot the territories 

along with the respective records. The below screenshot shows two territories plotted on the map, ‘Staten 

Island – 10306’ and ‘Staten Island- Mid’ which overlap on each other and have pushpins in common as 

highlighted.  
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Detail Map on CRM Dashboard 

To include the Maplytics Detail Map component on the Dashboard, click on the ‘new’ button and select 
‘Add Web Resource’. Select ‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource. The User can 
further modify this web resource by including some custom parameter. For Example, if the user wants to 
plot a route from a dashboard like Appointment Planner. The user can automate the complete process.   

 
 
Custom Parameter(data) : You need to provide the Custom Parameter(data) as  

• <Dashboard Name>||dashboard||true 

• Appointment Planner||dashboard||true 
 
The recommended number of rows in formatting is minimum 10. 
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Saved Template Visualization on CRM Entity Form 

Users can include the Maplytics Detail Map component that loads a saved template associated with the 
Entity record on the Entity Form. For this, the user needs to create a ‘Template’ lookup field on the Entity 
form where user can select the required Maplytics Template. The user also needs to select the name of 
that field in the ‘Template’ field under ‘Define Attributes’ section on the Entity Map for that particular 
entity. 

 
On the Entity form, the user needs to ‘Insert’ a new Tab and select ‘Add Web Resource’. Select 
‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource. The user now needs to add a Custom 
Parameter for the saved templates. The recommended number of rows in formatting is minimum 10. 

• Custom Parameter (data): Provide the Custom Parameter(data) as savetemplate  
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Now, when the user selects a Maplytics Saved Template on the ‘Template’ lookup field on the Entity form, 
the selected template will be plotted on the Detail Map component added on the Entity form.  
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Routing Optimization  
 

User can select some locations on the map as waypoints to plot an optimized route. User can follow this 
route to visit the required locations and complete their meetings. User can also redirect themselves for 
turn-by-turn navigation in order to reach the right location on 
time.  
 

Directions Card 

Directions card provides the user with all the routing features. 
The user can open the Directions Card directly by clicking on 
Directions tab.  
 
 
The Directions Card also opens up when the user adds a 
waypoint(s) to the route either through the Contextual Menu, 
ToolTip Card or using the ‘Add to Route’ mass action. User can 
select the required waypoints and the leaving/arriving time. The 
user can drag and drop the waypoints to change the order of 
route 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Note: The user can add a maximum of 25 waypoints in 

the direction functions. 
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Once the waypoints are selected, the user can choose the 
mode of transports like Driving, Walking, Transit or Truck 
to view the route.  
The user can select different options to reduce the time, 
toll, highways, etc. by clicking on the Options button. Some 
of these can be auto-selected using Maplytics 
Configuration Settings.  
 

 

Truck Route 

To start using Truck route, please contact crm@inogic.com. Once the user has contacted us at 
crm@inogic.com for the truck route, the user will be provided with a Maplytics license with Truck routing 
enabled into it. To start using Truck route, user needs to update the license and then configure as 
mentioned below:  
 
Update the license: Go to Maplytics App > Settings > License registration > Click on Activate. 
Configure: Go to Maplytics App > Settings > License registration > Configure Tab > Configure. Here the 
Asset data will be configured to the users Dynamics CRM. 

 

Note: To start using Truck route, please contact 

crm@inogic.com 

mailto:crm@inogic.com
mailto:crm@inogic.com
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Assets data configuration will create some sample records for Trucks which user can select while using 
the feature of Truck routing. User can click on the ‘New’ button to create new records of Assets. They can 
also edit and save changes to the configured Assets.   

 
 
After the sample records for trucks have been configured, user can enable the truck routing. To enable 
truck routing, go to Maplytics App > Settings > Maplytics Configuration Details > Default Configuration 
Detail record (with no user) > Advanced Settings > Enable Truck Route.  
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User can choose the truck icon on the Direction card to plot 
the route for a truck. On the selection of the truck icon a 
window will pop up to enter the Asset details.  
Within the Asset Details, user can either select one of the 
sample truck types or select the custom option to enter their 
own details and then click on ‘Go’ to plot the route.  
  
 

 
 
The Asset Details will be as follows:  
 

1. Asset type: The asset for which the route has to be plotted. It can be selected from the following 
list of configured sample records. User can also 
select ‘custom’ to enter their own details.  
• Trailer 1 
• Trailer 2 
• Trailer 3 
• Trailer 4 
• Trailer 5 
• Trailer 6 
• Custom 

2. Axles: The number of axles. 
3. Dimension Unit: The unit of measurement of 

width, height, length. Can be one of the following 
values:  

• Meter  

• Feet 
4. Height: The height of the vehicle in the specified 

dimension units. 
5. Length: The length of the vehicle in the specified 

dimension units. 
6. Width: The width of the vehicle in the specified 

dimension units.  
7. Weight Unit: The unit of measurement of weight. Can be one of the following values. 
8. Weight: The weight of the vehicle in the specified weight units. 
9. Hazardous Materials: List of one or more hazardous materials for which the vehicle is 

transporting. Possible values are: 

• Combustible   
• Corrosive   
• Explosive   
• Flammable   

Note: Optimization of the route with the Shortest 

Distance will not be available when Truck is selected as 

the mode of transport. 
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• Flammable Solid   
• Gas   
• Goods Harmful to Water   
• Organic   
• Other 
• Poison   

• Poisonous Inhalation   
• Radioactive  
• None 

 
 

Optimize Direction 
 

This can be selected from the Options. This option will 
provide the users with the optimized route direction 
between their waypoints keeping Origin & Destination 
as fixed waypoints based on Shortest Time or Shortest 
Distance as per the selection.  
 
 
Once the user clicks on ‘Go’ the route will be plotted and 
the directions will be available on the Directions Card.  
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User can view all the details regarding the pushpins on the route in the view data grid in the tab named 
as entity_Route. for example: Contact_Route. Each waypoint on the route will be represented by a 
pushpin. User can hover or click on any pushpin to view the details of the waypoint. If the waypoints are 
records saved within Dynamics CRM, it will open the tooltip card on its click showing the respective data 
configured for tooltip card.  
 
 If the waypoint is just a location, on a click it will open a 
tooltip card showing its address and an icon which can be 
used to create a record for the location. This includes the 
Default origin and destination pushpin as well.  
 
 
 
 
 
 
 

 
 
User can also choose to show or hide the layer of 
route from the layer card.  
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Send Route email: 
 

Maplytics also helps the user to send the route 
details in an email using ‘Send route email’ 
button. This will automatically fetch all the 
details of the route like the account details, 
waypoints, links etc. in the mail.  
 
Users can click on ‘Show Complete Route’ to see the entire route with all the waypoints or use the 

individual ‘Route link’ to see the routes between two waypoints. The user will be redirected to their 

preferred navigation app, Google, Waze, or Apple Maps, to visualize the route on the map based on the 

app selected in their Map Configuration Detail Record 

 

 
 
 
Maplytics admin or System admin can add four more columns to the existing route table to view more 

details on the same. To do this, they can go to Maplytics App > Settings > Entity maps > Entity map of 

respective entity > Advanced Settings > Route Email Configuration > Attributes > Select Attributes > Add.  
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Save Route: 

 Users can also save their route plotted. The route record 
will also save the information like number of waypoints, 
total distance and time for the route. User can add the 
route to an existing route or save the route with a name 
& owner as a new route.  
 
  

 
User can also update any route using the ‘Update’ 
button. User can search for routes existing in the 
required duration using the option of ‘Open Saved 
Routes’ and click on the ‘Update’ button for the 
required route.  

 
 
 
 
 
Multiple Routing: 

With Multiple Routing, the users are enabled to view multiple saved routes together on the map. For 

instance, if Shawn is the manager of a Sales Team of 5 members, he can create and save the travel 

routes for these 5 sales reps. Later, using multiple routing, he can view all 5 routes for all the team 

members on the map. 



Maplytics™ – User Manual 

 

Page 156 of 386 

   

 

Up to 10 routes can be viewed and saved at once within a certain date range on the map in this manner. 

All the Routes are color-coded in color legends. The same color legend is followed in the Saved Route 

Summary Card and on the Map. 
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Users can add or remove waypoints within any of these saved routes as per requirement. When clicked 

on one of the route names, the map zooms onto it. The route that needs an edit can be clicked upon, 

and the details open on the map. Additional waypoints can be added or deleted from the route panel. 

Clicking on Go, the route reroutes itself and can be saved using the save button. 

Back on the Saved Route Summary Card, the Update button can be clicked upon and the changes shall 

be reflected in that respective route. 
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Clear Route: 
 
The user can use the Clear Route button to clear the 
route from the map. This will just clear the route and 
directions card will still be opened for further use.  
 
 

Unified view for Route and Records 

While user plots the data and then creates a route, both the plotted data and the route will stay on the 
map for an easy Route Management. This makes it easy for the user to add more waypoints to the route 
and also update the route with the added waypoints. 

 

 
 
 
 
 

Note: The route will remain on the map unless the user clicks on the ‘Clear Route’ button or closes the 

Directions Card 
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Default Origin and Destination 

User can set default origin and destination for Route management.  
Go to Settings > Maplytics > Maplytics Configuration Details > Record of the user 

 
There are six options to select: 

• User Mailing Address - Reads address from User mailing address 

• User Other Address - Reads address from User other address 

• Business unit Bill to Address - Reads address from logged in user’s Business units bill to address 

• Business unit Ship to Address - Reads address from logged in user’s Business units ship to address 

• None - If user do not want to set default origin/destination 

• Other: It will have its own multiline textbox associated where user can enter their own address 
 

 
 
 
 
 
 
 
 
 
 

Note: If a user uses the “Plot route” button to plot a “Route” activity record on the  

Detail map, the Default origin/destination will not be set in the Direction card 
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Snap waypoint 

This helps the user to edit a plotted route just by dragging the route to the required point on the map. 
 

 
 
Drag to a location: User can drag a point on the route to a required location on the map. This will add the 
location as a waypoint at the dragged point in the route. This will also update the Directions card with the 
newly added waypoint. 
  
Drag to a pushpin: User can also drag a point on the route to a pushpin plotted on the map. This will 

detect the record and add the record’s location at the dragged point in the route. This will also update 

the Directions card with the newly added waypoint. 

 
Note: The option of snapping waypoints is not available for a route create for trucks. 
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Along the Route 

 This feature provides the user the ability to search the 

records that fall in the defined proximity along the route. 

The default value for Along the Route search can be 

configured in the Maplytics Configuration record. This will 

find all the records with the defined search parameter and 

that falls in the entered proximity along the route. 

 
 
 
 

 
 
 

Note: The user can add the value between 0 – 25. The user can also add decimal values with a scale of 2 

for the radius. 
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The Along the route records is also saved when the user saves the route. However, if the user has selected 
multiple Datasources on the Plot Card, only the first Entity and View combination in the Select Datasource 
will be saved for along the route search in the saved route. 
 
If the user has plotted data on the map and opens a saved route 
that has along the route parameter saved as well: 

• The user can either click on ‘Confirm’ to clear the plotted 
records and search along the route records with the 
Datasource saved in the route. 

• Or, the user can click on ‘Cancel’ to search along the route 
records with the existing plotted data, ignoring the 
Datasource saved in the route. 

 
 
If the user opens the Directions card directly without plotting the 
data or opens a saved route without the along the route parameter 
saved, they have the option to select the Datasource for the Along 
the route search directly on the Directions Card.  
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Route Redirect and Copy Route Links 

After plotting the route, user can use the 
‘Redirect’ button to open the ‘Navigation Links’ 
popup on the browser as well as the Dynamics 
365 App for Phones and Tablets.  
 
The user can click on individual links for route 
navigation from point A – B, B – C, and so on. User 
can also select the application within the User 
Configuration record to navigate the route. Refer 
the section of ‘Maplytics Configuration Details 
(Personalization)’ in the installation manual to 
select the application. These links will redirect the 
route to the app selected in the configuration.  
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Redirect with Google Maps 

User can view the turn-by-turn navigations on Google Maps site on desktop and Google Maps App on 
Phones and Tablets. User can also choose to view the complete route.  
 
 
 
 
 
 

Redirect with Waze 

User can view the turn-by-turn navigations on Waze site on 
desktop and Waze App on Phones and Tablets. This will show 
the navigation links from current location to the waypoints. 
 
 
 
 
 

Redirect with Apple Maps 

User can view the turn-by-turn navigations on Apple Maps on 
desktop and Apple Maps on iPhones and iPads. This will show 
the navigation links from current location to the waypoints. 
 
 
 
 
 
 
 
 
 
 

Note:  

• The maximum waypoints to show the complete route is 10 waypoints. 

• By Default, the navigation will be redirected to Google Maps. 

Note: The checkpoints should be under 3000 miles from 

the current location to view routes on Waze. 
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Redirection on mobiles: User can click on the route navigation 
buttons to redirect to the Google maps/Waze/ Apple Maps. 
The user can also use the ‘Copy Links’ button to copy the links 
to send them as an email or save it into a note.  
 

 
 

Note: 

• By default, the links will be redirected in Google 

Maps. 

• The links redirect on the Dynamics 365 App for 

Phones and Tablet works with Dynamics 365 

v9.x  

• For other devices and Dynamics 365 v8.2, users 

can use the ‘Copy Links’ button. 
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Print Route 

User can print a Route as well as the adjoining Map. 
User can plot a route on map, click on the ‘Print Route’ 
button to print the route. It will also print the Driving 
Directions as well.   

 
Clicking on the ‘Print Route’ button will open a new window with the map and Route on the page, which 
can be seen in the below screenshot. Click on the Print Icon to print the map and route instructions.  

 
 
t 

Note: 

• Routing requires a minimum of two waypoints provided to create a route. 

• A4 size paper with landscape mode is recommended while printing. 
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Proposed and Actual Route Tracking 

With Route Tracking, an optimized route can be plotted for a field rep by the Manager. However, in certain 
situations, the actual route followed by the rep would be different from the plotted one. The rep could 
have taken an uncommon shortcut, he could have taken a different turn to avoid the highway 
traffic/accident sight, or may have rushed away in between to address a personal emergency. These 
actions would take him away from the plotted route and the same can be recorded. 
The tracking of the actual route followed could help in analyzing the rep’s productivity, the new shortcut 
if more optimized could be incorporated into the route for the next time, or could give insights about 
frequent congestion, accident-prone regions, etc. 
 
Enable Route Tracking: User needs to enable the Real-Time tracking option for the route followed by the 
field user to be tracked. 
Maplytics > Settings > Map Configuration Details > Real-Time Tracking 
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Start Mobile Tracking: Within the Maplytics Mobile App, the user can 
start the tracking for estimated and actual route tracking.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

View Tracked Route:  The user can view the route plotted and followed with a few configuration setup.  
 
Maplytics > Settings > Routes > Route Entity > Route Activity Waypoints 
 

 
Clicking on the Blue ‘Navigate’ Arrow opens up the Detail Map with the route for that particular travel. 
 
Clicking the ‘Show Full Route’ button opens the Detail Map again with all the routes followed for all the 
waypoints for the Entity. 
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Route to a record 
 
Users can add the ‘Route to a Record’ tab to any entity to view the route plotted to a record’s location 
from their current location automatically. If user needs to meet any client, they can open the client’s 
record, go to this tab and view the route to reach the client’s location directly. Further, they can click on 

the Navigation button to navigate themselves with the turn-by-turn directions. They can also use the 
map to perform other Maplytics actions like Along the route, plotting more records etc.  
 
User's location will be represented by ‘A’ in map, while the record’s location will be denoted by ‘B’.  

 
 
Steps to add ‘Route to a Record’ tab to an entity form:  
 
Go to Settings > Advance Settings > Customize the system > Entities > Account > Main Form > Add a tab. 
Here we have taken Accounts form for an instance.  
 
Now select the tab and click on Insert > Add Web Resource (ikl_/Maplytics/Maplytics.DetailMap.html) 
The recommended number of rows in formatting is minimum 10. 
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Auto Scheduling 
 

Auto Scheduling helps users to create an optimized schedule to be followed on the field over a span of 
days by the concerned field professionals. The user can perform Auto scheduling on the required set of 
records (e.g., clients) to create Appointments and optimized routes, with the considerations of existing 
appointments, the preferred days of working, different meeting durations, availability of the selected 
users etc. This feature will help user to create appointments and optimized routes based on shortest time 
in order to provide an effective plan, hence saving the time and increasing the field productivity. 
 

Users can contact at crm@inogic.com to get the access of the feature and they will be provided with a 
Maplytics license with Auto Scheduling enabled into it.  
 

 
 
To perform Auto Scheduling user can go to the Mass Actions within the View Data grid. They can plot the 
Entity records on the map that are needed to be visited and open the ‘view data’ grid at the bottom to 
check the number of records plotted on the map and deselect the records that are not required.  

 
 

 
 
After plotting the required records to be scheduled for, user can Go to Mass actions > Auto scheduling. 
This will consider all the records that are plotted on the map and will proceed to the Auto Scheduling 
page.  
 
 
 

Note: The visibility of the option of ‘Auto scheduling’ into Mass Actions will be based on the Maplytics 

Security Template if any assigned to the user. Please refer to the section of ‘Maplytics Security 

Template’. 

Note: Auto Scheduling can be performed on a maximum of 100 records plotted on the map  

mailto:crm@inogic.com
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Auto scheduling card 
 

User can set the basic preferences as per the requirement so as to consider the same while creating a 
schedule. Users can also have these prefilled by setting default values for the preferences within their 
Configuration Detail Record. Please refer ‘Configuration Detail Record’ section Installation Manual to see 

configuration for Auto Scheduling. 
 
Consider Existing meetings: Select this option to consider existing 
meetings saved in CRM assigned to the selected users. 
 
Select users: Select the Maplytics user(s) to create Automated 
schedule for them. A maximum of 10 users can be selected to create 
an automated schedule. 
 
Period: The number of days the schedule should be for. The 
meetings will be distributed among the number of days selected 
here. User can choose any one option from the following:  
 

• 1 Day 

• 2 Days 

• 3 Days 

• 4 Days 

• 5 Days 

• 1 Week  

• 2 Weeks 

• 3 Weeks 

• 1 Month 
 

Duration: The time frame required for each meeting. User can 
choose any one of the following options. User can also change 
duration for individual meetings in Advanced Preferences. User can 
further change the duration of individual meetings in the ‘Advanced 
Preferences’. 

• 1 Minute 

• 5 Minutes 

• 10 Minutes 

• 15 Minutes 

• 20 Minutes 

• 30 Minutes 

• 45 Minutes 

• 60 Minutes 

• 75 Minutes 

• 90 Minutes 

• 120 Minutes 
 
Start Time: Time to start the schedule of each day. User can enter the time in 12-hour format (hh:mm)  
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End Time: Time to end the schedule of each day. User can enter the time in 12-hour format (hh:mm)  

Break Time: Starting time of Break for each day. User can enter the time in 12-hour format (hh:mm)  

Break Duration: Duration of the break during each day. User can select any one of the following options:  

• 0 Minutes 

• 5 Minutes 

• 10 Minutes 

• 15 Minutes 

• 20 Minutes 

• 30 Minutes 

• 45 Minutes 

• 60 Minutes 

• 75 Minutes 

• 90 Minutes 

• 120 Minutes 
 
Buffer time: User can add extra time to the schedule as buffer to be used in case of unforeseen situations 
to avoid changing the schedule. 

• 0 Minute 

• 5 Minutes 

• 10 Minutes 

• 15 Minutes 

• 20 Minutes 

• 30 Minutes 
 
Working days: User can select the days for which the selected users will be working. The meetings will be 
distributed only within the working days selected here. User can select any day between Sunday, Monday, 
Tuesday, Wednesday, Thursday, Friday, and Saturday. At least one day should be selected.  
 

 

Note:  

• If the logged-in user has set default values for the preferences in the respective Maplytics 
Configuration detail record, while opening the Auto scheduling section, the preferences will 
get prefilled with the same.  

• If the logged-in user selects any other single user, the preferences will get prefilled if there 
are default values set in the Maplytics Configuration detail record of the respective selected 
user.  

• If the logged-in user selects multiple users, the preferences will get prefilled if there are 
default values set in the Default Configuration detail record. 
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Advanced Preferences 

User can further click on ‘Advanced preferences’ within 
the Auto Scheduling card to select further preferences to 
be considered while creating an automated schedule.  
 
 
 
 
 
 
 
 
Meetings Per Day: User can select the average meetings that should be scheduled for a day. A minimum 
of 1 and a maximum of 20 meetings can be selected.   
 
Continuous Schedule: Instead of starting the route from the origin every day, if the route should be started 
on the ending location of the previous day, user can set it as ‘Yes’. For example: A user starts the first day 
from Brookwood in Alabama, USA to follow the route assigned and reaches Alexander city, Alabama which 
is the destination of the route for the day. Now, if the ‘Continuous Schedule’ is enabled, the user does not 
need to go all the way to Brookwood to start the route for the next day, instead the user can directly go 
to the first appointment scheduled for the second day, from Alexander City itself. 
 
Reschedule Existing Meetings: If the option of ‘Consider Existing Meetings’ has been selected within the 
Auto scheduling card, then the option of enabling ‘Reschedule Existing Meetings’ will be available. User 
can select ‘Yes’ in order to reschedule existing meetings. This might change the respective owners as well 
to get the highest optimization. If the existing meetings are needed to be met at the set appointment 
time, the user should select ‘No’.  
 

 
 

Note: If both Onsite and Offsite existing meetings have been considered, then, enabling reschedule 
existing meetings will make changes only to the Onsite meetings. 
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User Details  

Selected users will be listed here along 

with the space provided for the Origin 

and Destination locations for the same. If 

the default locations for Origin and 

Destination are set in the default 

configuration details of the users, the 

same will be prefilled here. If not, then 

user can click on ‘Edit’ and enter the 

required locations for Origin and 

Destination for the respective users. 

Location for Origin will be mandatory 

here.  

 

User can also uncheck any users in this list if they do not want to create an automated schedule for any 

user.  
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Meeting Details 

The details of the records selected to create the schedule will be listed here. Users can also deselect any 
record if they do not want to add the record to be considered while creating the schedule.  

 
User can also click on the individual duration of meetings to change it for the respective meetings as well 
as enter a value in the blank space to filter the data based on the entered value. In the below screenshots 
the data has been filtered by meetings with the duration of 30 minutes and city Staten Island. User can 
filter the data for with the values for other columns as well. 
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Existing meetings 

If user has selected ‘Consider Existing Meetings’ in the Auto Scheduling card, the Appointments, Bookable 

resource bookings etc. saved in CRM owned by the selected users will be listed here. User can also change 

the Meeting type of Onsite meetings to Offsite. They can further deselect the listed meetings or Activities 

they do not want to consider and also filter the meetings based on specified values. User can choose one 

among the options under ‘Select Meeting’, i.e. All Meetings, Appointments, Service activities or Bookable 

resource bookings to view the same in the list below that. Admins can also select the Activities within the 

Default Configuration Detail records that are needed to be considered here while Considering Existing 

Meetings.  

 

 
Once the User clicks on ‘Proceed’ a route based on user/resource selected will get planned and a schedule 
will be displayed on the calendar along with the plotted routes on map and a trip summary will get 
displayed for first day schedule. 
 
Consider a field rep, Mark, representing a pharmaceutical brand utilizing the schedule for his business 
trip. An Auto-Scheduling Calendar along with a Trip Summary Panel and a map with the travel route on it 
makes understanding the planned schedule easier for him. The resource legend is maintained the same 
for the route, the meeting details, and the trip summary. This makes visualization quick, especially for the 
users on the go. Mark can also get a quick access to the navigation directions and be aware of his next 
destination, in advance. He has the knowledge of the total distance he would be traveling in a day or every 
day for a week and also the total time of this travel. Overall, Mark will be better equipped with a proper 
plan, directions, and be punctual for the meetings. 
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Auto-Scheduling Calendar- 
The Auto-Scheduling Calendar on the left shows the schedule for the day/week of different users. Each 
individual user can be selected and an optimized schedule for them will be displayed. The meeting details 
as well as the allotted time slots can be viewed. The user can choose from the drop-down option available 
on the tool bar of the Calendar panel and view the schedule for day/week. An optimized route 
corresponding to the schedule in the calendar is plotted over the map. Every user is automatically assigned 
a specific route legend and the route is displayed in user specific colors for easy readability.  
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Though the map has routes plotted for all the users in the calendar, the route for the user currently 
selected is zoomed in the map view. 
 

 
 
 
In case of display being selected for weeks, the scheduling calendar shows all the meetings and their 
timeslots for all the days of the week. The days with no meetings are blank. All the days of the week and 
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the routes on the map follow the route legend. The optimized routes for all the meetings of the week can 
be seen on the map and the route legend aids in day-to-day differentiation. 
 
 

 
 

 
 
Trip Summary- 
The Trip Summary panel on the right shows the scheduled meetings for the day for the selected user It 
includes information about the origin and destination. The destination is assigned to the record that is 
hosting the meeting.  
For instance, if the first meeting starting at 8 AM requires the user to start from his office, the office 
location (A) would become the origin and the meeting location (B) would be the destination. For the next 
meeting, the first meeting location (B) would then become the origin and the next meeting location (C) 
would be the destination. This pattern continues throughout for all the scheduled meetings. 
The total number of meetings of the day, total time taken to travel to each of those meetings and all the 
meetings of the day, the total distance traveled for individual meetings and all the meetings scheduled is 
all shown on this panel.  
The origin and the destination of the multiple meetings are denoted by alphabets which are referenced 
on the route map as well. In case of a day’s view, the route legend at the bottom shows the color codes 
for different users.  
 

Note: The default view of the meetings and the route is of the first user added to the list   
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Turn-by-turn navigation directions can be seen when clicked on the down arrow below a meeting slot. 
 

 
 
 
In case of display being selected for a week, the trip summary is displayed for the first scheduled day. The 
route legend for the next scheduled days of the week is shown at the bottom. When the user manually 
clicks on the next scheduled day of the week in the calendar, the corresponding trip summary of that 
scheduled day is seen with total travel time and distance for the selected user. 
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Note: A change in the Entity Map shall reflect a change in the Title Attribute given to the destination 
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 Calendar Navigation Buttons 

 

Users can use the Next- Previous calendar navigation buttons to view the schedule for the next day of the 

week for a user. The same buttons can be used to see the schedule for the next week in case the weekly 

schedule is being viewed.  

Users can scroll through the meetings of the day displayed in the Scheduling calendar with the scroll bar 

at the side. They can use the scroll bar at the bottom to scroll thought all the meetings of the week while 

viewing a weekly display. 
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Create Activities 

User can save the schedule as Routes and Activities in the Dynamics 365 using ‘Create’ button. The user 

can create the following activities:   

• Appointments 

• Service Activities 

• Bookable Resource Bookings 
 
User can also select the option of ‘Create Route(s)’ in order to save the planned routes into ‘Route’ Activity 
Entity.  
 

 
 

Go to Detail Map: Using this button, user can go back to the Detail map   
 

Note: To make the option of Bookable resource booking visible, user needs to enable the OOB or any 
custom entity to create the bookable resource bookings.  
 

Note: All the scheduled data will be cleared, if ‘Go to Detail Map’ button will be used. To save the 

schedule created, user can use the option of ‘Create activities’.   
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Configuration Details for Auto Scheduling 
 

System admin and Maplytics admin can set the default settings for Auto Scheduling in the Default 
Maplytics Configuration Detail record. They can also set the start time as the default start time for the 
first activity as well as default values for other preferences for Auto Scheduling. 

 
Go to Maplytics App > Settings > Maplytics Configuration Details > Default Configuration details record 
for the user > Auto Scheduling 
 

 
 

 
 

Admins can also select the Activities that are needed to be considered while Considering Existing Meetings 

in Auto Scheduling. If no Activities are selected here Auto Scheduling will consider all the Activities while 
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Considering Existing Meetings. If Admins have selected Activities here then only selected activities will be 

considered while Considering Existing Meetings in Auto Scheduling.   

 

 
Users can also set the default settings for Auto Scheduling in their respective Maplytics Configuration 
Detail record. Go to Maplytics App > Settings > Maplytics Configuration Details > Configuration details 
record for the user > Auto Scheduling 
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Frequency Detail Feature 
With the traditional Auto Scheduling feature, the appointments for the working days at regular time slots 
are scheduled. An enhancement to its functionality is offered in the form of a Frequency Detail Feature.  
Suppose Jack, the sales manager at a pharma company is in charge of scheduling the weekly appointments 
for all his sales reps using Maplytics. It is easy to schedule regular appointments with Auto Scheduling but 
how can it be managed when certain clients are available only for a few days of the week and within fixed 
timeslots? Frequency Detail Feature would be helpful then. Using this feature, Jack would be able to 
schedule appointments for his on-field reps according to the availability of the clients at multiple locations. 
 
Adding Client Frequency Details 
To avail Client Frequency Details option, the checkbox for ‘Enable Meeting Frequency’ needs to be 
checked. The user can go to Settings > Default Maplytics Configuration Details > Auto Scheduling Tab 
and check on it. 
 
Follow the link for the detailed steps or check the Configuration Details section ahead 
To begin the process of scheduling according to the clients’ availability, the user needs to add the available 
days and time slots of the clients for appointments. For this, the Entity on which Auto Scheduling is to be 
performed needs to be considered. The records that have a selective availability need to be worked upon. 

Note: Create Activities for Custom Entity: 
• A custom entity should be linked to any OOB Entity into Entity Maps in order to Create 

Activities for the Entity 

https://youtu.be/4Y68Ci1rzBE
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Suppose we are performing Auto Scheduling on the Accounts Entity. Within the Client record, the User 
would go to the Auto Scheduling tab which is a PCF Control.  
 
Follow the link to understand the steps to add PCF Control or follow the Configuration Details section 

ahead 

 
Accounts> Client Record> Auto Scheduling 
 
There he would fill in the frequency detail of working days of the week and the corresponding work time 
slots the client would be available for. The user will have to repeat it for all the records that have an 
availability constraint.  
Certain records may not have this constraint, so, during the final scheduling process, the records with 
defined frequency details would be plotted on priority and the open slots would be filled in with records 
without any availability constraint. 
 

 
 
Once done, the standard Auto Scheduling process as described above can be followed where the user can 
go to the Mass Actions within the View Data Grid and select the Auto Scheduling option. 

Note: The existing client records of the CRM that have an availability constraint, need to be updated 
with these details. The newly added records can be updated at the time of creation. Certain accounts 
may not have availability constraints and can be left as is. 

https://youtu.be/4Y68Ci1rzBE
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Auto Scheduling Card 
The appointment Scheduler/ Admin can select the user to be scheduled. Start and End locations can be 
provided as before. 

 
 
With the Frequency Detail Feature, an additional slot of Consider Frequency gets added in User Details. 
If the Frequency Detail feature is enabled in the configuration, as seen above, the slot will be ‘Yes’ by 
default, else it’ll appear as ‘No’. In case the slot is ‘No’ the traditional Auto Scheduling process with no 
Frequency Details added can be carried out. 
Once done, the Scheduler/ Admin can specify the Start Time and End Time, like the traditional Auto 
Scheduling Process, and Proceed.  
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Thus, a proper Appointment Schedule shall be created with the Frequency Details specified for the client 
records taken into consideration. 

 
For two of the records available only on Thursday, the appointment gets scheduled on Thursday within 
the working/available time slot. 
 

Recursive Scheduling with Frequency Detail Feature 
 
Let us consider a situation Jack, our Pharma Sales Manager has while scheduling his field sales reps. 
Certain clients’ of Jack’s company reorder their standard orders every 7 days. Some patients who directly 
buy from the company place this order every 10 days. Thus, scheduling the same set of appointments 
every few days is added work for Jack. Besides, at times the patients fail to place these reorders although 
they need the new stock of medicines impacting their treatments. In addition, the clients could also have 
availability constraints for delivery. Thus, to solve both situations, Jack and others like him can refer to the 
Recursive Scheduling form within the Frequency Detail Feature. 
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Adding Frequency Details for Recursive Scheduling 
 

 
While adding the Frequency Details for an Account Entity, the user could specify the number of days after 
which the appointment needs to be rescheduled. In Jack’s case, this appointment would be of his sales 
rep going in to deliver the same medicine order. If the frequency is set to 7 days, the appointment shall 
be rescheduled every 7 days while setting up the appointment for weeks/month. 
 

 
The next appointment date after 7 days will be automatically counted based on the date of the first 
appointment. i.e. If the first appointment has been set on the 7th of a month, the next would get scheduled 
on the 14th of that month.  
The date of the previous appointment is populated automatically at the time of appointment creation as 
the ‘Last Schedule Date’ and the upcoming would be populated as the ‘Next Schedule Date’. Both the 
dates get updated with Appointment/ Activities Creation. 
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Note: Using the Advanced Find feature and the auto-populated Next Schedule Dates after appointment 
creation, records that would be due for a repeat appointment on a particular date can be selected and 
Auto Scheduling can be run only for those records. 
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Schedule Status 
 

 
If an account has been enabled for recursive scheduling but has missed its last appointment due to 
conflicting client availability and has crossed the frequency interval, its Schedule Status will appear as ‘No’. 
In case the Schedule Status is ‘No’ then that appointment would be taken up on priority for the next 
frequency schedule. This will prevent the account from being skipped in the next appointment cycle. 
 
Priority 
 

 
When 2 or more accounts are available on the same days during the same time slots, the account with 
priority ‘High’ is scheduled first followed by ‘Medium’ and ‘Low’. In case, all the accounts have the same 
priority the account nearest to the sales rep is scheduled first. 
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Configuration Details for Frequency Detail Feature 
Follow the entire procedure in a video format here 
 
Step 1: Enable flag from Map Configuration Record 
To avail Client Frequency Details option, the checkbox for ‘Enable Meeting Frequency’ needs to be 
checked. The System admin or Maplytics admin can go to Settings > Default Maplytics Configuration 
Details > Auto Scheduling Tab and check on it. 

 
 
Step 2: Add PCF Control 
Next, a PCF Control needs to be added to the Entity form that is being used for Frequency Detail. So, if 
Account is the entity being used, the control is added to its form 
The user needs to follow the path of Advanced Settings > Customization > Customize the System > 
Entities > Account > Forms  
Here, the main form of the Account entity needs to be opened. 
 

 
 

https://youtu.be/4Y68Ci1rzBE
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Step 3: Add Auto Scheduling Tab 
On the main form within the Insert Tab, Select One Column Option 
 

 
 
Double-click on the Tab and fill in the details as follows. Here, we are naming the Tab. 
 

 
 
Step 4: Create and Add New Fields for  

• Frequency Detail 

• Last Schedule Date 

• Next Schedule Date 

• Schedule Status and 

• Priority 
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Once the Auto Scheduling tab is renamed, click on New Field to create a new Multiple Lines of Text Field 
 

 
 
A convenient Display Name can be provided by the user. In our context, we have given it as Frequency 
Detail. The other values need to be changed as seen below and the window can be Saved and Closed. 
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The new custom field of Frequency Detail then needs to be added to the form. From the Custom Fields 
panel, it could be dragged and dropped within the Auto Scheduling Section 
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Select the Field, Frequency Detail and select ‘Change Properties’ option in the Home Tab 
 

 
On the properties that open, select the Control Tab and click on Add Control 
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Select the Maplytics Meeting Frequency Control and add it  
 

 
 
Select Web Control and Click on Ok 
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This will generate the days of the week and the time slots for the Account Entity. Now let us create a New 
Field in the Main form for the Last Schedule Date. Click on the New Field button on the main form and fill 
in the details as follows. Once filled, Save & Close. 
 

 
Again, drag the Last Schedule Date field from the Custom Fields column and drop it below the Frequency 
Detail 
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The process shall be repeated for the field Next Schedule Date and it will be dragged on the form as follows 
 

 
To add Schedule Status, the Data Type selected would be Two Options as it offers Yes and No answers 
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This too shall be dragged and dropped on the Form like earlier values 
 

 
The last field to be created is Priority with 3 Options. This would be an Option Set Field. The Priority options 
of High, Medium, and Low need to be added as new items with a value of 3,2,1 respectively. 
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Step 5: Save and Publish Customizations 
Once Saved and Closed, the Priority Field will appear in the New Field column. It needs to be dragged and 
dropped like the previous field. With all the options added, the Account Form can be Saved and Published 
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Step 6: Check the Account Entity 
 
After Publishing the Customizations, the fields would appear as follows in the Account Entity. If they do 
not, the previous steps in the form need to be rechecked. 
 

 
 
 
Step 7: Map Attribute in Account Entity 
As the last step of the Configuration process, all the fields created in this manner need to be linked to the 
Entity Map. 
The user can follow the flow of Entity Maps > Account > Attribute Mapping 
The following values can be selected from the drop-down 
 

 
Once added, it needs to be saved. 
With this, the Frequency Detail feature is up and ready for use for the Account Entity 
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Follow the entire process here in a convenient video format 
 

https://youtu.be/4Y68Ci1rzBE
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Check-In/Check-Out 
 
Check-In feature enables users (sales person/service person) to register their arrival and departure time 
for the meeting locations while navigating on field with the help of Check-In and Check-Out buttons. These 
buttons will help to tag the geo-coordinates of the location while a user is visiting a client. This will also 
help the management to track the activities of the field professionals as well as the time they have spent 
on every meeting.  

Configuration 

To get started with the feature of Check-In, the first step is to configure Maplytics. Configuration will 

create the Entity Map for the Check-In entity. Please refer to the section of ‘Configure’ under the ‘Initial 

Setup - Maplytics License Activation, Configuration for Entity Map, Dashboards and Census data’ within 

the Installation manual.  

This feature can be enabled for any OOB or custom entity within their respective Entity Maps. To enable 
this, System Admin/Maplytics Admin can follow the steps mentioned below. The following screenshot 
shows the entity map of Appointment for an instance.  
 
Go to Maplytics App > Settings > Entity Maps > Open Required Entity Map > General Tab > Enable Check-
In > Set the value to ‘Yes’ & click on ‘Save’. 

 

Note:   

• The default value for ‘Enable Check-In’ is set to ‘No’. 

• User cannot undo this option, once selected and saved.  

• After enabling this feature, please wait for a while before using this. 
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Related records for Check-In/Check-Out  

User can use the feature of ‘Plot Related Records’ to view the related records (Appointments, Accounts, 
etc.) for Check-In/Check-Out records that are plotted records on the map. using. This will help the 
managers to understand for which record has the sales person/service person checked-in/out. To plot 
related records for Check-In/Check-Out, user needs to select the relationship. To select the relationships, 
admins can follow the steps mentioned below. We have provided the steps for Appointments for an 
instance.  
 
Go to Maplytics App > Settings > Entity Maps > Required Entity Maps record > Configuration > Related 
Records Configuration > Relationship List > Select appointment - ikl_checkinentity  
 
User can also refer to the section of ‘Related Record Configuration’ under the Entity Maps within the 
Installation manual for the same.  

 
Check-Out 

After enabling the feature, user can also enable the option of ‘Check-Out’. This way the user can first click 

on the Check-In button while visiting the meeting and then can click on the Check-Out button while 

completing the meeting. Here, as the geo-coordinates for both the locations will be saved, it will also help 

the management to track the time spent on the meetings.  

Note:  User needs to select the respective Relationship with Check-in for every entity within their 
respective entity maps for which they want to see the related Check-In/Check-Out records. 
  



Maplytics™ – User Manual 

 

Page 209 of 386 

   

In order to enable Check- Out, System 

Admin/Maplytics Admin can follow the steps 

mentioned below:  

Go to Maplytics App > Settings > Map Configuration 

Details > Default Configuration Detail Record (the 

one with no user name) > Check-In tab > Set the 

value for Enable Check-Out to ‘Yes’ & click on ‘Save’. 

 

 

 

Default Radius 

It is the distance that the System admin/Maplytics admin can set to consider the accuracy of the Check-
In/Check-Out records created by the field professionals. If the Check-In/Check-Out record do not lie within 
this radius then it will be considered as invalid record and will be shown with a pushpin with this Red 

Cross. For example:  

Note:   

• The default value for ‘Enable Check-Out’ is set to ‘No’.  

• User can anytime disable this option.  

• Check-Out option can only be enabled for entities for which the feature of Check-In has been 
enabled.   

• Check-Out can be enabled/disabled only at Organization level. 

• Check-Out button will only be available for the records for which the user has checked-in.  

Note:  By default, Geofence radius is 0.20 kilometers or miles depending on the unit set in User 
Configuration Detail record. 
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Geofencing 

Geofencing is creating a virtual geographical boundary of a specified Geofence radius around a record. If 
Geofencing is enabled, user needs to be within this radius to successfully Check-In/Check-Out for a record. 
If the user is not within this radius, the user will not be able to Check-In/Check-Out and will be shown a 
message specifying that they need to be within ‘n’ Km/Mi of distance from the Check-In/Check-Out 
location. This will help the management to have only valid Check-In and Check-Out records done by the 
field professionals. 
 
In order to enable Geofencing, System Admin/Maplytics Admin can follow the steps mentioned below: 
 
Go to Settings > Map Configuration Details > Default Configuration Detail Record > Check-In tab > 
Geofencing > Set the value for Geofencing as ‘Yes’  

 
 

Geofence Radius 

After enabling Geofencing, System Admin/Maplytics Admin can set the default value for Geofence radius, 
which will be considered while a user Checks-In, or Checks-Out.  

 

 

Note:   

• By default, Geofencing is disabled in which case the user can Check-In/Check-out from any 
location. 

• By default, Geofence radius is 0.20 kilometers or miles depending on the unit set in User 
configuration Detail record. 
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Enable Notes on Check-In and Check-out 

Admins can enable this option to let the users add notes to the record for which they are checking in/out. 

To enable this option, go to Map Configuration Details > Default Configuration Detail Record > Check-In 

tab > Enable Notes on Check-In / Enable Notes on Check-Out.  

The admins will have three options to select:    

• Disable: This will disable the option to add notes while Checking-In or Checking-out.  

• Optional: The user is shown the pop up for notes but they can check-in or check-out without 

adding the notes.  

• Mandatory: It is necessary for the user to add notes while checking-in or checking-out. 

 

Pending Check-In/Check-Out Requests 

System Admins and Maplytics Admin can enable this option to allow the users to create the requests for 

Check-in/Check-out for meetings in the past. For example, if a user had an offsite meeting or missed to 

check-in/out for any meeting, they will be able to create requests for check-in/out for such meetings if 

this option is enabled.  

To enable it, go to Map Configuration Details > Default Configuration Detail Record > Check-In> Create 
pending Check-In/Check-Out Requests > Select the checkbox 
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Once this option is enabled, the admins can also see the ‘Reasons for Requests’ which shows the 

list of acceptable reasons that are predefined. The users can select anyone while creating pending 

Check-In/Out records. The admins can also configure custom Request Reasons by going to Check-

in Entity within CRM Customizations.  

 

Note:  Any user who would be inside the defined Default Radius/Geofence radius of a record 
will not be able to create pending check-in or check-out for the respective record. 
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Creating Check-In/Check-Out records 

 
While navigating on field, user can Check-In and Check-Out for any record. This can be done in the 
following two ways: 
 

• From Record Form: User can open the respective record (Appointments, Accounts etc.) and click 
on Check-In/Check-Out button on the ribbon.  
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• Through Detail Map: User can click on any plotted records (Appointments, Accounts etc.) to open 
the respective Tooltip Card and click on the button to Check-In/Check-Out. 

 
 
 
 
 

Note:   

• User needs to allow to read the GPS location of the device in order to Check-In/Check-Out. 

• Once checked-in, user can click on the same button to check-out.  
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Adding Notes while checking-in/out 

While a user registers a check-in/out, they can add 
some notes or attachment for the respective 
record. For example, if they want to add some notes 
related to the meeting they did, or any documents 
they need to attach regarding the requirements of 
the client, they can use this option to add the notes 
or attachment.  
 
Users can further go to the respective record to see 
the notes and attachments within the timeline of 
the Activities. If a user is checking-in/out for an 
activity record like appointments or Bookable 
resource bookings and has added notes or 
attachments then in such cases the notes and 
attachments will be saved within the respective 
related record (for example, Account/work order) 
saved in the regarding field. 

Note: Multiple Check-In/Check-Out records can be created for any record (Appointments, Accounts, 
etc.) 
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Creating Pending Check-In/Check-Out requests 

If users want to check-in or check-out for a record for 

which the meeting/service has been done in the past 

but they missed to check-in/out at that time, because 

of an off-site meeting or let’s say if they forgot to check-

in/out, so they can create check-in/out requests for 

those records later sometime. They can select the 

reason why they missed and select the date & time of 

the meeting for which they missed to check-in/out and 

click on ‘Create’. The requests will be pending for 

approval from managers. Unless the records have been 

approved by the manager, the records will not become 

active check-in/out records and will remain as pending 

check-in/our requests. 

 

 

 

If the user wants to enter a reason which is not listed 

then the user can select the ‘Other’ option and enter 

their reason in the provided text box and click on 

Create. These check-in/out requests will be converted 

to an active check-in/out record only when the 

respective manager approves the reason for missing 

the check-in/out and hence approves it to be a valid 

check-in/out records.  
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Visualize Check-In/Check-Out records on Detail Map 

The managers can visualize the activities of field professionals by plotting 

the Check-In/Check-Out records on the map just like any other entities 

with the help of the Plot Card. User can select ‘Check-In’ as the Datasource 

and select a required view to visualize the records from that view.  
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Analyze Check-In/Check-Out records 

After plotting the records for Check-In and Check-Out, user can analyze the pushpins by distinguishing 
between the following two kinds of pushpins: 

• Valid Check-In/Check-Out: When a user Checks-In/Checks-Out within the Default Radius or 

Geofence Radius, it is a valid record and will be represented by pushpin. 

• Invalid Check-In/Check-Out: When a user Checks-In/Checks-Out outside the Default Radius it is 

represented by pushpin. 

Visualizing Related Records  

 
After plotting the records for Check-in, user can also choose to view the records (Appointments, Accounts 
etc.) against which the plotted check-ins and check-outs were created.  
 

Visualizing Related Record (Appointments/Accounts, etc.) for Check-In/Check-Out records 

After selecting the relationship, user can choose to view the related record for any Check-in and Check-
out record plotted on the map.  

 
 
The related record can be visualized in the following two ways: 

• By Contextual Menu: User can right click on any Check-In/Check-Out pushpin to open the 

‘Contextual menu’ and click on ‘Show Related Record’. This will plot the related record for the 

selected pushpin. To hide the related record, user can again right click on the same Check-

In/Check-Out pushpin to open ‘Contextual Menu’ and click on ‘Hide Related Record’. 
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• By Tooltip Card: User can click on the Check-In/Check-Out pushpin to open the Tooltip Card and 

click on ‘Show Related Record’ from the ‘Tooltip Card Actions’. To hide the related record, user 
can again click on same Check-In/Check-Out pushpin to open the Tooltip Card and click on ‘Hide 
Related Record’. 
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Visualizing related Check-in/Check-Out records for plotted records (Appointments, Accounts, 

etc.) 

After selecting the relationship for the required entity within the entity map as suggested above, user can 
click on any plotted record to open the Tooltip card and click on ‘Plot related record’ to plot the related 
Check-In/Check-Out records. 
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Visualize Pending Check-in/out requests 

Managers can select the required view for the Check-in/out requests and plot the same on the map in 

order to visualize the pushpins.  

 
 

Approve/Reject pending Check-In/Check-Out records  

Once the manager has plotted the pending check-in/out request records on the map as shown above, 

they can check the request records created by field team and approve or reject the records in order to 

accept it as an active check-in/out record or reject it.  

If manager needs to approve/reject the requests from a 
particular salesperson, they can also select ‘Owner’ within 
the ‘Category’ in the ‘Plot Records’ card to categorize the 
request records with Owners. Manager can further go to the 
category card to deselect the other owners so as to visualize 
only the records created by salesperson who reports to 
them.  
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Now, manager can click on a pushpin from the map 
and to the see the Approve/Reject button. Admins 

can also go to Maplytics App > Settings > Entity 
map > Check-in entity map > Tooltip Mappings 
> Add Request reason. This will show the Reason 
for request on the tooltip card while a manager 
clicks on a pending check-in/out. After checking the 
reason, manager can decide and click on the button 
to open the window and select Approve or Reject 
and click on save.  

 
Manager can also use the option of 

Approve/Reject from the Mass Actions to 

approve or reject all the pending check-in/out 

request records plotted on the map. 

 
Note:  

• Only the system Admin, Maplytics Admin, or the Manager of a user can approve or reject the 
respective pending check-in or check-out records.   

• Once the manger/admin approves/rejects a record, they cannot approve/reject the same 
record again.  
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Land Area Mapping 

If users work with lands, real estates or farms etc. they can visualize their lands on map with this feature. 

Users will be able to assign land regions to the records and visualize them on the map to understand the 

coverage of area for each of the records using this feature. 

 

Create and Assign land areas to entity records 

Create 1: N relationship with Geography entity  

User first needs to assign the land regions (Geographies) to the records of the CRM entity for which the 

lands are to be visualized. For this, the user needs to create 1: N relationship between that entity and the 

Geography entity. For example, if the user wants to visualize the landscapes for Account records, so to 

create a 1: N relationship between the Accounts entity and the Geography entity. User can also add a grid 

on the Accounts form in order to see the list of landscapes that have been assigned to the record. 
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Attribute Mapping for Landscapes 

Once the relationship is created, select the same in the respective Entity map. As per our example, the 

Maplytics admin or system admin needs to go to Maplytics App > Settings (Left bottom) > Entity Maps > 

Accounts Entity map > Attributes Mapping > Geography relationship > Select the 1: N relationship of 

Geography and Account. 
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Assign lands to single record 

In order to visualize the land of a record, user first needs to create the geography for the landscape and 

assign the geography to the respective record. To do this, open the required record and click on ‘more 

commands’  to click on the button of ‘Land Area Mapping’.  

 
After clicking on ‘Land Area Mapping’, a new window will open as shown below where the user can 

upload Shape files or Excel files or draw shapes for the landscapes on the map.  
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Plot Options 

 

There will be two options that can be used to plot the landscapes on the map. 

• Shape File 

• By Drawing 

Shape File 

Users can select a shape file or an excel file to plot the respective lands on the map. The supported file 

formats are .shp, .kml, .geojson. Once the file is plotted on the map, user can use the selection tool at the 

right top corner to select, deselect, multi-select or delete the regions plotted on the map. Now user can 

select the required regions and right click to Assign Area.  

 

 
User can here select the name for the selected region and click on ‘Proceed’ to save it.  
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By Drawing 

Users can also create geographies for the landscaping using the option of ‘By Drawing’.  They can use 

the drawing tool to draw the shapes for the required landscape on the map. Further, use the selection 

tool to select drawn shape(s) and right click to assign area.  

 
Enter the name of the geography and click on ‘Proceed’. The color of the drawn shape changes after 

getting assigned to the record. 
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Assign lands to multiple records 

User can select multiple records from the home grid and assign lands to the selected records from the 

same map. After selecting required records, user can click on the ‘Land Area Mapping’ button. 

 
 

After clicking on ‘Land Area Mapping’, a new window will open as shown below where the user can upload 

Shape files or Excel files or draw shapes for the landscapes on the map as mentioned in the section of 

‘Plot Options’ above. Now just like mentioned in the sections, use the selection tool to select the required 

land on the map and right click to ‘Assign Geographies’.  

User can now select the area name if used a shape file or enter the area name if used the drawing tool 

and further select the record to which the respective land has to be assigned. This is how user can select 

the required region and assign it to all the records.  
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Visualizing Assigned lands to the record  

Users can select the entity in Datasource and the respective view in the ‘Plot Records’ card in Detail map 

to plot the record on the map as pushpins. While visualizing records on the Detail map, users can right 

click on any pushpin to open the Contextual menu and use the ‘Show Land Area’ button to plot the land 

that is assigned to the respective record.   

 
 

If the user wants to see all the lands that have been 

assigned to all the records that are plotted on the map, 

they can use the ‘Show Land Area’ toggle button on the 

Layer Menu to show/hide the same.  

 

User can also click on any area plotted on the map to open 

the Summary card to view the metadata (information from 

the shape file) of the region.   
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User can also select records from the home grid and click on ‘Land Area Mapping’ button from the ribbon 

to view all the lands assigned to the records. They can further assign more lands to the required records 

as mentioned in the section of ‘Assign lands to multiple record’ above. 

 
 

 

 



Maplytics™ – User Manual 

 

Page 232 of 386 

   

The below screenshot shows the lands assigned to the records selected from the Entity home grid. 
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Visualizing Assigned lands to the records having no geocoordinates  

If the users are using an entity for landscapes which doesn’t have its own address or are not geocoded, 

but have assigned lands to the records, they can still plot the lands assigned to the entity records. To do 

this select required record(s) from the entity dataset and click on ‘Land Area Mapping’ button from the 

Ribbon. This will open a window plotting all the lands that have been assigned to the records. User can 

further use the ‘Plot Options’ to plot lands on the map and assign them to the required records as 

mentioned in the section of the ‘Plot Options’ above.  
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Real-Time Tracking 
With Real-Time Tracking, sales reps, service reps and resources can be tracked within all modules of CRM 
in real time. This will help to view the routes that are being followed by reps/resources as well as the 
routes that had been followed by them in the past. The appointments/bookable resource bookings that 
have been assigned to the resources can also be seen with the help of this feature. This feature also works 
in the Dynamics CRM app, Dynamics CRM sales app and Field Service app.  

Configuration 

 
To enable this feature, go to Maplytics App > Settings > Map Configuration Details > Default 
Configuration details record (the one with no user) > Real-Time Tracking > Enable Real-Time Tracking > 
select the checkbox. 
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Refresh Interval: Admins can select the ‘Refresh Interval’ to decide the interval (in seconds) at which the 
location of the Resources/Sales reps will be tracked. For example, every 30 seconds. 
 
Day and Time: Working days and the start & end timings can be selected from the list. Based on this 
selection the reps/resources will be tracked. If admins do not want the reps/resources to be tracked on 
any particular day, they can leave the timings blank to avoid tracking on those days. Admins can also go 
to the Maplytics Configuration Detail record of individual reps to set different required timings for 
tracking.  
 

User Settings for CRM Modules other than Field service 

Real-time tracking can be used to track the reps/resources that have been added to the Maplytics team 

as users. The admin needs to go to the user’s record > Maplytics Location Tracking > Enable the tracking 

for the individual users and can view the other details.  

 

Enable Location Tracking: Select “Yes” to track the respective user.  

Last Tracked At: This will show the date and time when the respective user was last tracked at.  

Latitude & Longitude: These will be the coordinates at which the user was last tracked.  

Tracking Status: This will show the current status of tracking for the user. Based on three situations the 

status will be as follows:  

• Tracking - The user has enabled tracking in the Maplytics app and the tracking is on 

• Tracking Stopped - Outside business hours – Tracking has stopped as current time is outside 

business hours.  
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• Tracking Stopped - Tracking Disabled/ GPS Issue/ Location Service Issue – Tracking has stopped 

due to one of the three reasons:   

o The user has disabled tracking in the Maplytics app 

o GPS information is not available  

o There is issue with the location service.   

 

Maplytics Real-Time Tracking App for Sales and Other Modules 

The Reps can download & install the Maplytics App and log in to their CRM credentials. The app is available 

on Playstore and Appstore for Android or iOS devices. 

When the reps log in to the Maplytics App they can view their current location on map in the form of a 

pushpin. The pushpin will move on the map whenever the rep makes any movement. The rep can select 

the toggle button to start the tracking. Once they have finished their work they can use the toggle button 

to stop the tracking and log out from the app. 

 



Maplytics™ – User Manual 

 

Page 237 of 386 

   

 

 



Maplytics™ – User Manual 

 

Page 238 of 386 

   

 
Once the Real-Time Tracking has been enabled, users can go to the Detail map > Select Data source > 

select the Resource/User as the entity and the required view > click on Search. Once the users/resources 

are plotted as pushpins on map, the resource location that is being tracked at every interval will be 

updated on the map. Users can click on the pushpins of the users/resources to open the tooltip card for 

that user/resource. Users can view the tracking information for only those Resources/Users that have 

been added to the Maplytics team and have Location tracking enabled in the User Settings. Users can click 

on the Users/Resources to view the tooltip card to find the two buttons for Real-time tracking, i.e., 

‘Today’s plan’ and ‘Location History’.  

 

 

 

Note:  

• Users should be added to the Maplytics team in order to be tracked. 

• For field service, admin also need to enable ‘Location tracking’ within the Geolocation 

Settings of Dynamics 365 field service and select the timings, for example, every 1 minute 

to track the location of the Resources at every specified interval.  

• The users should be logged in to the Field Service app for tracking in Field Service CRM. 

• The users should be logged in to Maplytics app and the tracking option should be enabled 

for tracking in CRM with other Modules like Sales, Customer Service etc.  

 

Note: To view the Users as an entity in the option for ‘Select Datasource’, an entity map for the 

entity ‘Users’ should be created.  
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Today's Plan 

‘Today’s Plan’ button will allow the managers to view route assigned to the respective rep/resource to be 

followed today as well as the route that is being traveled by the respective rep/resource in real-time, and 

the appointments assigned to them for today. The route assigned to the rep/resource will be shown in 

sky blue color and the route that is being traveled by the rep/resource in real-time will be shown in navy 

blue color. As the rep/resource moves on the field, the pushpin for the rep/resource can also be seen as 

moving on the map. 

Sales and Other Modules 

Clicking on the User’s pushpin, its tooltip card opens up. 

User can also hover on the plotted user’s pushpin to see 

further information about the rep. The below screenshot 

shows the information about the rep in the tooltip card 

for the rep ‘Robert H’. Here user can click on the ‘Today’s 

plan’ button to track Robert for today.  

Users can view the following information of 

Appointment Timestamps on the Summary card opened 

up for the respective rep. They can also hover on the 

resource pushpin to see these details.  

• Start Time 

• End Time 

• Total Travel Distance 

• Total Travel time 

• Total Appointments 

• Total Completed Appointments 

• Total Canceled Appointments 

• Total InProgress Appointments 

• Total Scheduled Appointments 
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User can go to the Layer Menu and use the toggle button to 

show/hide the route being tracked in the real-time and the 

route that was assigned to the resource.  

 

 

 

User can also click on the pushpins of the waypoints on 

the map to view the details of the respective 

Account/Contact.  
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Field Service 

Clicking on the Resource’s pushpin, the tooltip card opens up. The below screenshot shows the Tooltip 

card of the Resource Sam K.  

 
Users can view the following information of Booking Timestamps on the Summary card opened up for the 

respective resource. They can also hover on the resource pushpin to see these details.  

• Total Travel Distance 

• Total Travel time 

• Total Bookings 

• Total Completed Bookings 

• Total Canceled Bookings 

• Total InProgress Bookings 

• Total Scheduled Bookings 

• End Time 

• Start Time 
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User can go to the Layer Menu and use the toggle button 

to show/hide the route being tracked in the real-time and 

the route that was assigned to the resource.  

 

 

 

User can also click on the pushpins of the Bookable 

resource bookings plotted on the map to see 

information about that booking.  
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User can also click on ‘View Data’ button to view the details of the resources.  
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Location History 

‘Location History’ button will allow the managers to view the routes that have been travelled by the 

reps/resources in the past. To do this, they can click on the ‘Location History’ button on the tooltip card, 

select the required date and click on search. Users can also select the time if they want to view the history 

between a specific duration on the selected date.  

Sales and Other Modules 

Clicking on the rep’s pushpin opens up the tooltip card. The below screenshot shows the tooltip card for 

the Sales rep Robert H. Users can click on the highlighted button of Location History and select the date 

& time required and click on Search.  

 

This will show the route assigned to the respective rep to follow on the selected date as well as the route 

that was actually travelled by the respective rep. Here we can see that Robert H is travelling the exact 

route that was assigned to him. Users can view the information of Appointment Timestamps on the 

Summary card opened up for the respective rep. They can also hover on the rep pushpin to see the details. 

User can also click on ‘View Data’ button to view the details of the reps.  
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User can go to the Layer Menu and use the toggle button to show/hide 

the route being tracked for the selected date and the route that was 

assigned to the rep.  

 

 

 

Users can go to the Direction card to select the reps required from the 

list there and click on Today’s plan or Location history button to view 

the tracked information for the respective resource.  
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Field Service  

Clicking on the resource pushpin opens up the tooltip card. The below screenshot shows the tooltip card 

for the resource Sam K. Users can click on the highlighted button of Location History and select the date 

& time required and click on Search.  

 

This will show the route assigned to the respective resource to follow on the selected date as well as the 

route that was actually travelled by the respective resource. Here we can see that Sam K had travelled the 

exact route that was assigned to him. Users can view the information of Booking Timestamps on the 

Summary card opened up for the respective resource. They can also hover on the resource pushpin to see 

the details.  
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If users are visualizing the tracking information for multiple reps/resources or multiple days, each route 

will be plotted into different colors so as to be able to differentiate between individual routes. Further 

users can close the Summary card to remove the tracking information for the respective rep/resource 

from the map. Thus, users can track reps/resources in the following ways. 

• Single rep/resource for multiple days  

• Multiple reps/resources for single day  

• Multiple reps/resources for multiple days  
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Real-Time Tracking in Mobile 

Users can use Real-Time Tracking within the Field Service App/Dynamics CRM app/Dynamics CRM Sales 

App as well, just like the way explained above for desktop. Once they have plotted the reps/resources on 

the map, they can click on the pushpins to open the tooltip card and see the buttons for Location History 

and Today's Plan to view the travel history of the rep/resource for the required dates and time or the 

travel plan of the rep/resource for today respectively. 
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Maplytics API 
 

Maplytics API allows users to retrieve geographical data from Maplytics maps to use it outside of CRM. If 

a user needs to show CRM data based on a Proximity search or from a specific region etc. on a portal or 

website, they can use Maplytics API to do the same. Maplytics API will be used to make API request to 

give the response as per user input like proximity, region etc. For example, if a user has a website that 

provides training for driving and they want to allow the visitors to find trainers nearby their location. If 

the trainers are stored in Dynamics CRM, then Maplytics API can be used to show the results of Maplytics 

Proximity search i.e., the trainers around a specified location on the website while a visitor searches for 

it. 

Maplytics API will be provided with a transaction limit. The transaction count will be provided as per the 

user’s requirement. The API transaction usage will be counted into three ways. Please contact Inogic at 

crm@inogic.com if interested into using Maplytics API. 

• Daily 

• Monthly 

• Yearly 

The transaction limit will be provided based on the required usage among the three mentioned above. 

Let’s say, based on user’s requirement, if they have been provided with daily transaction limit of 100 then 

the user will be allowed to make 100 API requests per day. If the user exceeds the limit for a day, then a 

message will be shown that will inform the user that they are not allowed to make any more API requests 

for today. Then the user will be able to make API requests the next day. It will work the similar way for 

the Monthly and Yearly usages. 

 

 

List of APIs:  

1. Proximity Search 

2. Region Search 

3. Territory Search 

4. Template Search 

5. Direction instruction  

6. Get Timezone 

API accepts following parameters. Based on the value passed in the parameter of the respective operation 

it will get the response. Also, Parameters are optional. 

Note: To execute API request you should have active Maplytics license.   

mailto:crm@inogic.com
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By Proximity 

Suppose you want to search using proximity. For this, we have created the custom action with name 

“Inogic.Maplytics.API.Proximity” (ikl_InogicMaplyticsAPIProximity).           

Custom action accepts following parameters:  

• CurrentLocation: Location for which you want to do the proximity search. 

• Proximity: Provide the proximity radius. e.g., 3. If you want to do Concentric Proximity search, 
then specify multiple proximity radii separated by comma ‘,’. For example, 5, 10, 15.    

• DistanceUnit: Provide the radius unit. It can be either “mile or kilometer". If the unit is not 
specified then by default mile will be considered as the radius unit. 

• Records: EntityCollection  

• Entity: Provide the entity name. e.g. “Account" 

• ViewName: Specify the view name. e.g., “My Active Accounts” 

When user passes the required parameters and executes this action then it will return records collection.  

 

 

To execute proximity action using the C#, use the following code. 

  //create request object 
string requestName = "ikl_InogicMaplyticsAPIProximity"; 
 
                    //create request object 
                    OrganizationRequest orgReq = new OrganizationRequest(requestName); 
                    //for proximity 
                    orgReq["CurrentLocation"] = "New York"; 
                    orgReq["Proximity"] = "10,25"; 
                    orgReq["DistanceUnit"] = "Mile"; 
                    //Entity & view 
                    orgReq["Entity"] = "account"; 
                    orgReq["ViewName"] = "My Active Accounts"; 
                    OrganizationResponse response = service.Execute(orgReq); 
 
                    EntityCollection recordsCollection = 
(EntityCollection)response.Results["RecordsCollection"]; 

 

To execute the action using the javascript (web api) you can use following code. 

function executeCustomAction() { 
    try { 
 
        var actionObj = { 
            CurrentLocation: "New York", 
            Proximity: "10,25", 
            DistanceUnit: "Mile",           
            Entity: "account", 
            ViewName: "My Active Accounts", 

Note: As custom action has 2 minutes timeout so maximum records that are processed is around 

90K- 100K. If you have a view having records more than 100K then it may throw a timeout issue. 

So, make sure to enter the viewname of the view that has less then 100K records. 
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        } 
 
        // call this function to execute the action  
       execute(actionObj, "ikl_InogicMaplyticsAPIProximity()", function (data) { 
 
            alert("Success: " + data); 
 
        }, function (error) { 
            debugger; 
            alert("Error: " + error.message); 
        }); 
 
    } catch (e) { 
        alert(e.message); 
    } 
} 
 
function execute(req, reqName, successCallback, errorCallback) { 
 
    //create AJAX request 
    $.ajax({ 
        type: "POST", 
        contentType: "application/json; charset=utf-8", 
        datatype: "json", 
        url: encodeURI(getWebAPIPath() + reqName), 
        data: window.JSON.stringify(req), 
        beforeSend: function (xhr) { 
            //Specifying this header ensures that the results will be returned as JSON.              
            xhr.setRequestHeader("Accept", "application/json"); 
            //xhr.setRequestHeader("Content-Type", "application/json; charset=utf-8"); 
            xhr.setRequestHeader("OData-MaxVersion", "4.0"); 
            xhr.setRequestHeader("OData-Version", "4.0"); 
        }, 
        success: function (data, textStatus, xhr) { 
            //successCallback function 
            if (data != null && data.value != undefined) { 
                successCallback(data.value); 
            } else { 
                successCallback(data); 
            } 
        }, 
        error: function (xhr, textStatus, errorThrown) { 
            errorCallback(Inogic.Maplytics.ApiLib.errorHandler(xhr)); 
        } 
    }); 
 
} 
 
function getWebAPIPath() { 
    return Xrm.Page.context.getClientUrl() + "/api/data/v8.0/"; 
} 
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By Region 

Suppose you want to search records within a specified region. For this, we have created the custom action 

with name “Inogic.Maplytics.API.Region” (ikl_InogicMaplyticsAPIRegion). Custom action accepts the 

following parameters.   

• RegionType: Provide the type of region based on which user wants to search. , i.e., City, State, 
County, Country, PostalCode, PostCode Sector, PostCode(Outward Code), PostalCode Areas 
“City/Postalcode/State”. You need to provide any of the above. 

• Region: Provide the region where you need to search. E.g., New York.  

• Entity: Specify the entity name. e.g., “Account" 

• ViewName:  Specify the view name. e.g., “My active accounts” 

When user passes the required parameters and executes this action then the action will return records 
collection.  

To execute region action using the C#, use following code. 

string requestName = "ikl_InogicMaplyticsAPIRegion"; 
 
                    //create request object 
                    OrganizationRequest orgReq = new OrganizationRequest(requestName);                    
 
                    //for region 
                    orgReq["RegionType"] = "city"; 
                    orgReq["Region"] = "New york"; 
 
                    //Entity & view 
                    orgReq["Entity"] = "account"; 
                    orgReq["ViewName"] = "My Active Accounts"; 
 
                    OrganizationResponse response = service.Execute(orgReq); 
 
                    EntityCollection recordsCollection = 

(EntityCollection)response.Results["RecordsCollection"]; 

To execute the action using the javascript (web api) you can use following code. 

var actionObj = { 
             RegionType: "City", 
             Region: "New York", 
             Entity: "account", 
             ViewName: "My Active Accounts", 
         } 
 
         // call this function to execute the action  
         execute(actionObj, "ikl_InogicMaplyticsAPIRegion()", function (data) { 
 
              alert("Success: " + data); 
 
         }, function (error) { 
             debugger; 
             alert("Error: " + error.message); 
         }); 
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By Territory 

Suppose you want to search records within specified territories. For this, we have created the custom 

action with name “Inogic.Maplytics.API.Territory” (ikl_InogicMaplyticsAPITerritory).           

Custom action accepts the following parameters.   

• Territories: Specify the names of territories. E.g., “FL, NY”.  

• Entity: Specify the entity name. e.g., “Account" 

• ViewName:  Specify the view name. e.g., “My active accounts” 

When user passed the required parameters and executes this action then the action will return the 

collection of records.  

To execute region action using the C#, use following code. 

string requestName = "ikl_InogicMaplyticsAPITerritory"; 
 
                    //create request object 
                    OrganizationRequest orgReq = new OrganizationRequest(requestName); 
 
                    //for Territories 
                    orgReq["Territories"] = "NY";                   
 
                    //Entity & view 
                    orgReq["Entity"] = "account"; 
                    orgReq["ViewName"] = "My Active Accounts"; 
 
                    OrganizationResponse response = service.Execute(orgReq); 
 
                    EntityCollection recordsCollection = 

(EntityCollection)response.Results["RecordsCollection"]; 

To execute the action using the javascript (web api) you can use following code. 

//By territory 
        var actionObj = { 
            Territories: "NY",           
            Entity: "account", 
            ViewName: "My Active Accounts", 
        } 
 
        // call this function to execute the action  
        execute(actionObj, "ikl_InogicMaplyticsAPITerritory()", function (data) { 
 
            alert("Success: " + data); 
 
        }, function (error) { 
            debugger; 
            alert("Error: " + error.message); 
        }); 
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By Template 

If you want to search records based on Maplytics template then for this we have created the custom 

action with name “Inogic.Maplytics.API.Template” (ikl_InogicMaplyticsAPITemplate).           

Custom action accepts the following parameters.   

Template: Specify the Template name. E.g., “Accounts with 10 miles”.  

When user passes the required parameters and executes this action then the action will return the 

collection of records.  

To execute Template action using the C#, use following code. 

string requestName = "ikl_InogicMaplyticsAPITemplate"; 
 
//create request object 
OrganizationRequest orgReq = new OrganizationRequest(requestName); 
 
orgReq["Template"] = "Accounts with 10 miles"; 
 
 //execute the request 
OrganizationResponse response = service.Execute(orgReq); 
 
EntityCollection recordsCollection = 

(EntityCollection)response.Results["RecordsCollection"]; 

Get Time zone 

To get the time zone of a region, when we pass address or latitude/longitude then it will return the time 

zone. 

To execute time zone action using the C#, use following code. 

string requestName = "ikl_InogicMaplyticsAPIGetTimeZone"; 
 
                //create request object 
OrganizationRequest orgReq = new OrganizationRequest(requestName); 
 
orgReq["TimezoneLocation"] = "new york"; 
 
                //execute the request 
OrganizationResponse response = service.Execute(orgReq); 
 
string TimeZone = "TimeZone: " + (string)response.Results["TimeZone"]; 
 

string TimeZoneAbbreviation = "TimeZoneAbbreviation: " + 

(string)response.Results["TimeZoneAbbreviation"]; 

 

To execute the action using the javascript (web api) you can use following code. 
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  var actionObj = { 
            TimezoneLocation: "New york",            
        } 
 
        // call this function to execute the action  
        execute(actionObj, "ikl_InogicMaplyticsAPIGetTimeZone()", function (data) { 
 
            alert("Success: " + data); 
 
        }, function (error) { 
            debugger; 
            alert("Error: " + error.message); 
        }); 
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PowerApps Component Framework  
 
User can add custom controls on fields or grids within Dynamics CRM. These custom controls will help the 
user to view the respective records on the map on the record form or the entity grid without switching to 
any other screen. This will enhance the user experience while working with views and individual records. 
User can add the following custom controls: 

Map View Control for Record  

User can add this control on any of the field with the Data type ‘Single Line of Text’ of the record to view 

the respective record plotted on the map. User can further view the Address and geo-coordinates on the 

hover of the pushpin.  

 

Steps to Add control: To add the control to a field within a record form, user can follow the steps 

mentioned below:  

1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Lead entity for an instance. Within Leads, go to Forms > Main Form > Select 

a field > Change Properties  

 

 

 

 

Note: The data type of the field on which user needs to add control should be ‘Single Line of Text’. 
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2. Go to Controls > Add Control > Select Map View Control for Record > Add 

 

 

 

 

 

 

 

 

 

 

Note: Please uncheck the option of ‘Display label’ within the field properties for better visualization. 
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3. User can choose to allow the control on Web, Phone or Tablet. Click on ‘OK’ > Save & Publish.  

4. User can open any record of the entity to view this control added on the field.  
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Map Edit Control for Record 

User can add this control on any of the field with the Data type ‘Single Line of Text’ of the record to view 

the respective record plotted on the map. User can hover on the pushpin to see the coordinates as well 

as the address of the pushpin. User can further drag the pushpin around and drop it on the required 

location to update the new Address and the geo-coordinates for the record. User can also type in the 

address in the space provided and click on the update button to update the Address and the geo-

coordinates for the record. Before updating this, the user will be shown a message where user can also 

choose if they want to save address and the geo coordinates or only the geo coordinates.  

Steps to Add control: To add the control to a field within a record form, user can follow the steps 

mentioned above while selecting ‘Map Edit Control for Record’ in the Step2.  After adding the control user 

can open any record of the entity to view this control added on the field.  
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Map View Control for Dataset  

User can add this control to any entity to visualize all of the records of the view or sub-grid on a map. User 

can further hover on the pushpins to view the information regarding the records. The information on the 

hover of the records is customizable. To add more information on hover, please refer to the section of 

Advanced Settings within the Entity maps in the Installation manual. User can also click on the pushpins 

to highlight them. Highlighting multiple pushpins can help the users to perform various actions from the 

ribbon on all the highlighted records at once. User can also right click on any pushpin to open the 

respective record.  

 

Steps to Add control: To add this control on an entity grid, user can follow the steps mentioned below:  

1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Contact entity for an instance. Within Contacts, go to Controls > Add Control 

> Select Map View Control for Dataset > Add 
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2. User can choose to allow the control on Web, Phone or Tablet. Click on Save > Publish.  

 

3. User can open any view of the entity to view this control.  
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Detail Map Control for Dataset 

User can add this control to any entity dataset or dashboard to visualize all of the records of the view, 

sub-grid or dashboard on a map. User can also click on the pushpins to highlight them. Highlighting 

multiple pushpins can help the users to perform various actions from the ribbon on all the highlighted 

records at once. Detail Map Control provides the user with the freedom of using Maplytics features right 

from the page without switching to any other screens. User can also perform the following Maplytics 

features within the Detail map control. To know about these features in detail, please refer to the 

respective feature section in this manual. 

• Plot entity records – The records of the entity dataset on which this control has been added will be 

plotted on the map by default. They can hover on the pushpins to view the details regarding the 

pushpin and click on the pushpins to open the respective tooltip card. Users can use right-click to open 

the contextual menu which allows to take certain actions on the respective pushpin. They can open 

the record, set the respective record’s location as origin, destination or a waypoint to a route. They 

can further set the record’s location as current location, 

POI location or take actions like add tasks or Schedule 

Appointment based on the actions configured for the 

Tooltip card. With the Contextual Menu, user can use 

the option of ‘Save Settings’ to save the default 

locations for current location, Origin, Destination and 

the default Map Zoom Level & map centre.  

 

• Plot multiple datasources - Other than the 

default data plotted on the map i.e. the Entity 

dataset on which the Detail map control has been 

added, user can also select two more Data sources and 

their respective active views to plot the same on the map. Thus, a maximum of three datasources can 

be visualized on map.  

 

 

 

 

 

 

 

Note: Visibility of Maplytics actions within the Detail map control will be dependent on the actions 
selected within the Security Template if any assigned to the logged-in user. Please refer to the 
Security Template section.  
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• Users can also select the required colors and the shape of the pushpins for the records of the view 

within the Datasource section in the Plot Records card. Once the color or pushpin is selected, it 

will instantly reflect on the map. 

 

 
 

 

• Multi-Address Plotting – If users have multiple addresses saved for their entities then users can use 

the feature of Multi-address plotting to plot the records based on multiple addresses at once in the 

same map. This feature enhances the visualization experience of those records that have a presence 

Note: By default, the color and shape of the pushpins will be plotted based on View configuration in the 
Entity map.  



Maplytics™ – User Manual 

 

Page 264 of 386 

   

in multiple cities or states etc. The required addresses once configured within the Entity map can be 

selected and plotted on the map.  

In the Plot Records Card, the user can click on the three ellipse  and then click on the ‘Select 

Address’  button after selecting the Datasource & View and select the multiple addresses based 

on which the records need to be plotted and hit the search button. The respective addresses plotted 

on the map will also be listed in the layer menu which can be toggled to focus on the required data 

on the map.  

 

 
 

 

 

• Search Options – User can choose the search 

options By Location , By Region , or By 

Drawing to plot the data as per their 

requirement.  
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By Location: This search option will be selected by default. The following screenshot shows records of the 

default view My Active Accounts been plotted by location. 

 
 

 

By Region: The below screenshot shows the active account records falling in New York, USA. 

 

 

By Drawing: The below screenshot shows the accounts falling into the drawn shapes.  
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By Template: The user can save the search criteria as a template using the ‘Save Template’ button 

within the Plot Records Card. They can plot the respective saved templates using the ‘By Template’ 

search option. All the Templates saved by the client publicly are available for plotting. 

The following Proximity Search has been plotted for records in Staten Island. This search result can be 

saved as a Template using the Save Template option. 

 

Adding a convenient name it shall be saved for Public access. 
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The same Template or a different one can then be plotted using the ‘By Template’ option in the Plot 

Records Card 

 

 

When the template is plotted from the default search layer, it will appear in the new search layer with 

the default search layer being disabled. It can then be enabled manually from the Layer Menu. When 

the template is plotted in a new Search Layer, it appears in the same layer with the default layer visible 

as is. The below screenshot shows account records within the User’s Proximity plotted using a Template 

‘Sep 23 Visits’. 
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• Plot categorized data- User can also select an attribute for each data sources plotted on the map with 

the option of ‘Select category’ to categorize the data sources based on the selected respective 

attribute. 
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Users can also select the required colors and the shape of the pushpins for the respective category within 

the category card. Once the color or pushpin are selected, it will instantly reflect on the map. 
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• Multiple-Category for single entity - User can also plot a single entity records categorized by 

multiple attributes. For e.g. Account records categorized by Open revenue, Originating lead, 

Owner. The user can choose an entity twice or thrice with two or three different views 

respectively and choose required attributes for the respective views to categorize the same entity 

with different attributes. User can select a maximum of three attributes to categorize a single 

entity. 
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• Tooltip card: While users clicks on any record’s pushpin, the pushpin will be highlighted and the 

tooltip card will open for the respective record. User can view more details of the record on the 

tooltip card. The tooltip card actions buttons will allow the user to perform required actions like 

Show related records, create tasks, create phone calls, follow, etc. on the selected record. The 

screenshot shows the use of the Tooltip card action button ‘Plot related records’ that plots related 

records based on the selected relationships for the respective record.  

All the users of the record can follow/unfollow the record in order to enable/disable viewing of the 

timeline with a note of all the actions performed on the record. 
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• Show Entity Image – If a record has an image saved within, while the user clicks on such record they 

will be able to see the image record on tooltip card. Moreover, the user can also hover on the image 

appearing in the tooltip card to zoom in on the image. User needs to select the ‘Default Image’ field 

in the field of ‘Entity image’ in Entity map to view the record image on hover and tooltip card. Please 

refer to the installation manual.  
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Users can also hover on pushpins plotted on the map to have a quick glance at its details as well as the 

image associated with the record.  
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• Proximity search – User can set any location as the current location from the tooltip card or 

contextual menu with a right-click on any location on map. Once the user sets the current location, 

they can perform Concentric Proximity Search and can look for the Line-of-Sight Distance on the 

hover or the tooltip card for any record plotted within the proximity. The user with a Truck Routing 

license can enable the ‘Drive Time Zone’ option and view the boundaries of regions that lie within 

specific travel time. 
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Drive Time Zone 

Suppose a user is willing to travel within specific regions that lie within a certain travel time, he can 

enable the option of Drive Time Zone and visualize the regions of the records within that travel time. 

The time could be in minutes or hours. 

Suppose a user is willing to travel for an hour, the Drive Time Zone will be visible as follows. 

 

The User can go to Settings> Maplytics Configuration Details> Advance Settings> Enable Drive Time 

Zone and select the check box to enable the option. 



Maplytics™ – User Manual 

 

Page 277 of 386 

   

 

The user can click on Save & Close the changes once the check box is selected and plot and view the 

regions comfortably along with the records. The user can also create new records in this drive zone. 

To be able to enable this option, the user needs to hold the license for Truck Routing which has been 

explained in-depth within the Truck Routing section. 

• POI locations – User can set any location as the POI location from the tooltip card or contextual menu 

with a right-click on any location. Once the user sets the POI location, they can use the POI card and 

view any geo-tagged Bing mapped locations by clicking on the icons available on the POI card or 

entering the keyword for the required location. For example, the below screenshot shows the POI 

locations plotted for Coffee places and Dentist.  
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Route Optimization– User can set any location as the origin, destination or a waypoint from the tooltip 

card or contextual menu by right clicking on a record or anywhere on the map and get the route created 

for the waypoints selected. User will get further options like selecting the unit for the distance, Optimize 

Route based on Shortest Time or Shortest Distance, avoiding highways or toll roads and see Traffic etc. 

within the direction card. Once the route is created, user can use the ‘Save’ button on the Directions 

card to save the route. They can use this button to it to add changes to an existing route or save it as a 

new route with a date and owner assigned. The saved route can later be plotted using the ‘Open Saved 

Route’ option by entering a date or range of date. With the Multiple Routing feature, up to 10 saved 

routes can be visualized on the map at once. The waypoints can be added/deleted and the routes get 

updated accordingly. All the Routes are color-coded in color legends. 

 

 

User can also use the ‘Open Navigation Links’ button on the Direction card to view the turn-by-turn 

directions to navigate themselves for the route on Google Map, Waze App, or Apple Map based on 

the App Set in User Configured Detail record. User can also send the route as an email to any other 

user or clear the route with the options on the Direction card. User can also click on ‘Print Route’ to 

print a Route as well as the adjoining Map.  
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• Layer Menu- User can show/hide the layers of the plotted 

data on the map using the Layer menu to view only the data 

that is required.  
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• Current location- While using Maplytics Detail Map Control on Mobile/Tablet, users can easily plot 

their current GPS location with the help of the ‘Locate me’ button thereby making it easier to 

perform Proximity search and relate the data plotted on the map in terms of their location. 

 

Deactivate- On deactivating a record by selecting the option, all the fields from CRM and on the 

Individual Map for that record get deactivated. 

• Check in/out- Check-In feature enables users to register their arrival and departure time for the 

meetings while navigating on field with the help of Check-In and Check-Out buttons. User can click on 

any record’s pushpin to open the Tooltip card and click on the Check-in button to register the arrival 

to the meeting location and click on the same button that gets converted to the Check-out button and 

register the meeting completion and departure from there. User can further add some notes for the 

respective records and also create pending check-in/out requests if they are outside the default 

radius.  

Once field team has check-in/out for respective meetings, their managers can plot the Check-in entity 

to plot the respective check-in/out records on the map and analyze pushpins are valid and which are 

invalid to track the performance of the field team. They can also plot the pending check-in/out 

requests and approve/reject the same.  
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• Land Area Mapping – Organizations working with lands, real estates or farms etc. can visualize their 

lands/properties on map with this feature. Users will be able to assign land regions to the records and 

visualize them on the map to understand the coverage of area for each of the records using this 

feature.  

Lands can be assigned to the required records as mentioned in the section ‘Land Area Mapping’ in this 

manual. Once the lands are assigned, users can select the entity in Datasource and the respective 

view in the ‘Plot Records’ card in the map to plot the record on the map as pushpins. While visualizing 

records on the map, users can right-click on any pushpin to open the Contextual menu and use the 

‘Show Land Area’ button to plot the land(s) that is assigned to the respective record. The user can also 

see all the lands that have been assigned to all the records that are plotted on the map, using the 

‘Show Land Area’ toggle button on the Layer Menu and show/hide the same. 
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• Multi search layer - While users have so many search options and features to plot data on the map, 

they also have the capability to perform more than one search at a time to plot data on a map. For 
example, if the user needs to view the data with the search of By Region as well as By Drawing together 
on the same map, they will be able to do it with this ability of Multi search.  

In the Detail map control, the records from the respective view will be plotted by default. In the below 
screenshot, the map shows the default view of the Accounts plotted with pushpins in green color. To 

add more searches to the map, user can click on ‘Add New Search’  to select the required search 
option and Data sources for the same.  
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The below screenshot shows that the Search option ‘By Region’ is selected in the New search which 
becomes ‘Search 2’ after clicking on Search button. It is now showing all the records from Alabama, USA 
in purple color. However, as the default view was already plotted in green color pushpins, the records are 
still there as the part of Search 1. Since the views for both of the searches is the same i.e. the default view 
the purple pushpins of Search 2 are overlapping on the green pushpins of Search 1.  

 

 

The number of multiple Searches is visible in Plot 

Records Card. User can also click on the ‘Delete’ to 
delete the respective search layer.  

 

 

 

 

The ‘Layer Menu” will show the layers based on the 
Searches performed. In this screenshot, it is showing the 
Search 1 that contains the default view plotted and the 
Search 2 with the records plotted from Alabama State 
using ‘By region’ option as mentioned above.  User can 
use the toggle buttons to hide/show the Search layers or 
the layers within an individual Search. This will also help 
to view the pushpins that are overlapped by other 
pushpins in case the views selected in two searches are 

the same like in our example above.   
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Users can also use the ability of Multi Search layers to perform Proximity Search at different locations in 
the same map. The below screenshot shows Search 1 where the Proximity search is performed on My 
Active accounts that is the default view here & the All Contacts and Search 2 where the Proximity search 
is performed on My Active Accounts on a different location.  

 
 
While clicking on the circles of the Proximity searches the Summary card information will be shown based 
on the pushpins belonging to the respective Proximity Searches. 

 
 

• Shape Operations 

Using the plot by-drawing feature, two or more shapes can be drawn on the map. The user can then 

perform 3 types of shape operations i.e. Difference, Intersection, and Union on the overlapping shapes. 

The records then get filtered according to the shape operations used. The option can be availed by right-

clicking on the overlapped shapes. 
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Difference- This highlights the shape(s) obtained by subtracting the overlapped ones from the selected 

shape.  

 

Intersection- This highlights the shape(s) where the selected shape and other shapes overlap.  
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Union- This adds all the shapes overlapped on the selected shape 

 

The records plotted within these shapes on performing the operations are visible on the data grid on the 

right.  
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Using the ‘Undo’ option the operation is reverted and all the records from all the drawn shapes become 

visible. Using the option of ‘Reset’, the user can remove all the operations that are performed on the 

shapes drawn on the map 

Advanced Shape Operations 

This enhancement in the shape operations utilizes the Multi-Search feature to perform multiple search 

operations simultaneously. Shape operations are performed on the overlapping shapes plotted in this 

manner.  

 

For instance, a user can perform a proximity search in two different search layers. Once the proximity 

circles and the records within them are plotted, Shape Operations can be performed on them as seen 

above.  
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The filtred records derived using the Shape Operations are visible in the Data Grid. Mass Actions can be 

performed on all of these or a selected few records as required.  

 

Records could be saved for future use, Emails could be sent to them, activities could be created for 

them, or they could be added to a route. 

 

 

• Map mode and labels- Two map modes are available viz. Road and Aerial view. User can also select to 

view the labels of regions on the map.  
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• Data Grid – All the records of the view are listed in the Data Grid. The check box against the records 

can be ticked to utilize the records for operations. 
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In case a particular record needs to be selected, it can be filtered out from all the records of the view by 

adding a suitable keyword  

 

 
 

Hovering over the record image displays the details of the records. These details are configurable 
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Clicking on the record row in the data grid zooms the map view to the area of the pushpin. The pushpin 

blinks a couple of times and rests 

 

 
 

• Lasso Tool- The user can use this tool to select a bunch of records together at once. The records will 

get selected in the data grid and be available to perform multiple activities. 
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• Mass Actions – Mass Actions can be performed on the selected records. They could be added to a 

travel route, the selected data set could be saved, activities could be created for these records, mail 

could be mass sent to them. 
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Add To Route: This option will add selected data points to the route. The user can add at max 25 

data points to the route 

Save Data: The selected records can be saved as static Marketing List or Personal View in Dynamics 

CRM 

Create Activities: User can create activities for non-activity Entity records currently selected in 

“View Data grid.” The user can define the Activity, Subject, Schedule Start date and Schedule end 

Time, Duration, Owner(User/Team) and Priority. The activities selected in respective Entity maps 

can be seen in the list of activities available to create using the button of “Create activities”. By 

clicking this button below window will open and the activities will be created based on the inputs 

given in the window by the user. 

• Send Email: The user can send a mass email to the selected records. User can select any one the 

available email templates or a new email to write their own content. User can also choose to 

keep the recipient as To/Cc/Bcc in the email.  

• Smart Route: The route plotted using the Add To Route button above can be optimized in terms 

of the shortest travel time or distance. The order of the waypoints can be adjusted and the 

route re-routes itself.  
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This optimized smart route can thus be saved with a name, date, and, an owner.  

 
 

Activities such as appointments/tasks can be created for each of the waypoints on the smart 

route using the Create Activities option. In case of Appointments being created, the subject, 

start date and time, end time, duration of each appointment, buffer time in between 

appointments, priority, etc. can be saved, along with the Smart Route.   
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Once saved, the user can have a preview of these appointments with start and end times. 

Activity details can also be edited at this stage if required.  
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The appointments created in this manner are visible in the Activities list under the Activity Name 

provided in the Subject. The start, end date, and time, too, are visible for each. The Smart route 

is visible in the Activities section under the Route Category. 

 

• Favorite Places- Users visit some places more often than the rest. Such places are set as current 

locations, locations of interest very frequently. It is a hassle to plot and search for them every time. 

Thus, ‘Favorite Places’ could be used to ease it. 

 

By default, the menu would be blank and the user will be able to add his favorite places to it.  

Note: Activities will be created only for the selected date 
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This can be done by right-clicking directly on the map or on any record pushpin. The address field is 

populated with the address of the pushpin and cannot be changed.  

 

However, when the favorite place being added is directly from a map location, the address can be 

selected from the auto-suggest list. The place can then be saved in the My Favorite Places list after 

giving it a suitable name.  

The third way to add to the Favorite List is by directly clicking on the ‘+’ sign and filling in the details. 
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Operations on My Favorite Places- A few operations, as follows, can be performed on the records in the 

favorites list. 

 

Plot on Map- Clicking on this option, the favorite place gets plotted on the map. On hovering over it, the 

name and address of the favorite place is visible. The respective layer of favorites also becomes visible. 
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The Plot on Map option changes to Remove from Map in order to remove the favorite record that has 

been plotted. 

Once a favorite pushpin has been plotted on the map, the Layer Menu for Favorite Places will be 

enabled. Once all the favorites have been removed from the map, the Layer Menu for favorites will not 

be visible. 

 

Set As Origin- Clicking on this option, the favorite place gets added as the Origin for a route 

Add To Route- This option adds the favorite place to the route as a waypoint 

Set As Destination- The favorite place shall be added as the destination for a route 

Delete from Favorites- The Favorite Place shall be removed from the list 

Set As Current Location- When a user wants to set a location as Current Location and there are a few 

records already added to the favorites list, these favorites will get auto-suggested for Current Location 

when the user clicks on the space bar. Thus, they can be quickly selected and plotted. 
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Similarly, if the user enters an address in the Current Location and the address is similar to any records 

in the favorites list, it will be prompted on top of the auto-suggest list. 

Set As POI Location- When a user wants to set a location as POI Location and there are a few records 

already added to the favorites list, these favorites will be auto-suggested for POI Location when clicked 

on the space bar. Thus, they can be quickly selected and plotted. 
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Similarly, if the user enters an address in the POI Location and the address is among the favorites list, it 

will be prompted on top. 

 

 

 

• Reset Button- This button resets records as per current search 

Note: Only 20 places can be added as favorites in the Favorite Places List 
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• See More- The current view displays the CRM Records on the current page. To view more records, 

user can click on the See More option at the bottom. 
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• Print Route- User can print a Route as 

well as the adjoining Map. User can plot 

a route on map, and use the button ‘Print 

Route’ to print the route. 

 

Note: There are some limitations to some of the features mentioned above which will be 
available in our future releases. 
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Steps to Add control: To add this control on an entity grid, user can follow the steps mentioned below:  
1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Contact entity for an instance. Within Contacts, go to Controls > Add 

Control > Select Detail Map Control for Dataset > Add 
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2. User can choose to allow the control on Web, Phone or Tablet. Click on Save > Publish.  

 

3. User can open any view of the entity to view this control.  
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Address Autosuggest Control 

Users can add this control on any of the fields with the Data type ‘Single Line of Text’ of the record to get 

auto suggestions of addresses while typing the respective field. User can select the required address and 

get that address auto-filled within the fields.  

 

Steps to Add control: To add the control to a field within a record form, the user can follow the steps 

mentioned below:  

1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Accounts entity for an instance. Within Accounts, go to Forms > Main Form 

> Select any field > Change Properties  

 
 

 

 

 

 

 

Note: The data type of the field on which user needs to add control should be ‘Single Line of Text’. 
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2. Go to Controls > Add Control > Select ‘Maplytics - Address Autosuggest > Add 

 

 

3. While adding the control, user needs to choose the required address fields. While user uses Auto 

suggest control, the respective addresses that are selected here will be auto filled. User can 

choose to allow the control on the Web, Phone, Tablet. Click on ‘OK’ > Save & Publish.  



Maplytics™ – User Manual 

 

Page 308 of 386 

   

 

 

 

4. User can open any record of the entity to view this control added on the field. User needs to enter 

the address and based on the entered keywords, it will provide suggestions for addresses.  

Note: Please uncheck the option of ‘Display label’ within the field properties for better visualization. 
 



Maplytics™ – User Manual 

 

Page 309 of 386 

   

 

User can select the required address and it will get auto filled within the respective address fields. 
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Heat Map 
 
Clicking on the Heat Map command button will bring up the Heat Map Screen.  

  
Select Datasource: 
This option helps the user to choose the Entity and view combination to analyze the data. 
 

Select Measure: 
This helps the user to define the aggregation method to be used to color code the region. By default, it is 
based on number of records (i.e. ‘By Count’). The user can change this to any other field attribute from 
the drop-down. Dropdown contains the list of all numeric and currency fields.  
 

Select Category: 
This option helps the user to filter data. The user can modify the search result using selection in the 
Category option.  
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Select Region Type: 
 

This option helps the user to define the geography level for aggregation. The user can choose any option 
from the drop-down:  

• City 
• State 
• County 
• Country 
• PostalCode: The smallest postcode category, such as a zip code. 
• PostCode Sector: The second ‘1’ is called “Postcode Sector”. Example: CA1 1 
• PostCode(Outward Code): This is called Outward Code, the part of the postcode before the single 

space in the middle. Example: CA1 
• PostalCode Areas: The next largest postcode category after Postcode1 that is created by 

aggregating Postcode1 areas. 
• Territory: This option will use the Sales Territory defined in Dynamics CRM.  

 

 
 

The default option is to summarize the addresses by City. You can find the default settings on the 
Maplytics Configuration record for the individual user as shown below: 

 

Note:  

• The regions that were plotted using the option Post code Areas before will now be plotted by 
using the option of Post code sector.   

• The regions will be plotted as per the Bing maps.  

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FPostcodes_in_the_United_Kingdom%23Overview&data=02%7C01%7Cv-szczup%40microsoft.com%7C65818020a8fc4120be9108d618ac626f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636723526031148736&sdata=uIf6X6f4o349Rg6LSBtVlpIXeqzCk4kDyXjSZjRzWbE%3D&reserved=0


Maplytics™ – User Manual 

 

Page 312 of 386 

   

Select Display 

There are four options available to analyze data on Heat Map. Default Heat map display can be selected 
using Maplytics Configuration Settings.  

Boundary 

This will create Heat Map on basis of selected region type like City, Postal Code, Country, State, Territory, 
etc. 

 
No Boundary 

This option does not consider the region type. It simply creates a Heat Map by the density of the measure 
selected without geographical boundaries.  
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Pie chart 

Users can view the data in the form of Pie charts based on the heat of the attribute selected in the 
Measure and Filter.  Pie charts help the users to analyze the data on the basis of comparative data shown 
by the Pie charts on the map. 

 
Column chart  

Users can view the data in the form of column charts plotted on the basis of the heat of the attribute 
selected in the Measure and Filter. User can easily analyze the plotted data on the basis of the proportions 
shown by the respective columns. 
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o Hover: On hover, it shows the details of that Boundary/Pie chart/Column chart 
o Summary Card: The user can click on any Boundary/Pie chart/Column chart to get the summarized 

information of the same.  

 

 
 

 
 

Note: If Pie chart/Column chart is selected as the Display type, the option of Territory under Region 

Type will not be available. 
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Search: 
Clicking on the ‘Search’ button will plot the addresses of all the records that were selected in the view and 
has already been geocoded. Records that do not have their latitude/longitude updated in the record will 
be ignored and will not be plotted on the map. 
 

Summary card: 
Every time the users create a heat map visualization, a 
‘Summary Card’ summarizing the aggregate 
information for the complete heat map will open up. 
This gives the users a brief summary of the heat map 
they created. The measure is also summarized by 
default. 
  
 
 
 

The user can also click on any region plotted on the 
map to open the summary card for that region. This 
will also filter the data of the region in the data grid. 
To differentiate between the summary cards, the 
individual summary cards have the region 
name/number as the title.  
 

If the user has selected a field attribute in the ‘Filter’ 
dropdown, the summary card will further 
summarize the information for the selected 
category filter as well.  
 

Export to Excel: The search results are listed by the grouping selected at the bottom of the screen and 

user can further export these data points using this button as shown below; 

 
This functionality adhere to CRM security roles, if the user does not have permission to ‘Export Data to 
Excel’ in CRM, then he/she will not be able to export data from Maplytics.  
Zoom Level of Heat Map uses personalized ‘Zoom Level’ setting for the logged in user. Also, the color scale 
for the Measure will be fetched from the defined ‘Heat Map Measure Color Scale’ in the Entity Category 
configuration on the Entity Map for that particular entity.  

Print: Clicking on the print button will print the heat map, as shown in the screenshot below:  
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Note: A4 size paper with landscape mode is recommended while printing. 
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Support for CDS 
If user does not have Dynamics CRM, they can still use Maplytics by subscribing for the PowerApps 

platform. This platform comes packaged with some base entities that includes Accounts and Contacts 

along with other platform entities to provide support for it security and other infrastructure. 

To use Maplytics within PowerApps, user can follow the steps mentioned below: 

A. Go to admin.powerapps.com > log in using PowerApps credentials.  
B. Click on ‘New environment’ > Enter the details > Create an environment  

 

 
• Click on ‘Create database’ > Select the required details > Create database 

   
• Click on ‘Navigate to other Applications’ > All apps > Powerapps > Select required environment 

https://admin.powerapps.com/


Maplytics™ – User Manual 

 

Page 318 of 386 
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Import Maplytics solution  

• Click on solutions at the left navigation pane > Import > Maplytics. This will create the Maplytics App. 
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• To access the Maplytics App, click on Apps at the left navigation pane > Select Maplytics App.  
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Clicking on the Maplytics app, following Maplytics dashboard will open.  

 
o Activate and configure Maplytics  

To access the Maplytics user needs to Activate and Configure Maplytics to start the license 
and configure the basic Entity maps, Dashboards and Census data.  

▪ Go to Settings > License registration > Click on Activate  
▪ Go to Settings > License registration > Click on Configure 

o Add users to Maplytics team   
▪ Go to Settings > Teams > Maplytics team > Add users 

 
 
 
 
 
 
 
 
 
 
 

Note:  
1. Entities of leads, Cases, Opportunity, Invoices are not available in PowerApps 

2. Marketing lists are not available  

3. While configuring, four Entity maps will get created for Accounts, Contacts, Appointments and 

Customer Address 

4. Only three dashboards will get shipped on configuration 
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Access Maplytics in PowerApps  

User can use the credentials of the environment to log in to PowerApps and select the Maplytics app to 
perform Maplytics features. Use the buttons ‘Details Map’ or the ‘Heat Map’ to open the respective maps.  
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Maplytics Dashboard 
The users can define their Dashboard views for Maplytics and include them as web resources in standard 
Dynamics CRM Dashboards. 
 

 
 
Maplytics ships with five pre-defined Dashboards for various Sales and Service Modules for different user 
roles. To set up more dashboards, please refer the ‘Installation Manual’. 
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View Category donuts in dashboard 

Users can view the categorized data in the form of donuts on the respective dashboards.  
 
In the screenshot below, in the first dashboard, the appointments for the team are plotted which have 
been categorized based on the status of the appointments. The donuts are shown based on the 
percentage of the records falling into the each of the categories. For example, 17.50% of the total 
appointments were canceled, 47.50 % of the total appointments are completed and 35 % of the total 
appointments are scheduled. If the user hovers over the donut, they can see the exact count of records 
falling into each of the categories.  
Similarly, the second dashboard shows the heat map for the Accounts based on the annual revenue. The 
donuts show that 18.10% of the total Accounts have Annual revenue ranging from 0 to 5000 and 19.73 % 
of the total Accounts have Annual revenue ranging from 5000 to 10000. 
 

 
 
Hide Donut Panel 
The Donut Panel can be hidden as per the User’s requirement by clicking on the arrow at the extreme 
right of the Panel. The same can be clicked again to expand the hidden panel and put it on display. 
 



Maplytics™ – User Manual 

 

Page 325 of 386 

   

 
 

 
 
 
Filter records on Map using Donuts 
The record pushpins displayed over the Map can be filtered out using the donuts. In the Dashboard below, 
when clicked on the Donut displaying the percentage of ‘Completed’ appointments, the pushpins on the 
map are filtered out to show only those Appointment records that belong to the ‘Completed’ Category. 
The rest belonging to Scheduled and Canceled are hidden. Similarly, when clicked on the ‘Status’ donut, 
the filter will be reset and record pushpins belonging to all categories of Appointments i.e. all 
appointments are displayed.  
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Hovering and Tooltip Card 
When hovered over the record pushpins, the information about the respective record is displayed. The 
information shown here can be configured within the Advanced Settings within the respective dashboard 
record in the Maplytics Settings.  

 
 
If the pushpin is clicked upon, a tool tip card is opened with the details of the respective record. The 
information shown on the Tooltip Card can be configured within the  
‘Tooltip Mapping’ section of the respective dashboard in the Maplytics settings.  



Maplytics™ – User Manual 

 

Page 327 of 386 

   

 
 

Steps to add Maplytics View to Dashboard 

To include the Maplytics component in 
Dashboard, click on the new button and select to 
add Web Resource. Select 
‘ikl_/Maplytics/Maplytics.Dashboard.html’ web 
resource and set the name of the Dashboard 
record in the custom data parameter to be passed 
to the HTML web resource. The recommended 
number of rows in formatting is minimum 10. 
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Create a route dashboard 

To plot route on a CRM dashboard follow the steps mentioned below: 
 

1. User needs to include the Maplytics Detail Map component on the Dashboard. To do this click on 
the ‘New’ button in the section of dashboard and select ‘Add Web Resource’. Select 
‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource.  
 
Go to Sales > Dashboards > Click on “New” button 

 
 

2. Choose any layout as shown below: 

 
 

3. Provide the dashboard name and click on the web resource button to add the Detail map HTML 
web resource.  
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4. Add web resource :‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource  
5. Add a parameter in Custom Parameter (data) field as <Dashboard Name>||dashboard||true 

and click on ‘OK’ 
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6. After saving the dashboard and user can see the route plotted on the dashboard.    
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Only 25 waypoints can be added into the route. 
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Add a template in dashboard 

Users can add a template to a Dashboard to visualize resultant data of pre-set search criteria on the 

dashboard in one glance. 

To do this, user can select the required criteria on the map and save it as a template using ‘Save Template’ 

button. Please refer to the Template section in this manual to know more about saving templates. After 

saving the template, user can add the template to the dashboard.  

Steps to add template to dashboard 

User can create a new Dashboard as explained in above topics and add the web resource 

‘ikl_/Maplytics/Maplytics.DetailMap.html’. They also need to provide the custom parameter (data) 

having template name. For example, the template with the name “Clients around supplier” should be 

entered as – Clients around supplier||template. Click Ok then Save 

 

Once the web resource is added, user can refresh and open the dashboard to view the saved template. 

Moreover, if a user wants they can add multiple templates to a CRM dashboard to view multiple data in 

a single dashboard. 
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Workflows  
Maplytics ship the following workflows: 

1. Geocoding workflows – This geocodes addresses of the records and provides the values for respective 

Latitude and Longitude. 

2. Territory Assignment workflow – This assigns territories to CRM records on the basis of the addresses 

in the respective records.  

3. Driving Instructions workflow – This automatically generates directions (in HTML and Plain text 

format) between two related entity records using their respective addresses.  

4. Get Time zone workflow – This provides the time zone of the respective records in which they lie 

based on their addresses.  

Geocoding workflow is configured for Account, Lead, and Contact entities and Territory workflow for 

Account by default. The user can set up these workflows for custom entities also.  

 

 

Note: To run the workflow, please make sure the Microsoft Dynamics CRM Asynchronous 

Processing service is running as shown in below screenshot.      
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Configure Geocoding workflows for custom entities 
1. Go to Setting > Processes > Click on ‘New’ to design a new Workflow Process. 
2. Write Process name, choose ‘Workflow’ under category section and select desired entity as 

shown below; 

 
 
 
 

3. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields 
change’ options as shown below: 
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4. For the Record fields change option, select all of the address fields to ensure the address is 
geocoded when any of the address fields is changed as shown below; 

 
 

5. Select the Inogic.Maplytics.Geocoding workflow assembly from the Add step menu as shown 
below; 

 

Note: Please don’t select Latitude & Longitude field attribute here.  
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6. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the 
workflow assembly; 

 
7. Choose ‘Update Record’ from ‘Add Step’ menu after selecting ‘Set Properties’ record and select 

same entity for which workflow is being created. 
8. Click on ‘Set Properties’ of the new record and in the update window set the Latitude, Longitude 

and Rating to the output parameters returned by the workflow assembly as shown in the 
screenshot below; 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Note: For custom workflows, add an 'AND' condition, if the address fields are not blank as shown in the 

above screenshot. This will avoid the trigger of the workflow if the address fields do not have any value.  
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Geocoding Confidence Rating: 
User can also check the geocoding confidence rating provided by Bing Maps. A ‘Rating’ field can be added 
that shows the confidence rating as High, Medium or Low. The ‘Rating’ field is set in the workflow as 
shown in the above screenshot. 

  
 

 
 
 

Note:  

• Latitude and Longitude fields should of data type: ‘Floating Point Number’ with precision set to 
5. Add minimum to maximum range of fields respectively Latitude (-90 to +90), Longitude (-180 
to +180). 

• Geocoding Confidence Rating cannot be checked for Geocoding plugin 
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Configure Territory Assignment workflow for custom entities 

 
1. Follow the Steps 1 – 3 from configuring 

geocoding workflow for custom entities. This 
will help you create a new workflow.  

2. For the Record fields change option, select all 
of the address fields to ensure the territory is 
changed when any of the address fields is 
changed as shown below; 
 

 
 
 
 
 
 
 
 
3. Click on ‘Add Steps’ and add ‘AssignTerritoryWorkflow.AssignTerritory’ assembly as shown below; 

 
 

4. Click on ‘Set Properties’ and set the address parameter as shown below and Save this. 

NumberOfRecords – Set the number of records to be fetched from the CRM at once 



Maplytics™ – User Manual 

 

Page 339 of 386 

   

 

 

Configure Get Time Zone workflow 

 
1. Go to Settings > Processes > Click on ‘New’ to design a new Workflow Process. 
2. Write Process name, choose ‘Workflow’ under category section and select desired entity: 
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3. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields change’ 
options. 

 
 
4. For the ‘Record fields Change’ option, select all of 

the address fields to ensure the address is 
retrieved when any of the address fields is 
changed. 
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5. Select the Inogic.Maplytics.GetTimezone workflow assembly from the Add step menu. 

 
 
6. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the 

workflow assembly. 
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Here, user needs to specify the address fields on the basis of which user wants to get the time zone. After 

this user needs to set the time zone in field (string type). Please follow below steps for the same: 

1. Choose ‘Update Record’ from ‘Add Step’ menu after selecting ‘Set Properties’ record and 
select same entity for which workflow is being created. 

2. Click on ‘Set Properties’ of the new record and in the update window set the TimezoneName, 
TimezoneAbbreviation to the output parameters returned by the workflow assembly. 

 
 

Once user finishes all the above steps and activates the workflow, 

user can run it on any record of the respective entity which has 

address data. This will provide set the time zone set for the record 

as shown below. 
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Configure Driving Instructions workflow 
7. Go to Advanced Setting > Processes > Click on ‘New’ to design a new Workflow Process. 
8. Write Process name, choose ‘Workflow’ under the category section and select desired entity, and click 

on Okay as shown below; 

 
9. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields change’ 

options Click on Okay and Proceed; 
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10. For the ‘Record fields Change’ option, 
select all of the address fields to ensure the 
address is retrieved when any of the 
address fields are changed as shown 
below; 
 

 
 
 
 
 
 
 
 
 
 
 
11. Select the Inogic.Maplytics.DrivingInstructions workflow assembly from the Add step menu as shown 

below; 
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12. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the workflow 
assembly; 

 

 
In ‘FromAddress’: Select the address fields of the entity that you want the direction ‘From’. Select 
the all address field i.e. Steet1, Street2, and City etc. and ensure sure you keep space between 
two fields. 
{Address 1: Street 1(Account)}   {Address 1: Street 2(Account)}  {Address 1: City(Account)}  {Address 

1: State/Province(Account)}         
 

In ToAddress: Select the address fields of the entity that you want the directions ‘To’. Select the 
all address field i.e. Steet1, Street2, and City etc. and ensure to keep space between two fields. 

 
Travel Mode: Select the Travel mode. For example (Driving, Walking, Transit, and Truck). If you 
do not specify the Travel mode then it will take Driving mode by default. 

 
Distance Unit: Select the Distance unit. For example (Mile or mi, Kilometer or km). If you do not 

specify the unit then it will take Kilometer as default unit. 

 

13. For the ”OptimizeBy” field, input any one of the values mentioned below: 

distance: The route is calculated to minimize the distance. Traffic information is not used. 

time: The route is calculated to minimize the time. Traffic information is not used. 

timeWithTraffic: The route is calculated to minimize the time and uses current traffic information. 

timeAvoidClosure: The route is calculated to minimize the time and avoid road closures. Traffic 

information is not used in the calculation. 



Maplytics™ – User Manual 

 

Page 346 of 386 

   

 

 

 

 

 

 

 

 

 

 

 

 

Note:  

• If you are not passing any values on “OptimizeBy”, then you will get results on distance 
optimization. 



Maplytics™ – User Manual 

 

Page 347 of 386 

   

14. Click on add step -> Send Email -> Click on set property 

Click on Email body -> Select Look for -> local value “inogic.Maplytics.DrivingInstructions. 
DrivingInstruction” 

Select DrivingInstruction for plan text or DrivingInstructionHTML for html page. Click on save and 

close. 
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15. The driving instructions will be returned both in HTML and Plain Text format as an output parameter 
to this workflow. User can use either of them. For example we have used HTML formatted direction 
instruction in Email here.  

 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

16. Also, we have included four outputs to get the Travel Time & Travel Distance with/without unit 

values. 

For example, create four columns in the Account entity as mentioned below, 

Column 1: Travel Time (datatype should be decimal or floating point) 

Column 2: Travel Distance (datatype should be decimal or floating point) 

Column 3: Travel Time with Text (datatype should be a single line of text) 

Column 4: Travel Distance with Text (datatype should be a single line of text) 

 

Click on Add step -> Update Record -> Select Entity (that you want to set Time & distance value for) -> 

Click on Set Property ->  

Click on the field that you have created -> Select Look for -> local value 

“inogic.Maplytics.DrivingInstructions. DrivingInstruction”  

Select the TravelTime & TravelDistance output 
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 - It will give you the result in decimal or floating point without unit values (only numbers) 

Select the TravelTimeWithText & TravelDistanceWithText output 

 - It will give you the result in text with unit values(miles/hours) 
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Maplytics Batch Processing Tool  
The workflows for Geocoding and Territory Assignment designed can be used on a day-to-day basis for 
addresses that are changed or added occasionally. However, for bulk geocoding/territory assignment on 
data, we recommend using the Batch Processing tool. This tool ensures that the bulk geocoding on records 
is handled in single batch. While in the territory assignment, this tool helps to assign the respective 
territories to all the selected records based on their Latitude and Longitude values. 
 

 
 
 
To run the tool, Extract the Batch 
Processing tool .zip file and run the 
BatchProcessingTool application. 
 
 
 
 
 
 

Executing Batch Processing Tool 
 
Connection Details: 
Please enter the CRM details on this screen. The users have to enter the following details: 

Deployment Type: The user can select either of the options given in below screenshot depending 
on their deployment. 
Office365 
Show Advanced: The user can select the Online Region and proceed to enter the ‘Username’ and 
the ‘Password’ 
Organization: The organization list will be auto-populated with the organizations available in CRM 
on selecting the checkbox. Select the organization for which Maplytics is to be or already has been 
installed. 
Username: Username of a valid CRM user. For example: mollyc@mollyc.onmicrosoft.com 
Password: Password of CRM user 
 
 
On-premises 
Server: Please enter the server url of CRM. For example, http://<servername>:<port> or 
https://<orgname>.crm.dynamics.com 
Organization:  
When the user enters the server URL  in case of On-Premises deployment model, the organization 
list will be auto-populated with the organizations available in CRM on selecting the checkbox. 
Select the organization for which Maplytics is to be or already has been installed. 
Username: Username of a valid CRM user. For example: mollyc@mollyc.onmicrosoft.com 
Password: Password of CRM user 

Note: To run this tool, the user needs to make sure that machine has Microsoft .net framework 4.0 

and Maplytics installed in Dynamics CRM.  

mailto:mollyc@mollyc.onmicrosoft.com
mailto:mollyc@mollyc.onmicrosoft.com
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Make A Selection: Here, the user can make selection whether they would like to run this tool for 
Geocoding (Batch Geocode) or Territory Assignment. The third option is available for installing/ 
uninstalling Territory Distribution Windows Service. In this example, we have chosen Batch Geocode as 
shown below: 
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Choose Entity and Filtering: 
Please find the details of the same below: 

• Entity: Select the entities on which the user would like to run this tool.  

• Views: Once the user selects the entity, all the views defined for this entity are populated in the list 
of views. Select the required view.  
 

The plus sign can be clicked upon to add more entities and views. The check box at the bottom allows the 
records to be shared with the user, if required.  
 
Non-Geo coded Records have a separate view ‘Non Geocode’ for Batch Geocoding for all the Entities. All 
the non-geo coded records of multiple entities can be processed together. 
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Users can enter the email address, if the they would like the job results to be mailed to them.  
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The user can go back to the previous stage while in the ‘Make A Selection’ and ‘ Choose Entity And 
Filtering’ stages of the process. Returning from Processing and Result stage is not possible. 
 
Processing : 
In this section, the user can see the progress of the geocoding process. User can quit the process 
anytime by clicking on the option at the bottom. 
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Note: The Batch Processing Tool takes time to process based on the number of records selected. 

Please do not close the window until this process is completed. 
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Record Summary:  
 
Geocoding:  
Bing Status: This shows the number of the records for which the geocoding from Bing maps was a success 
or a failure.  
CRM Status: This shows the number of the records for which the updation of geocordinates (Latitude & 
Longitude) to the respective CRM records was a succes or a failure. 
 
After completing the geocoding process, the user can download the results. The results will be 
downloaded in Excel format. User can check the columns of CRMDescription and BingDescription in the 
result to check the reason for failure of processes on the records.    
 
With the options at the bottom, the user can return home, download the result in an Excel format, or exit 
the process. 
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Territory assignment:  
CRM Status: This shows the number of the records for which the updation of Territories  for the respective 
CRM records was a success or failure. 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

Note:  

1. The Non Geocode records can be processed in a separate view for all the Entities 
2. Non Geocode View is not applicable for Territory Assignment while running the Batch 

processing tool  
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Territory Assignment Rule 

Users can use this feature to create rules for assigning territories or owner to the CRM records 
as per the requirement. With creating a rule user can set some conditions based on which the 
territories or the owners will be assigned to only those records which satisfy the conditions 
provided.  

Enable Territory Assignment Rule 

To enable the Territory Assignment Rule, go to Maplytics App > Settings> Map Configuration 
Details > Default Configuration Detail record (the one with no user)> Advance Settings > Enable 
Territory Assignment Rule and select the checkbox to enable using the feature. The feature will 
be disabled by default.  
 

 
           
Once this feature is enabled, they will be able to see a new tab of Territory Assignment Rule in 

the Entity Maps. For an instance, the screenshot below shows the Entity map of Accounts. 
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Creating Territory Assignment Rule 

To create a new rule, click on New. The user will be able to see the window for a New Rule.  

General 

In the ‘General’ tab, user can enter the name for the rule and select the entity for which the rule is being 

created. 

 

Assignment query  

Here, the user can find the various options as explained below to set the conditions required within the 

rule: 
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Assign Owner: Select the user who should be assigned as the owner to the records.  

Assign Territory: Select territory which should be assigned to the records. If users want to assign only the 

owner to the records, they can leave this blank. 

Location Agnostic: This option will be visible only when a territory is selected in the Assign Territory 

field. It will be deselected by default and will have an effect on the assignment of the territories and 

owners as explained below.  

• Not selected - If the option of Location agnostic is not selected, the selected territory and the 

owner will be assigned to only those records which satisfy the query and also lie within that 

selected territory based on the respective latitude or longitude values of the records. For example, 

a territory for Staten Island has been selected and the condition in the query says, Accounts with 

Annual revenue greater than 100K USD, then Staten Island territory and the selected owner will 

be assigned to only those records which have annual revenue greater than 100K as well as they 

lie within Staten Island based on the latitude and longitude values of the records. 

• Selected: If the option of Location agnostic is selected, then the selected territory and the owner 

will be assigned to all the records from the selected view that satisfy the query irrespective of the 

latitude and longitude values of the records. For example, a territory for Staten Island has been 

selected and the condition in the query says, Accounts with Annual revenue greater than 100K 

USD, then Staten Island territory and the selected owner will be assigned to all the Accounts from 

the selected view which have annual revenue greater than 100K, even if they lie outside the Staten 

island based on the latitude and longitude values of the records. 

Query Mode: There are two Query Modes:  

• Simple: If query mode is selected as Simple then it will show all the system views. User can select 

a System view to consider the respective records. 
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• Advanced: If query mode is selected as Advanced, the user can put the required Fetch xml in the 

field as shown in the below screenshot.  

 

 
 

To create a Fetch XML query, go to Advanced find > Select the entity and the required 

filters > Download Fetch XML 
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Priority: If multiple Territory Assignment Rules are created and while assigning territories a record satisfies 

more than one rules then this field will decide the priority of the rules to be run and assigned among the 

list of rules. Where 1 is the highest priority and the priority keeps decreasing as we go to a higher number. 

Let’s say three Territory Assignment rules are created with the priorities given as 1, 2 and 3. While 

assigning territories, if a record satisfies all the three rules, then first, it will check the priority of those 

three rules and 1 being the highest priority, the respective territory and the owner will be assigned to the 

record as per the Territory assignment rule with Priority 1.  
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Override Existing Territory 
 
The Maplytics admin or the System admin can use this feature for the respective entities to decide 
whether the existing territory(ies) will be overwritten or not while assigning territories to the records.  
 
To use this, first create a field with data type ‘Boolean’ on required entity form for Override territory. Here 
users can set it to be ‘Yes’ or ‘No’. By default, this field has already been created for Accounts, which can 
be added to the form. This option will be set as null by default.  
 
Once the field is added to the required entity, Maplytics admin or System admin can go to Maplytics App 
> Settings > Entity map > Open entity map for required entity > Attribute Mappings > Override Territory 
> Select the field that was added on the entity form. 

 
Based on the value of the ‘Override territory’ field in the record, it will be decided whether the existing 
territory(ies) will be overwritten or not while assigning territories to the respective records.  

• If the Override territory field is set as ‘Yes’ then while assigning territories, if there are any 
territory(ies) already assigned to the respective records, then those will be overwritten and 
replaced by the new territory(ies) that are being assigned. 

• If the Override territory field is set as ‘No’, then while assigning territories, if there are any 
territory(ies) already assigned to the respective records, then those will remain as it is and no new 
territories will be assigned. 

• If Override territory field is set as ‘No’, then while assigning territories, if there is no territory is 
assigned to the respective records, then it will assign the new territory(ies). 
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Maplytics – Tablet / Mobile 
For Dynamics 365 v9.x, Maplytics can be accessed from mobile and tablets as well. Users can use the 
Dynamics 365 App for Phones and Tablets, Dynamics 365 Sales App or Dynamics 365 field service app to 
Access Maplytics into Mobiles and Tablets. Users can use the ‘Detail Map’ , ‘Heat Map’ and ‘Map’ buttons 
and the dashboards to access Maplytics into their devices.  
 
 
 
Clicking on the ‘More’ option within the Entity Menu slides up the following options. 

 

                 

A click on the Maplytics menu above opens a modal window with an option for Detail Map and Heat 

Map 

Mobile Tablet 
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Maplytics™ – User Manual 

 

Page 367 of 386 

   

                     

Within an individual account entity, a click on the Maplytics menu opens a modal window with an option 

for Map and Check-in 
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Detail Map  

The Detail map consists of the following components. There are five ways to plot the data on Map, similar 

to the Detail Map on desktop: 

• By Location 

• By Region 

• By Drawing 

• By Territory 

• By Template 
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Proximity 

Enter the radius for the proximity search. The Proximity can be provided in either Miles or Kilometers.  
 

     
    
 
 

Concentric Proximity Search 
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Category Filter 

 
User can categorize the data on the basis of an attribute of the Entity  
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Current Location 

This is used in combination with Proximity to specify the center point for the proximity search. By default, 
this field displays the address stored in the Maplytics Personalized record of the logged in user. 
 

Set GPS Location as the current location 

The user can also locate the GPS location of phone/tablet devices using  button.  
 

     
     
 
GPS location is represented by ‘Blue’ circle on the map. It will automatically update the user’s current 
location, making it easier to perform proximity (Near-Me) searches.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Please ensure the following points for the GPS functionality to work: 

• Provide ‘Location’ permission to Dynamics 365 App in phone / tablet device 

• GPS location is turned ON of respective devices 

• ‘User Content and Location’ is tuned ON in Dynamics 365 App 



Maplytics™ – User Manual 

 

Page 373 of 386 

   

Tooltip Card 

Every Pushpin will display the record name, address, as well as the contextual data defined in the tooltip 
section of the Maplytics Configuration when double clicked on the record. The user can open the record, 
check-in/out and perform other actions using the available quick actions button. 
 

     
      

Contextual Menu 

To get a contextual menu on the map, long press anywhere on the map. Pushpin Contextual menu 
provides the following additional options. These option provides commonly used features in Maplytics 
like Set as Current Location, Origin, and Adding to Route, etc. 
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Set As Origin:  
Selecting this option will set the address of the pushpin as the start location of the route. 
 

Set As Destination:  
Selecting this option will set the address of the pushpin as the end location of the route. 
 

Add to Route:  
This option will set the address of the pushpin as a middle waypoint of the selected route. For example, if 
the users already have Point A and Point B selected as their route, and click on the Add To Route option, 
then the Point B will become Point C, and the address of the selected pushpin will become the Point B of 
their route. 
 

Set As Current Location:  
This option is used to set the address of the pushpin as the current location, which can be used for 
proximity search. For example, if the user wants to plot all the leads that are within a radius of 100 miles 
from a particular record then the user can click on the Set As Current Location option to set the address 
as the current location and then the user can plot the records around this location. 
This option also removes the additional step to type the current location manually for the proximity 
search. 
 
Set As POI Location:  
This option helps the user to set the center point for the Point of Interest (POI) searches like ATMs, 
restaurants, Airports, etc. Once this location is set as the POI location, the user can search for different 
POI around this location. User can choose the icons or the locations from the list of ‘others’ or enter a 
keyword to search for the respective POI locations on the map. 
 

                
 
 

 

Save Template:  
User can save the plotted search criteria as a template, so as to open the template directly instead of 
searching on  the map again. 
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Search Record 

 
After plotting of records, particular record can be searched by typing the primary attribute and getting 
prompts for records. 
 
 

  
 
 
The selected record gets highlighted and zoomed. The zoom level gets set accordingly. 
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Data Grid 

 
The plotted records are visible in the Data Grid at the bottom of the screen. They could be filtered out 
by adding appropriate keywords in the ‘Filter by keyword’ bar. Mass Actions can be performed on the 
selected records in the grid. 
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Routing – Tablet / Mobile  

 
Another essential feature of Maplytics is Routing across multiple waypoints. Using the Contextual Menu 
options explained above, the users can add multiple waypoints to their journey. At given point in time, 
the users can add maximum 25 waypoints in direction.  
 

  

 

     

    
 
Once multiple waypoints have been added, click on Go button to bring up the Routing Screen shown 
below.  
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Unified View for Route and Records 

When the user plots the data and then creates a route, both the plotted data and the route will stay on 
the map. This makes it easy for the user to add more waypoints to the route without switching between 
Plot and Directions card. The route can be cleared using the ‘Clear Route’ button. 

 

     
    
 

Save Route and Plot Saved Routes 

Users can now save the route from the Dynamics 365 App for Phones and Tablets and later use the ‘Open 
Saved Route’ feature to plot the saved routes. 
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Along the Route Search 

The user can also search the along the route records the same way as on the Browser. 
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Route Redirect and Copy Navigation Links 

 
Redirect with Google Maps 
 

     
     
 
 
Redirect with Waze 

 
 

 

     
 
Redirect with Apple Maps 
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Heat Map – Tablet / Mobile 

 
For Dynamics 365 v9.x, Maplytics can also from the Entity homepage and entity form using ‘Heat Map’. 
When clicked on Heat Map button, it opens the heat map.  

 

     
 
 

Summary card 
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Pie chart in Heat Map 
  

      

 

Column chart in Heat Map 
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Dashboards – Tablet / Mobile 

The users can define their Dashboard views for Maplytics and include them as web resources in standard 
Dynamics CRM Dashboards. Maplytics ships with 6 pre-defined Dashboards for various Sales and Service 
Modules for different user roles. 
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Contact Us 
M/S. INOGIC TECH (INDIA) PVT. LTD.  
A-301 Everest Nivara InfoTech Park, 
MIDC, Turbhe, Navi Mumbai - 400 705 - INDIA. 
 
E-mail: crm@inogic.com  
Twitter: @Maplytics; @Inogic 
Facebook: @Maplytics; @Inogic 
Website: http://www.maplytics.com/ ; http://www.inogic.com/ 
Online Help File: www.docs.maplytics.com 
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